
VIJAYABHERI

MALAPPURAM DISTRICT PANCHAYATH 
EDUCATIONAL PROJECT 2021-22

STEP-UP

കമ്പ്യൂട്ടർ ആപ്ലിക്കേഷൻസ്
(ഹ്യൂമാനിറ്റീസ്)

CLASS - XI

 (Supporting Material for Higher secondary)

Join Telegram Channel: https://t.me/hsslive Downloaded from www.Hsslive.in ®



ആമുഖം

വിദ്യാഭ്യാസപരമായി ഏറ്റവും പുറകില്‍ നിന്നിരുന്ന മലപ്പുറം ജില്ല കഴിഞ്ഞ കുറച്ചു വർഷങ്ങള്‍

കൊണ്ടുണ്ടാക്കിയ നേട്ടങ്ങള്‍ അഭൂതപൂർവമാണ്. എസ്. എസ്. എല്‍. സി, പ്ലസ്ടു,  വി. എച്്ച. എസ് . ഇ

ഫലത്തിന്റെ  കാര്യത്തില്‍  മാത്രമല്ല  എ  പ്ലസ്്സ  ലഭിച്ച  വിദ്യാർത്ഥികളുടെ  എണ്ണത്തിലും  വിവിധ

മത്സരപരീക്ഷകളിലും നമ്മള്‍ ഏറെ മുന്നേറി. പൊതുവിദ്യാഭ്യാസ സംരക്ഷണത്തിന്റെ കാര്യത്തില്‍ മറ്റു

ജില്ലകള്‍ക്ക്  നമ്മള്‍മാതൃകയാണ്.  മലപ്പുറം  ജില്ലാ  പഞ്ചായത്ത്  ആവിഷ്‍കരിച്ചു  നടപ്പിലാക്കി

കൊണ്ടിരിക്കുന്ന  വിജയഭേരി  വിദ്യാഭ്യാസ  പദ്ധതി,  തദ്ദേശ  സ്വയംഭരണ  സ്ഥാപനങ്ങളുടെ

ഇടപെടലുകള്‍,  ജനപ്രതിനിധികള്‍,  എസ് .  എസ് .  കെ,  ഡയറ്്റ,  വിദ്യാഭ്യാസ ഓഫീസർമാർ ഒപ്പം എല്ലാ

നല്ല പ്രവർത്തനങ്ങള്‍ക്കും കൂടെ നില്‍ക്കുന്ന അധ്യാപകർ എന്നിവരാണ് ഈ നേട്ടങ്ങള്‍ക്കു പിന്നില്‍. 

നേട്ടങ്ങള്‍  ആഘോഷിക്കുന്നതിനോടൊപ്പം  അടിയന്തിര  ശ്രദ്ധ  പതിയേണ്ടുന്ന  മേഖലകള്‍

ഇനിയും ഏറെയുണ്്ട. 10 - ാം ക്ലാസ്സില്‍ നിന്നും വിജയം നേടി പ്ലസ്്സ 1,  വി. എച്്ച. എസ് . ഇ ക്ലാസ്സുകളില്‍

എത്തുന്ന  വിദ്യാർത്ഥികളില്‍  നല്ലൊരു  ശതമാനം  വിദ്യാർത്ഥികള്‍  ഹയർ  സെക്കണ്ടറി  സിലബസ്

പിന്തുടരുന്നതിന്  ഏറെ  പ്രയാസം  അനുഭവിക്കുന്നവരാണ്.  കോവിഡ്  കാരണം  സ്‍കൂള്‍‍ പ്രവർത്തി

ദിനങ്ങള്‍  നഷ്‍ടപ്പെട്ടതോടെ  ഭൂരിപക്ഷം  വിദ്യാർത്ഥികളും  പഠന  പ്രയാസങ്ങള്‍  അനുഭവിക്കുന്നു.

ഈയൊരു  പശ്ചാത്തലത്തില്‍  പ്ലസ്ടു,  വി.  എച്്ച.  എസ്  .  ഇ   തലത്തില്‍  വിവിധ  വിഷയങ്ങള്‍

അനായാസകരമായി  പഠിക്കുന്നതിനും  എല്ലാ  വിദ്യാ‍ത്ഥികളും  പ്ലസ്ടു,  വി  .  എച്്ച  .  എസ്  .  ഇ

പരീക്ഷകളില്‍ മികച്ച വിജയം ഉറപ്പു വരുത്തുന്നതിനായി    സ്റ്റെപ്്പ - അപ്്പ 22 എന്ന പേരില്‍ പ്രത്യേക

മെറ്റീരിയല്‍  വിജയഭേരി  പദ്ധതിയുടെ  ഭാഗമായി  തയ്യാറാക്കി  സ്‍കൂളുകളിലെത്തിക്കുകയാണ്.

തീർച്ചയായും  ഈ മെറ്റീരിയല്‍ അധ്യാപകർക്കും വിദ്യാർത്ഥികള്‍ക്കും ഏറെ സഹായകരമാകുമെന്ന്

പ്രതീക്ഷിക്കുന്നു. 

ഈ പഠനസഹായി സമയബന്ധിതമായി പൂർത്തീകരിക്കുന്നതിന് നേതൃത്വം നല്‍കിയ മലപ്പുറം

ഡയറ്്റ,  ഹയർ  സെക്കണ്ടറി  ജില്ലാ  കോർഡിനേറ്റർ  /  അസിസ്റ്റന്റ ്   കോർഡിനേറ്റർ,  ശില്പശാലയില്‍

പങ്കെടുത്ത അധ്യാപകർ എന്നിവർക്കുള്ള നന്ദിയും കടപ്പാടും പ്രത്യേകം അറിയിക്കുന്നു.

സ്‍കൂള്‍തലത്തില്‍  അനുയോജ്യമായ  സമയം  കണ്ടെത്തി  രക്ഷിതാക്കളുടെ  സഹകര

ണത്തോടെ  ഈ  പഠനപ്രവർത്തനങ്ങള്‍  വിദ്യാർത്ഥികള്‍ക്ക്  നല്‍കണം.  അതിനായി  എല്ലാ

അധ്യാപകരുടെയും സഹകരണം പ്രതീക്ഷിക്കുന്നു. 

     പ്രസിഡണ്്ട             ചെയർപേഴ്‍സണ്‍         അസി: ഡയറക്ടർ       ആർ.ഡി.ഡി      പ്രിന്‍സിപ്പാള്‍ 

ജില്ലാ പഞ്ചായത്ത്    ആരോഗ്യ വിദ്യാഭ്യാസ      വി..എച്്ച. എസ് .ഇ           മലപ്പുറം             ഡയറ്്റ

       മലപ്പുറം                 സ്ഥിരം സമിതി                  മലപ്പുറം                                            മലപ്പുറം
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 അധ്യായം 1 
  കമ്പ്യൂട്ടറിലെ അടിസ്ഥാനഘടകങ്ങൾ

  ഡാറ്റയും വിവരവും ( Data and Information )
അക്കങ്ങൾ, വാക്കുകൾ,      തുക മുതലായഅസംസ്കൃത വസ്തുതകളെയും കണക്കുകളെയും ഡാറ്റ

 എന്ന് പറയുന്നു.
ഉദാ: - സുരേഷ്, 17, 12

      അർഥപൂർണമായതും പ്രോസസ് ചെയ്യപ്പെട്ടതുമായ ഡാറ്റയുടെ രൂപമാണ് വിവരം ( Information ) .
ഉദാ: -
പേര് പ്രായം ക്ലാസ്സ്

സുരേഷ് 17 12
   ഡാറ്റയും വിവരവും തമ്മിലുള്ള താരതമ്യം(Comparison between Data & Information)

 ഡാറ്റ (Data)  വിവരം ( Information)

  അസംസ്കൃത വസ്തുതകളും കണക്കുകളും   പ്രോസസ് ചെയ്തഡാറ്റ

  അസംസ്കൃത വസ്തുവിന് സമാനം   പൂർത്തിയായ ഉൽപ്പന്നത്തിന് സമാനം

  നേരിട്ട് ഉപയോഗിക്കാൻ കഴിയില്ല   തീരുമാനങ്ങൾഎടുക്കാൻസഹായിക്കുന്നു

 കൃത്യവും വ്യക്തവുമല്ല  വ്യക്തവും അർത്ഥപൂർണ്ണവും

 ഡാറ്റാ പ്രോസസ്സിംഗ് (Data Processing)
      ഡാറ്റ പ്രോസസ്സിംഗ് എന്നത് വിവരങ്ങൾസൃഷ്ടിക്കുന്നതിനായി ഡാറ്റയിൽ നടത്തിയ

 പ്രവർത്തനങ്ങളെസൂചിപ്പിക്കുന്നു.
   ഡാറ്റ പ്രോസസ്സിംഗിലെ വിവിധഘട്ടങ്ങൾ

1.ഡാറ്റാശേഖരണം –   സോഴ്സ് ഡോക്യുമെന്റ്
   തയ്യാറാക്കലും വിവരശേഖരണവുമാണ് ഇതിലെ

പ്രവർത്തനങ്ങൾ.
2. ഇൻപുട്ട് –   പ്രോസസ്സിംഗിനായി കമ്പ്യൂട്ടറിലേക്ക്

 ഡാറ്റ നൽകുന്നു..
3.സംഭരണം –    ഇൻപുട്ട് ഡാറ്റയും പ്രോസസ്സ്

    ചെയ്തതിന് ശേഷമുള്ള വിവരങ്ങളും കമ്പ്യൂട്ടറിൽ
സൂക്ഷിക്കുന്നു.
4. പ്രോസസിംഗ് – കണക്കുകൂട്ടൽ, വർഗ്ഗീകരണം, 
താരതമ്യം, തരംതിരിക്കൽ, ഫിൽട്ടറിംഗ്, 

    സംഗ്രഹിക്കൽ തുടങ്ങിയ പ്രവർത്തനങ്ങൾഈ
 ഘട്ടത്തിൽ നടത്തുന്നു.

5. ഔട്ട്പുട്ട് –    പ്രോസസ്സിംഗിന് ശേഷം ലഭിക്കുന്ന
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   വിവരങ്ങൾഈഘട്ടത്തിൽ ലഭ്യമാകും.
6.  വിവരത്തിൻ്റെ വിതരണം –   ഔട്ട്പുട്ട് വിവരങ്ങൾ

  ഗുണഭോക്താക്കൾക്ക് വിതരണം ചെയ്യുന്നു.
  കമ്പ്യൂട്ടറിന്റെ പ്രവർത്തനഘടകങ്ങൾ ( Functional units of a computer )

 ഇൻപുട്ട് യൂണിറ്റ്,    സെൻട്രൽ പ്രോസസിംഗ് യൂണിറ്റ് ( CPU ),  സ്റ്റോറേജ് യൂണിറ്റ്,  ഔട്ട്പുട്ട് യൂണിറ്റ്.
                     

1.  ഇൻപുട്ട് യൂണിറ്റ്
    •    പ്രോസസ്സിംഗിനുള്ള നിർദ്ദേശങ്ങളും ഡാറ്റയും സ്വീകരിക്കുന്നു.
    •         ഈഡാറ്റയും നിർദ്ദേശങ്ങളും കമ്പ്യൂട്ടറിന് സ്വീകാര്യമായ ഒരു ഫോമിലേക്ക് പരിവർത്തനം ചെയ്യുന്നു.
    •       പരിവർത്തനം ചെയ്ത നിർദ്ദേശങ്ങളും ഡാറ്റയും പ്രോസസ്സിംഗിനായി കമ്പ്യൂട്ടറിലേക്ക് നൽകുന്നു.
    • ഉദാ: - കീബോർഡ്,  മൗസ്   
2.  സെൻട്രൽ പ്രോസസിംഗ്  യൂണിറ്റ് ( CPU )

സി.പി.യു.  കമ്പ്യൂട്ടറിന്റെ തലച്ചോറാണ്.    എല്ലാ പ്രധാന കണക്കുകൂട്ടലുകളും താരതമ്യങ്ങളും
 നടത്തുന്നത് സി.പി.യു.വിലാണ്.

     സിപിയുവിന്റെ പ്രവർത്തനങ്ങൾ മൂന്ന് ഘടകങ്ങളാണ് നിർവ്വഹിക്കുന്നത് :
( i )    അരിത്‌മെറ്റിക്‌ലോജിക് യൂണിറ്റ് ( ALU ):   ഇത് എല്ലാ ഗണിത,   ലോജിക്കൽ പ്രവർത്തനങ്ങളും

                 നടത്തുന്നു.
( ii )   കൺട്രോൾ യൂണിറ്റ് ( CU ):     ഇത് കമ്പ്യൂട്ടറിന്റെ മറ്റെല്ലാ ഘടകങ്ങളെയും നിയന്ത്രിക്കുകയും

                   ഏകോപിപ്പിക്കുകയും ചെയ്യുന്നു.
( iii ) രജിസ്റ്ററുകൾ‌:  ഇവസി.പി.യു.   വിനുള്ളിലെ താൽ‌ക്കാലിക മെമ്മറികളാണ്.

3.  സ്റ്റോറേജ്
 ഡാറ്റയും നിർദ്ദേശങ്ങളും,  ഇടക്കാല ഫലങ്ങളും,   അന്തിമ ഫലങ്ങളും സൂക്ഷിക്കുന്നു.
    സ്റ്റോറേജ് യൂണിറ്റിൽ രണ്ട് തരം ഉൾപ്പെടുന്നു  : -  

       (i)   പ്രാഥമിക സംഭരണം (  പ്രധാന മെമ്മറി) : RAM (   റാൻഡംആക്സസ് മെമ്മറി), ROM (  റീഡ്
 ഒൺലി മെമ്മറി)  എന്നിങ്ങനെ തിരിച്ചിരിക്കുന്നു.      കമ്പ്യൂട്ടർ പ്രവർത്തിക്കുന്നസമയത്ത് റാമിൽ ഡാറ്റയും

 നിർദ്ദേശങ്ങളും അടങ്ങിയിരിക്കുന്നു.      കമ്പ്യൂട്ടറിന്റെ സ്റ്റാർട്ട് അപ്പ് നടപടിക്രമത്തിനുള്ള നിർദ്ദേശങ്ങൾ
 റോമിൽഅടങ്ങിയിരിക്കുന്നു.

(ii)   ദ്വിതീയ സംഭരണം (  ഓക്സിലറി സ്റ്റോറേജ്) :     സ്ഥിരമായസംഭരണവും വലിയ സംഭരണ  ശേഷിയും
ഉണ്ട്. ഉദാ:  ഹാർഡ് ഡിസ്ക്, CD, DVD തുടങ്ങിയവ.

4.  ഔട്ട്പുട്ട് യൂണിറ്റ്
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• CPU      നിർമ്മിക്കുന്നഫലങ്ങൾ കോഡ് ചെയ്ത രൂപത്തിൽസ്വീകരിക്കുന്നു.
    •        ഈകോഡുചെയ്ത ഫലങ്ങൾ മനുഷ്യർക്ക് വായിക്കാവുന്നരൂപത്തിലേക്ക് പരിവർത്തനം ചെയ്യുന്നു.
           •    ഫലങ്ങൾ പുറം ലോകത്തിന് നൽകുന്നു.
           • ഉദാ:- മോണിറ്റർ,  പ്രിന്റർഫലങ്ങൾ

 കമ്പ്യൂട്ടർ ( Computer )
      നൽകുന്ന നിർദേശങ്ങൾക്കനുസരിച്ച് ഡാറ്റ സ്വീകരിക്കുകയും പ്രോസസ്സ് ചെയ്ത്  ഔട്ട്പുട്ട്  പ്രദർശിപ്പിക്കുകയും

     ചെയ്യുന്ന വേഗതയേറിയ ഒരു ഇലക്ട്രോണിക് ഉപകരണമാണ് കമ്പ്യൂട്ടർ.
  കമ്പ്യൂട്ടറുകളുടെ സവിശേഷതകൾ ( Characteristics of Computers )

മേന്മകൾ പരിമിതികൾ

*  വേഗത -    ഒരു കമ്പ്യൂട്ടറിന് ദശലക്ഷക്കണക്കിന്
   പ്രവർത്തനങ്ങൾ ഒരു സെക്കൻഡിലോ
   സെക്കൻഡിന്റെഅംശത്തിലോ ചെയ്യാൻ കഴിയും.

*  കൃത്യത -     ഒരു കമ്പ്യൂട്ടറിന് വളരെ ഉയർന്ന
    കൃത്യതയോടെ ഗണിത പ്രവർത്തനങ്ങൾ നടത്താൻ

കഴിയും.
*  സ്ഥിരോത്സാഹം -   കംപ്യൂട്ടർ ഒരു

   യന്ത്രമായതിനാൽ മണിക്കൂറുകളോളം തളരാതെ
പ്രവർത്തിക്കാനാകും.
*   ബഹുമുഖവൈദഗ്ധ്യം -   പല തരത്തിലുള്ള

    പ്രോസസ്സിംഗ് ജോലികൾ ചെയ്യാൻ ഇത്
ഉപയോഗിക്കാം.
*   വലിയ മെമ്മറി -    കമ്പ്യൂട്ടറിന് വലിയ മെമ്മറി
ശേഷിയുണ്ട്.

* ഐ.ക്യു.   വിന്റെഅഭാവം -   ഒരു കമ്പ്യൂട്ടറിന്
   മനുഷ്യനുള്ളതുപോലെ സ്വാഭാവിക ബുദ്ധി ഇല്ല.

*   തീരുമാനമെടുക്കാനുള്ള കഴിവില്ലായ്മ - കമ്പ്യൂട്ടറിന്
  സ്വന്തമായി തീരുമാനിക്കാൻ കഴിയില്ല.

  നമ്പർസിസ്റ്റം ( Number system )
         ഒരു നമ്പർ സിസ്റ്റത്തിൽ ഉപയോഗിക്കുന്ന ചിഹ്നങ്ങളുടെ എണ്ണത്തെ ബേസ് അല്ലെങ്കിൽ റാഡിക്സ് (Base or 

Radix)  എന്ന് വിളിക്കുന്നു.
Number System Base  Symbols used Example
Binary  2  0 1  (1101) 2

Octal  8  0 1 2 3 4 5 6 7  (236) 8

Decimal  10  0 1 2 3 4 5 6 7 8 
9

 
  (5946)10

Hexadecimal 16  0,1, 2, 3, 4, 5, 6, 
7, 8, 9, A , B , C , 
D , E , F

  (12AF ) 16

  സംഖ്യകളുടെ പ്രതിനിധാനം ( Representation of integers )
      കമ്പ്യൂട്ടർ മെമ്മറിയിൽ ഒരുസംഖ്യയെ പ്രതിനിധീകരിക്കുന്നതിന് മൂന്ന് രീതികളുണ്ട്.

( i )     ചിഹ്നവും മൂല്യവും കൊണ്ടുള്ളപ്രതിനിധാനം ( Sign and magnitude representation )
( ii ) 1     ന്റെ പൂരകം കൊണ്ടുള്ളപ്രതിനിധാനം (1’ s complement representation )
( iii ) 2     ന്റെ പൂരകം കൊണ്ടുള്ളപ്രതിനിധാനം (2’ s complement representation )
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  അക്ഷരങ്ങളുടെ പ്രതിനിധാനം ( Representation of characters )
     കമ്പ്യൂട്ടർ മെമ്മറിയിൽഅക്ഷരങ്ങളെ പ്രതിനിധീകരിക്കുന്നതിനുള്ള വ്യത്യസ്ത രീതികൾ:

 ● ASCII(       അമേരിക്കൻസ്റ്റാൻഡേർഡ് കോഡ് ഫോർ ഇൻഫർമേഷൻ ഇന്റർചേഞ്ച് )
➢     ഓരോ പ്രതീകത്തെയും പ്രതിനിധീകരിക്കാൻ 7  ബിറ്റുകൾ ഉപയോഗിക്കുന്നു.
➢  128    പ്രതീകങ്ങൾ മാത്രമേ പ്രതിനിധീകരിക്കാൻ കഴിയൂ.
➢   ASCII-8(Extended ASCII) 8  ബിറ്റുകൾ ഉപയോഗിക്കുന്നു.  കൂടാതെ 256   പ്രതീകങ്ങളെ

   പ്രതിനിധീകരിക്കാൻ കഴിയും.

 ● EBCDIC(     എക്സ്റ്റൻ്റഡ് കോഡഡ് ഡെസിമൽ ഇന്റർചേഞ്ച് കോഡ്)
➢     ഓരോ പ്രതീകത്തെയും പ്രതിനിധീകരിക്കാൻ 7  ബിറ്റുകൾ ഉപയോഗിക്കുന്നു.
➢  256    പ്രതീകങ്ങൾ മാത്രമേ എൻകോഡ് ചെയ്യാനാകൂ.

 ● ISCII(      ഇന്ത്യൻ സ്റ്റാൻഡേർഡ് കോഡ് ഫോർ ഇൻഫർമേഷൻ ഇൻ്റർചേയ്ഞ്ച്)
➢         ഇന്ത്യയിലെ വിവിധ എഴുത്ത് സംവിധാനങ്ങളെ പ്രതിനിധീകരിക്കുന്നതിനുള്ളഎൻകോഡിംഗ് സ്കീം.
➢   8  ബിറ്റ് കോഡ്.
➢   256    പ്രതീകങ്ങൾഎൻകോഡ് ചെയ്യാൻ കഴിയും.

 ● Unicode(യൂണികോഡ്)
➢    16  ബിറ്റ് കോഡ്.
➢    65536    പ്രതീകങ്ങൾഎൻകോഡ് ചെയ്യാൻ കഴിയും.
➢          ലോകത്തിലെ ലിഖിത ഭാഷകളിലെ എല്ലാ പ്രതീകങ്ങളെയും പ്രതിനിധീകരിക്കാൻ ഉപയോഗിക്കുന്നു.

.....................................................................................................................................................
 മാതൃക ചോദ്യങ്ങൾ

1.     അസംസ്‌കൃതഅക്കങ്ങളും വസ്‌തുതകളും ..........   എന്ന് അറിയപ്പെടുന്നു.
2.       ഒരു സംഖ്യാ സമ്പ്രദായത്തിൽ ഉപയോഗിച്ചിരിക്കുന്ന ചിഹ്നങ്ങളുടെ എണ്ണത്തെ ..................  എന്ന്
    വിളിക്കുന്നു.
3. ASCII   യുടെ പൂർണരൂപം എഴുതുക.
4.     ഒക്ടൽസംഖ്യാ സമ്പ്രദായത്തിന്റെആധാരം ....................... ആകുന്നു.
5. CPU   വിന്റെ പൂർണ്ണരൂപം ............... ആകുന്നു.
6.    ഡാറ്റയും വിവരവും തമ്മിലുള്ള വ്യത്യാസങ്ങളെഴുതുക?
7.   കമ്പ്യൂട്ടറിന്റെ സവിശേഷതകൾ പട്ടികപ്പെടുത്തുക.
8.    സി പി യു ( CPU )   വിന്റെഘടകങ്ങളുടെ പേരെഴുതുക?
9.       കമ്പ്യൂട്ടർ മെമ്മറിയിൽ പൂർണസംഖ്യകളെ പ്രതിനിധാനം ചെയ്യുന്ന രീതികൾ എന്തെല്ലാം.
10.       ചിത്രത്തിന്റെസഹായത്തോടുകൂടി കമ്പ്യൂട്ടറിന്റെ പ്രവർത്തനഘടകങ്ങളെ കുറിച്ച് വിശദീകരിക്കുക.
11.         ലോകത്തിലെ എല്ലാ മനുഷ്യ ഭാഷകളിലെയും പ്രതീകങ്ങളെ പ്രതിനിധീകരിക്കാൻ കഴിയുന്ന കോഡിംഗ്

  സിസ്റ്റത്തിന് പേര് നൽകുക.
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CHAPTER 2

  കമ്പ്യൂട്ടർ സിസ്റ്റത്തിന്റെ ഭാഗങ്ങൾ

     ഒരു കമ്പ്യൂട്ടറിന് പ്രധാനമായും രണ്ട് ഘടകങ്ങളാണുള്ളത് -   ഹാർഡ്‌വെയറും സോഫ്‌റ്റ്‌വെയറും.

 ഹാർഡ്‌വെയർ (Hardware)

•        ഒരു കമ്പ്യൂട്ടറിന്റെ തൊട്ടറിയാൻ കഴിയുന്നതും കാണാൻസാധിക്കുന്നതുമായ ഭാഗങ്ങളെ

ഹാർഡ്‌വെയർ  എന്ന് വിളിക്കുന്നു.

Eg:- Processor, Motherboard, Keyboard, etc.

   കമ്പ്യൂട്ടറിന്റെ ഹാർഡ്‌വെയർ ഘടകങ്ങൾ ഇവയാണ്  :  

• Processor

• Motherboard

• Peripherals and ports

• Memory

• Input devices

• Output devices

 പ്രോസസ്സർ (Processor)

•        കമ്പ്യൂട്ടറിൽ എല്ലാവിധ കണക്ക് കൂട്ടലുകൾ നടത്തുന്നതും മറ്റെല്ലാ പ്രവർത്തനങ്ങളേയും

 നിയന്ത്രിക്കുന്നതും Processor/CPU ആണ്.

Eg:- Intel core i3, core i5, core i7, AMD Quadcore

സി  .  പി  .  യു  .    വിന്റെ മൂന്ന് ഘടകങ്ങളാണ്  :  

• ALU – Arithmetic and Logic Unit

• CU – Control Unit

• Registers

ALU  എല്ലാ ഗണിത,   ലോജിക്കൽ പ്രവർത്തനങ്ങളും നടത്തുന്നു.

CU      കമ്പ്യൂട്ടറിന്റെ മറ്റെല്ലാ ഘടകങ്ങളെയും നിയന്ത്രിക്കുകയും ഏകോപിപ്പിക്കുകയും ചെയ്യുന്നു.
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Registers സി.പി.യു.   വിനുള്ളിലെ താൽ‌ക്കാലിക മെമ്മറികളാണ്.   പ്രോഗ്രാമിന്റെ പ്രവർത്തനം

വേഗത്തിലാക്കുന്നു.

 പ്രധാനപ്പെട്ട  5    രജിസ്റ്ററുകൾ‌ഇവയാണ്  :  

(i) അക്യുമുലേറ്റർ: അരിത്മെറ്റിക്,   ലോജിക് ഫലങ്ങൾസൂക്ഷിക്കുന്നു.

(ii)    മെമ്മറി അഡ്രസ്സ് രജിസ്റ്റർ (MAR): Read or Write    ചെയ്യാനുള്ളഡാറ്റയുടെ മെമ്മറി

  ലൊക്കേഷന്റെഅഡ്രസ്സ് സൂക്ഷിക്കുന്നു.

(iii)    മെമ്മറി ബഫർ രജിസ്റ്റർ (MBR):     പ്രോസസ്സിങ്ങിനു വേണ്ടി ഡാറ്റ താൽക്കാലികമായി

സൂക്ഷിക്കുന്നു.

(iv)   ഇൻസ്ട്രക്ഷൻ രജിസ്റ്റർ (IR):     പ്രോസസ്സർഎക്സിക്യൂട്ട് ചെയ്യേണ്ട നിർദ്ദേശങ്ങൾ

സൂക്ഷിക്കുന്നു.

(v)   പ്രോഗ്രാം കൗണ്ടർ (PC):      എക്സിക്യൂട്ട് ചെയ്യേണ്ടഅടുത്തനിർദ്ദേശത്തിന്റെ മെമ്മറി  അഡ്രസ്സ്

സൂക്ഷിക്കുന്നു.

 മദർബോർഡ് (Motherboard)

•     കമ്പ്യൂട്ടറിനുള്ളിലെ പ്രധാന പ്രിന്റഡ് സർക്യൂട്ട് ബോർഡ്.     കമ്പ്യൂട്ടറിന്റെ എല്ലാ പ്രധാനഘടകങ്ങളും

(പ്രോസസർ,  മെമ്മറി മുതലായവ) ഘടിപ്പിക്കുന്നു.

  പെരിഫറലുകളും പോർട്ടുകളും (Peripherals and ports)

•     കമ്പ്യൂട്ടർ സിസ്റ്റവുമായി ബന്ധിപ്പിച്ചിരിക്കുന്ന ഉപകരണങ്ങളാണ് പെരിഫറലുകൾ.

Eg:- input devices, output devices

•       ബാഹ്യ ഉപകരണങ്ങളെ കമ്പ്യൂട്ടറുമായി ബന്ധിപ്പിക്കുന്നതിന് മദർബോർഡിലെ പോർട്ടുകൾ

ഉപയോഗിക്കുന്നു.

    കംപ്യൂട്ടറുകളിൽ ഉപയോഗിക്കുന്ന വിവിധ പോർട്ടുകൾ ഇവയാണ്: Serial, Parallel, USB, LAN, 

PS/2, Audio, VGA, HDMI, etc.

a.   സീരിയൽ പോർട്ട് (Serial port)

•         സീരിയൽ പോർട്ട് ഒരു സമയം ഒരു ബിറ്റ് ഡാറ്റ ട്രാൻസ്മിറ്റ് ചെയ്യുന്നു.

•   പഴയ കംപ്യൂട്ടറുകളിൽ മോഡം, മൗസ്,      കീബോർഡ് എന്നിവ കണക്ട് ചെയ്യാൻ ഇത് ഉപയോഗിച്ചു.

b.    പാരലൽ പോർട്ട് (Parallel port)

•        പാരലൽ പോർട്ടുകൾക്ക് ഒരു സമയം നിരവധി ബിറ്റുകൾകൈമാറാൻ കഴിയും.
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•  കമ്പ്യൂട്ടറുമായി പ്രിന്റർ,     സ്കാനർ തുടങ്ങിയവ ബന്ധിപ്പിക്കാൻ ഇത് ഉപയോഗിക്കുന്നു.

c. USB  പോർട്ട് (Universal Serial Bus)

•     ഉപകരണങ്ങൾക്കിടയിൽഅതിവേഗഡാറ്റാ വിനിമയം സാധ്യമാക്കുന്നു.

• കീബോർഡ്, മൗസ്, പ്രിന്റർ,      സ്കാനർ തുടങ്ങിയ ഉപകരണങ്ങൾ കണക്ട് ചെയ്യാൻ

ഉപയോഗിക്കുന്നു.

Advantages:

•     ബാഹ്യ ഉപകരണങ്ങളിലേക്ക് വൈദ്യുതി നൽകാൻ USB  പോർട്ടുകൾക്ക് കഴിയും.

•    പവർ ഓണായിരിക്കുമ്പോൾ പോലും USB     ഉപകരണങ്ങൾ കണക്റ്റ് ചെയ്യാനും വിച്ഛേദിക്കാനും

കഴിയും.

d. LAN (Local Area Network)  പോർട്ട് / Ethernet പോർട്ട്

•      ഒരു കമ്പ്യൂട്ടറിനെ നെറ്റ്‌വർക്കിലേക്ക് ബന്ധിപ്പിക്കാൻ ഇത് ഉപയോഗിക്കുന്നു.

e. PS/2 പോർട്ട്

•    കീബോർഡും മൗസും ബന്ധിപ്പിക്കുന്നതിന് ഉപയോഗിക്കുന്നു. 

•   വേഗത വളരെ കുറവാണ്.

f.   ഓഡിയോ പോർട്ട്

• സ്പീക്കറുകൾ,    മൈക്രോഫോൺ മുതലായവ ബന്ധിപ്പിക്കാൻ ഉപയോഗിക്കുന്നു.

•   ഓഡിയോ പോർട്ടുകൾ ഇവയാണ്:  ലൈൻ ഇൻ,  ലൈൻഔട്ട്,  മൈക്ക് ഇൻ.

g.    വീഡിയോ ഗ്രാഫിക്സ് അറേ (VGA) പോർട്ട്

• മോണിറ്റർ,     പ്രൊജക്ടർ എന്നിവ കമ്പ്യൂട്ടറുമായി ബന്ധിപ്പിക്കാൻ ഉപയോഗിക്കുന്നു.

h.     ഹൈ ഡെഫനിഷൻ മൾട്ടിമീഡിയ ഇന്റർഫേസ് (HDMI) പോർട്ട്

•   ഒരു കേബിളിലൂടെ ഹൈ-       ഡെഫനിഷൻ വീഡിയോയും മൾട്ടി ചാനൽഓഡിയോയും കൈമാറാൻ

ഉപയോഗിക്കുന്നു.

 മെമ്മറി (Memory)

ഡാറ്റയോ,       നിർദ്ദേശങ്ങളോ താൽക്കാലികമായോസ്ഥിരമായോ സൂക്ഷിച്ചു വയ്ക്കാനുള്ളസ്ഥലമാണ്

മെമ്മറി.

•  പ്രൈമറി മെമ്മറി,     സെക്കൻഡറി മെമ്മറി എന്നിങ്ങനെ രണ്ടായി തരംതിരിച്ചിരിക്കുന്നു.
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   മെമ്മറി അളക്കുന്നയൂണിറ്റുകൾ (Memory measuring units)

  പ്രൈമറി മെമ്മറി (Primary memory)

സി.പി.യു.      നേരിട്ട് ആക്‌സസ്സുചെയ്യുന്ന സെമികണ്ടക്ടർ മെമ്മറിയാണ് പ്രൈമറി മെമ്മറി. 

    മൂന്ന് തരം പ്രൈമറി മെമ്മറികളാണ് റാം(RAM), റോം(ROM), ക്യാഷ്(Cache) എന്നിവ.

    റാമും റോമും തമ്മിലുള്ള താരതമ്യം  (Comparison between RAM and ROM)  

RAM (   റാൻഡംആക്സസ് മെമ്മറി) ROM (   റീഡ് ഓൺലി മെമ്മറി)

  റോമിനേക്കാൾ വേഗത കൂടുതലാണ്.   ഇതിന് വേഗത കുറവാണ്.

  കമ്പ്യൂട്ടർ പ്രവർത്തിക്കുമ്പോൾ ഡാറ്റയും, 

   അപ്ലിക്കേഷൻ പ്രോഗ്രാമും ഓപ്പറേറ്റിംഗ്

 സിസ്റ്റവും സൂക്ഷിക്കുന്നു

    കമ്പ്യൂട്ടർ ബൂട്ട് ചെയ്യുവാനുള്ള പ്രോഗ്രാം

സൂക്ഷിക്കുന്നു.

 ഡാറ്റ Read  ഉംWrite  ഉം അനുവദിക്കുന്നു.
   ഇതിൽ നിന്ന് ഡാറ്റ Read  ചെയ്യാൻ

 മാത്രമേ സാധിക്കുകയുള്ളൂ.

Volatile ആണ്.   കമ്പ്യൂട്ടർ ഓഫാക്കിയാൽ

  ഇതിലെ ഉള്ളടക്കം നഷ്ടപ്പെടുന്നു.

Non-volatile ആണ്.   കമ്പ്യൂട്ടർ ഓഫ്

 ആക്കിയാലും ROM   ലെ ഉള്ളടക്കം

നഷ്ടപ്പെടുന്നില്ല.

   വ്യത്യസ്ത തരം റോമുകൾ ഇവയാണ്:

• PROM - Programmable Read Only Memory

• EPROM - Erasable Programmable Read Only Memory

• EEPROM - Electrically Erasable Programmable Read Only Memory

  ക്യാഷ് മെമ്മറി (Cache memory)

•        പ്രൊസസ്സറിന്റെയും റാമിന്റെയും ഇടയ്‌ക്കുള്ള ചെറുതും വേഗതയേറിയതുമായ മെമ്മറിയാണ് ക്യാഷ്

മെമ്മറി.

•   റാമിനേക്കാൾ വേഗത കൂടുതലാണ്.
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 1024   KB

 1024 MB

 1024   GB

 1024 TB

 ബൈനറി ഡിജിറ്റ് =  1 ബിറ്്റ  1  (MB മെഗാ ബൈറ്്റ) =

 1 നിബ്ൾ =  4 ബിറ്്റസ്  1  (GB ജിഗാ ബൈറ്റ്) =

 1 ബൈറ്്റ =  8 ബിറ്്റസ്  1  (TB ടെറാ ബൈറ്്റ) = 

 1  (KB കിലോ ബൈറ്്റ) =  1024 ബൈറ്റ്സ്  1  (PB പെറ്റാ ബൈറ്്റ) =
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•  റാമിനേക്കാൾ വിലയേറിയതാണ്.

b.   സെക്കൻഡറി മെമ്മറി (Secondary memory/Auxiliary memory)

•     സ്ഥിരമായി ഡാറ്റ സംഭരിച്ചു വെക്കുന്നതിന് ഉപയോഗിക്കുന്നു. 

•   സംഭരണശേഷി വളരെ കൂടുതലാണ്.

• non-volatile ആണ്.     കമ്പ്യൂട്ടർ ഓഫ് ആക്കിയാലും ഉള്ളടക്കം നഷ്ടപ്പെടുന്നില്ല.

•   റാമിനേക്കാൾ വേഗത കുറവാണ്.

•     ഇത് ഒരു ബാക്കപ്പ് ആയും ഉപയോഗിക്കുന്നു.

   വിവിധതരത്തിലുള്ള സെക്കൻഡറി മെമ്മറികൾ ഇവയാണ്  :  

(i) Magnetic storage devices. Eg:- magnetic tapes, floppy disks, hard disks.

(ii) Optical storage devices. Eg:- CD, DVD, Blu-Ray DVD

(iii) Semiconductor storage devices. Eg:- USB flash drive, Flash memory cards

     വിവിധ തരം ഡാറ്റ സംഭരണികളുടെ സവിശേഷതകൾ

(Comparison of different types of memory)

സംഭരണം വേഗത സംഭരണശേഷി  അനുപാതിക മൂല്യം
അസ്ഥിരമായത്

Volatile

രജിസ്റ്ററുകൾ‌ അതിവേഗം  വളരെ കുറവ്  ഏറ്റവും കൂടുതൽ അതെ

ക്വാഷ്  കൂടിയ വേഗം കുറവ്  വളരെ കൂടുതൽ അതെ

 റാം (RAM)  വളരെ വേഗം  മിത വേഗം കൂടുതൽ അതെ

 ഹാർഡ് ഡിസ്ക്  മിത വേഗം  വളരെ കൂടുതൽ  വളരെ കുറവ് അല്ല

  ഇൻപുട്ട് ഉപകരണങ്ങൾ (Input devices)

      കമ്പ്യൂട്ടറിലേക്ക് ഡാറ്റയും നിർദ്ദേശങ്ങളും നൽകുന്നതിന് ഇൻപുട്ട് ഉപകരണം ഉപയോഗിക്കുന്നു.

     വ്യത്യസ്ത തരം ഇൻപുട്ട് ഉപകരണങ്ങൾ ഇവയാണ്  :  

1. കീബോർഡ്:        അക്ഷരങ്ങളും സംഖ്യകളും വിവിധ ചിഹ്നങ്ങളും ഇൻപുട്ട് ചെയ്യുന്നതിന് ഇത്

ഉപയോഗിക്കുന്നു.

2. മൗസ്:  പോയിന്റിംഗ് ഉപകരണമാണിത്.     കമ്പ്യൂട്ടർ സ്ക്രീനിലെ കഴ്‌സറിന്റെ ചലനം

     നിയന്ത്രിക്കുന്നകൈപ്പിടിയിലൊതുങ്ങുന്ന ഒരു ചെറിയ ഇൻപുട്ട് ഉപകരണമാണിത്.

3.  ലൈറ്റ് പേന:       കമ്പ്യൂട്ടർ സ്ക്രീനിൽ ചിത്രങ്ങൾ വരയ്ക്കാൻ ഉപയോഗിക്കുന്നലൈറ്റ്
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  സെൻസിറ്റീവ് പോയിന്റിംഗ് ഉപകരണമാണിത്.

4.  ടച്ച് സ്‌ക്രീൻ:     ഡിസ്‌പ്ലേയിൽ സ്‌പർശിച്ച് കമ്പ്യൂട്ടർ പ്രവർത്തിപ്പിക്കാൻ ഉപയോഗിക്കുന്നു.

5.  ഗ്രാഫിക് ടാബ്‌ലെറ്റ്:      ഗ്രാഫിക് ചിത്രങ്ങൾ നിർമ്മിക്കുന്നതിന് കലാകാരന്മാർ ഇത്

ഉപയോഗിക്കുന്നു.

6. ടച്ച‌്പാഡ്:        കമ്പ്യൂട്ടർ സ്‌ക്രീനിൽ മൗസ് പോയിന്റർ നീക്കാൻ ഉപയോഗിക്കുന്ന പോയിന്റിംഗ്

ഉപകരണമാണിത്.

7. ജോയ്സ്റ്റിക്ക്:       വീഡിയോ ഗെയിമുകൾ കളിക്കാൻ ഉപയോഗിക്കുന്ന ഒരു പോയിന്റിംഗ്

ഉപകരണമാണിത്.

8. മൈക്രോഫോൺ:    ശബ്‌ദം ഇൻപുട്ട് ചെയ്യുന്നതിന് ഉപയോഗിക്കുന്നു.

9. സ്കാനർ:         ഫോട്ടോകളും ടെക്സ്റ്റ് പേജുകളും സ്കാൻ ചെയ്ത് ഇൻപുട്ട് ചെയ്യുന്നതിന് ഇത്

ഉപയോഗിക്കുന്നു.

10.    ഒപ്റ്റിക്കൽ മാർക്ക് റീഡർ (ഒ‌.എം‌.ആർ):     ഒബ്ജക്റ്റീവ് ടൈപ്പ് പരീക്ഷകളുടെ മൂല്യ  നിർണ്ണയം

    കൃത്യതയോടെയും വേഗത്തിലും നടത്താൻ ഇത് ഉപയോഗിക്കുന്നു.

11.   ബാർകോഡ് റീഡർ /   ക്വിക്ക് റെസ്‌പോൺസ് (QR)  കോഡ് റീഡർ:  അച്ചടിച്ച

   ബാർകോഡുകൾസ്കാൻ ചെയ്യുന്നതിന് ഉപയോഗിക്കുന്നു.   ബാർകോഡുകൾക്ക് സമാനമാണ് QR 

കോഡുകൾ. QR   കോഡുകൾ‌ക്ക് വെബ്‌സൈറ്റ് URL,  സാധാരണ ടെക്സ്റ്റ്,   ഫോൺ നമ്പർ  തുടങ്ങി

   കൂടുതൽ വിവരങ്ങൾസംഭരിക്കാൻ കഴിയും.

12.     മാഗ്നെറ്റിക് ഇങ്ക് ക്യാരക്ടർ റെക്കഗ്നിഷൻ (MICR) റീഡർ:   ചെക്കുകൾ പ്രോസസ്സ്

  ചെയ്യുന്നതിന് ബാങ്കുകളിൽ ഉപയോഗിക്കുന്നു.

13.  ബയോമെട്രിക് സെൻസർ: വിരലടയാളം,    റെറ്റിന തുടങ്ങിയവ തിരിച്ചറിയാനുള്ള ഉപകരണം.

14.   സ്മാർട്ട് കാർഡ് റീഡർ:       ഡാറ്റ സംഭരിക്കാനും വിനിമയം ചെയ്യാനും കഴിയുന്ന ഒരു  പ്ലാസ്റ്റിക്

 കാർഡാണ്    സ്മാർട്ട് കാർഡ് (ഉദാ:- ATM Card).    സ്മാർട്ട് കാർഡിലുള്ളഡാറ്റ   എടുക്കുന്നതിന് സ്മാർട്ട്

  കാർഡ് റീഡർ ഉപയോഗിക്കുന്നു.

15.  ഡിജിറ്റൽ ക്യാമറ:   ചിത്രങ്ങളും വീഡിയോകളും എടുക്കാനും,    അത് ഒരു കമ്പ്യൂട്ടറിലേക്ക്  മാറ്റാനും

ഉപയോഗിക്കുന്നു.

  ഔട്ട്പുട്ട് ഉപകരണങ്ങൾ (Output devices)

    കമ്പ്യൂട്ടറിൽ നിന്നുള്ള വിവരങ്ങൾ പ്രിന്റ് /     ഡിസ്പ്ലേ ചെയ്യുന്നതിന് ഔട്ട്പുട്ട് ഉപകരണം

ഉപയോഗിക്കുന്നു.
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 ഹാർഡ് കോപ്പി,    സോഫ്റ്റ് കോപ്പി ഔട്ട്പുട്ട് (Hard copy and Soft copy output)

•   ഹാർഡ് കോപ്പി ഔട്ട്‌പുട്ടുകൾ  സ്ഥിരമായഔട്ട്‌പുട്ടുകളാണ്,    അത് പിന്നീട് ആവശ്യമുള്ളപ്പോൾ

ഉപയോഗിക്കാം. 

•     ഹാർഡ് കോപ്പി ഔട്ട്പുട്ട് ഉപകരണത്തിന് ഉദാഹരണം: പ്രിന്റർ, പ്ലോട്ടർ

•   സോഫ്റ്റ് കോപ്പി ഔട്ട്പുട്ടുകൾ  ഇലക്ട്രോണിക് ആണ്,     അവഡിജിറ്റൽ രൂപത്തിൽ സ്ക്രീനിൽ

ലഭ്യമാണ്. 

•     സോഫ്റ്റ് കോപ്പി ഔട്ട്പുട്ട് ഉപകരണത്തിന് ഉദാഹരണം: മോണിറ്റർ

     വ്യത്യസ്ത തരം ഔട്ട്പുട്ട് ഉപകരണങ്ങൾ ഇവയാണ്  :  

1.  മോണിറ്റർ (Monitor)

      കമ്പ്യൂട്ടറിൽ നിന്നുള്ള വിവരങ്ങൾ പ്രദർശിപ്പിക്കുന്നതിന് ഉപയോഗിക്കുന്നഔട്ട്പുട്ട് ഉപകരണം.

   വ്യത്യസ്ത തരം മോണിറ്ററുകൾ ഇവയാണ്  :  

a.    കാതോഡ് റേ ട്യൂബ് (CRT) മോണിറ്റർ:   പഴയകാല ടെലിവിഷനുകൾക്ക് സമാനം.  ഭാരം

കൂടുതലാണ്.   കൂടുതൽവൈദ്യുതി ഉപയോഗിക്കുന്നു.

b.   ഫ്ലാറ്റ് പാനൽ മോണിറ്റർ:   ഇത് കനം കുറഞ്ഞതാണ്,  ഭാരം കുറവാണ്,   കുറഞ്ഞവൈദ്യുതി

ഉപയോഗിക്കുന്നു,   കുറഞ്ഞതാപം പുറപ്പെടുവിക്കുന്നു.  ഉദാ: - LCD മോണിറ്ററുകൾ, LED 

മോണിറ്ററുകൾ,  പ്ലാസ്മ മോണിറ്ററുകൾ, OLED മോണിറ്ററുകൾ.

2.   എൽസിഡി പ്രൊജക്ടർ (LCD projector)

  വലിയ സ്ക്രീനിൽ വീഡിയോ,       ഇമേജുകൾഅല്ലെങ്കിൽ കമ്പ്യൂട്ടർ ഡാറ്റ പ്രദർശിപ്പിക്കുന്നതിന് ഇത്

ഉപയോഗിക്കുന്നു.

3.  പ്രിന്റർ (Printer)

     കമ്പ്യൂട്ടറിൽ നിന്നുള്ള വിവരങ്ങൾ പ്രിന്റ് ചെയ്യുന്നതിന് ഉപയോഗിക്കുന്നു.

 രണ്ടായി തിരിച്ചിരിക്കുന്നു: - ഇംപാക്റ്റ് പ്രിന്ററുകൾ, നോൺ-ഇംപാക്റ്റ് പ്രിന്ററുകൾ.

a.    ഇംപാക്റ്റ് പ്രിന്ററുകൾ  :     അച്ചടിക്കുമ്പോൾ പ്രിൻറ് ഹെഡ് പേപ്പറിൽ തൊടുന്നു. 

ഉദാ: - ഡോട്ട്-  മാട്രിക്സ് പ്രിന്റർ.

   ഡോട്ട് മാട്രിക്സ് പ്രിന്റർ (Dot Matrix Printer)

•  പ്രിന്റിങ്ങ് മെറ്റീരിയൽ:   മഷി പുരട്ടിയ റിബൺ
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•   പ്രിന്റ് നിലവാരം കുറവ്,   കാർബൺ പകർപ്പ് സാധ്യമാണ്,  വേഗത കുറവാണ്,  ശബ്ദം

ഉണ്ടാക്കുന്നു. 

b.   നോൺ  -   ഇംപാക്റ്റ് പ്രിന്ററുകൾ  :     അച്ചടിക്കുമ്പോൾ പ്രിൻറ് ഹെഡ് പേപ്പറിൽ തൊടുന്നില്ല.

ഉദാ: - ഇങ്ക്ജെറ്റ്, ലേസർ,  തെർമൽ പ്രിന്ററുകൾ

  ഇങ്ക്ജറ്റ് പ്രിന്റർ (Inkjet printer)

•  പ്രിന്റിങ്ങ് മെറ്റീരിയൽ:   ദ്രവ രൂപത്തിലുള്ള മഷി

• നിശബ്ദം,  ഗുണനിലവാരമുള്ള പ്രിന്റിങ്ങ്,   പ്രിന്ററിന്റെ വില കുറവാണ്,  മഷി വിലയേറിയതാണ്.

  ലേസർ പ്രിന്റർ (Laser printer)

•  പ്രിന്റിങ്ങ് മെറ്റീരിയൽ:   പൊടി രൂപത്തിലുള്ള മഷി

• നിശബ്ദം,  വേഗത്തിൽ പ്രിന്റുചെയ്യുന്നു,  ഗുണനിലവാരമുള്ള പ്രിന്റിങ്ങ്,   ടോണറും പ്രിന്ററും

ചെലവേറിയതാണ്.

  തെർമൽ പ്രിന്റർ (Thermal printer)

•  പ്രിന്റിങ്ങ് മെറ്റീരിയൽ:   ഹീറ്റ് സെൻസിറ്റീവ് പേപ്പർ.

• നിശബ്ദം,    വേഗതയേറിയതും ചെറുതും ഭാരം കുറഞ്ഞതുമാണ്‌,   കുറഞ്ഞവൈദ്യുതി

ഉപയോഗിക്കുന്നു,   കൊണ്ട് നടക്കാൻ എളുപ്പം.

4.  പ്ലോട്ടർ (Plotter)

•       വലിയ ഗ്രാഫുകളും ഡിസൈനുകളും പ്രിന്റ് ചെയ്യാൻ ഉപയോഗിക്കുന്ന ഉപകരണം. 

• കാറുകൾ, കപ്പലുകൾ, വിമാനങ്ങൾ, കെട്ടിടങ്ങൾ,    ഹൈവേകൾഎന്നിവയുടെ രൂപകൽപ്പനയിൽ

 ഇത് ഉപയോഗിക്കുന്നു.

5.   ത്രീ ഡൈമെൻഷനൽ (3D) പ്രിന്റർ

• 3D        വസ്തുക്കൾഅച്ചടിക്കാൻ ഉപയോഗിക്കുന്ന ഒരു പുതിയ തലമുറഔട്ട്പുട്ട് ഉപകരണമാണിത്.

•   ഇതിന് സെറാമിക് കപ്പുകൾ,  പ്ലാസ്റ്റിക് കളിപ്പാട്ടങ്ങൾ,     മെറ്റൽ മെഷീൻ ഭാഗങ്ങൾ തുടങ്ങിയവ

 അച്ചടിക്കാൻ കഴിയും.

6.  സ്പീക്കർ (Speaker):    ശബ്‌ദം പുറപ്പെടുവിക്കുന്നഔട്ട്പുട്ട് ഉപകരണമാണ് സ്പീക്കർ.
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ഇ-  മാലിന്യം (e-Waste)

   ഉപയോഗശൂന്യമായ ഇലക്ട്രോണിക് ഉപകരണങ്ങൾ ഇ-വേസ്റ്റ്  എന്ന് അറിയപ്പെടുന്നു.

ഉദാ: -  ഉപേക്ഷിക്കപ്പെട്ട കമ്പ്യൂട്ടറുകൾ,  മൊബൈൽ ഫോണുകൾ,  ടെലിവിഷൻ സെറ്റുകൾ, 

റഫ്രിജറേറ്ററുകൾ.

ഇ  -     മാലിന്യം നിർമാർജന മാർഗ്ഗങ്ങൾ  (e-Waste disposal methods)  

a. പുനരുപയോഗം b.  കത്തിച്ചു കളയൽ c.  പുതുക്കി ഉപയോഗിക്കൽ d.  മണ്ണിട്ടു മൂടൽ

ഇ-     മാലിന്യത്തെ കുറിച്ച് നാം എന്തുകൊണ്ട് ഉത്കണ്ഠപ്പെടണം? (Why should we be 

concerned about e-Waste?)

•   ഇലക്‌ട്രോണിക് മാലിന്യത്തിൽ മെർക്കുറി,     ലെഡ് തുടങ്ങിയ വിഷ പദാർത്ഥങ്ങൾഅടങ്ങിയിട്ടുണ്ട്.

•     വേണ്ടവിധം നിയന്ത്രിച്ചില്ലെങ്കിൽഈവിഷവസ്തുക്കൾ കാൻസർ,  പ്രത്യുൽപ്പാദനശേഷി കുറവ്,  മറ്റ്

  ആരോഗ്യപ്രശ്നങ്ങൾഎന്നിവക്ക് കാരണമാകുന്നു. 

ഇ-     മാലിന്യം നിർമ്മാർജ്ജനത്തിൽ വിദ്യാർത്ഥികളുടെ പങ്ക് (Students’ role in e-Waste 

disposal)

•     അനാവശ്യമായി ഇലക്ട്രോണിക് ഉപകരണങ്ങൾ വാങ്ങുന്നത് നിർത്തുക.

•       പുതിയത് വാങ്ങുന്നതിന് പകരം കേടായ ഉപകരണങ്ങൾ നന്നാക്കാൻശ്രമിക്കുക.

•     ഇലക്ട്രോണിക് ഉപകരണങ്ങൾ റീസൈക്കിൾ ചെയ്യാൻശ്രമിക്കുക.

•       ഡിസ്പോസിബിൾ ബാറ്ററികൾക്ക് പകരം റീചാർജ്ജ് ചെയ്യാവുന്നബാറ്ററികൾ ഉപയോഗിക്കുക.

•     നല്ല വാറന്റി ഉള്ള ഉൽപ്പന്നങ്ങൾ വാങ്ങുക.

 ഹരിത കമ്പ്യൂട്ടിംഗ്/   ഹരിത സാങ്കേതികവിദ്യ (Green computing / Green IT)

•        പാരിസ്ഥിതിക്ക് യോജിച്ച രീതിയിൽ കമ്പ്യൂട്ടറുകളും അവയുടെ വിഭവങ്ങളും ഉപയോഗിക്കുന്നതിനെ

   ഹരിത കമ്പ്യൂട്ടിങ് എന്ന് പറയുന്നു.

   കമ്പ്യൂട്ടറുകളെ എങ്ങിനെ ഹരിതാഭമാക്കാം (How to make computers green?)

   ഹരിത കമ്പ്യൂട്ടിംഗ് പ്രോത്സാഹിപ്പിക്കുന്നതിനുവേണ്ടിയുള്ള 4 സമീപനങ്ങളാണ്:

(i)   ഹരിത രൂപകൽപന (Green design)

(ii)   ഹരിത നിർമാണം (Green manufacturing)

(iii)   ഹരിത ഉപയോഗം (Green use)

(iv)   ഹരിത നിർമാർജനം (Green disposal)
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 സോഫ്റ്റ്‌വെയർ (Software)

•         കമ്പ്യൂട്ടർ സിസ്റ്റം ഉപയോഗിക്കാൻ നമ്മെസഹായിക്കുന്ന പ്രോഗ്രാമുകളുടെ ഒരു കൂട്ടമാണ്

സോഫ്റ്റ്‌വെയർ.

•   രണ്ടു തരത്തിലുള്ള സോഫ്റ്റ്‌വെയറാണുള്ളത്:  സിസ്റ്റം സോഫ്റ്റ്‌വെയർ,   ആപ്ലിക്കേഷൻ സോഫ്റ്റ്‌വെയർ

 സിസ്റ്റം സോഫ്റ്റ്‌വെയർ (System software)

•        കമ്പ്യൂട്ടറിന്റെ പ്രവർത്തനങ്ങൾ നിയന്ത്രിക്കുന്നതിന് രൂപകൽപ്പന ചെയ്തിട്ടുള്ള ഒന്നോ അതിലധികമോ

  പ്രോഗ്രാമുകളുടെ ഒരു കൂട്ടമാണിത്.

    സിസ്റ്റം സോഫ്റ്റ് വെയറിന്റെഘടകങ്ങൾ ഇവയാണ്: 

 ഓപ്പറേറ്റിംഗ് സിസ്റ്റം,  ലാംഗ്വേജ് പ്രോസസ്സറുകൾ,   യൂട്ടിലിറ്റി സോഫ്റ്റ് വെയർ.

a.   ഓപ്പറേറ്റിംഗ് സിസ്റ്റം (Operating system)

•         ഉപയോക്താവും കമ്പ്യൂട്ടർ ഹാർഡ്‌വെയറും തമ്മിലുള്ള ഇന്റർഫേസായി പ്രവർത്തിക്കുന്ന ഒരു കൂട്ടം

പ്രോഗ്രാമുകളാണിത്. 

• ഉദാഹരണം: - ഡോസ്, വിൻഡോസ്, യുണിക്സ്, ലിനക്സ്

    ഓപ്പറേറ്റിംഗ് സിസ്റ്റത്തിന്റെ പ്രധാന ധർമ്മങ്ങൾ (Functions of operating system): 

•   പ്രോസസ്സ് കൈകാര്യം ചെയ്യുക

•   മെമ്മറി കൈകാര്യം ചെയ്യുക

•   ഫയൽകൈകാര്യം ചെയ്യുക

•   ഉപകരണംകൈകാര്യം ചെയ്യുക.
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 Computer languages

  :Low Level Language  യന്ത്രാധിഷ്ഠിതഭാഷ എന്നറിയപ്പെടുന്നു. രണ്ടു തരത്തിലുണ്ട്:

.  : a Machine language ബൈനറി അക്കങ്ങൾ മാത്രം ഉപയോഗിക്കുന്ന ഭാഷ.

.  : b Assembly language മധ്യവർത്തിയായ പ്രോഗ്രാമിംഗ് ഭാഷയാണ്.

  :High Level Language  ഈ ഭാഷകൾ ഇംഗ്ലീഷ് ഭാഷയെപ്പോലെയുള്ളതും ലളിതമായി 
മനസിലാക്കാൻ സാധിക്കുന്നതുമാണ്. കമ്പ്യൂട്ടറിന് മനസ്സിലാക്കാൻ സാധിക്കുകയില്ല.   
ഉദാ:- ++C
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b.   ലാംഗ്വേജ് പ്രോസസർ (Language processor)

•         ഹൈ ലെവൽ ലാംഗ്വേജിലോ അസംബ്ലി ലാംഗ്വേജിലോ എഴുതിയിരിക്കുന്ന പ്രോഗ്രാമുകളെ അതിന്

   സമാനമായ മെഷീൻ ലാംഗ്വേജിലേക്ക് മാറ്റുന്നു.

 വിവിധതരത്തിലുള്ള  ലാംഗ്വേജ്    പ്രോസസ്സറുകൾ  (Types of language processors)  

 അസംബ്ലർ (Assembler):      ഇത് അസംബ്ലി ലാംഗ്വേജിനെ മെഷീൻ ലാംഗ്വേജിലേക്ക് മാറ്റുന്നു.

 ഇന്റർപ്രറ്റർ (Interpreter):       ഇത് ഹൈ ലെവൽ ലാംഗ്വേജിനെ വരിവരിയായി മെഷീൻ

 ലാംഗ്വേജിലേക്ക് മാറ്റുന്നു.

 കംപൈലർ (Compiler):        ഇത് ഹൈ ലെവൽ ലാംഗ്വേജിനെ ഒറ്റത്തവണയായി മുഴുവനായും

  മെഷീൻ ലാംഗ്വേജിലേക്ക് മാറ്റുന്നു.

c.  യൂട്ടിലിറ്റി  സോഫ്റ്റ്‌വെയർ (Utility software)

•        സിസ്റ്റം മെയിന്റനൻസ് ജോലികളിൽ ഉപയോക്താക്കളെ സഹായിക്കുന്ന പ്രോഗ്രാമുകളുടെ ഒരു കൂട്ടം.

    ചില യൂട്ടിലിറ്റി പ്രോഗ്രാമുകൾ താഴെ കൊടുക്കുന്നു  :  

(i)   കംപ്രഷൻ ടൂൾസ് (Compression tools):      വലിയ ഫയലുകൾ കംപ്രസ് ചെയ്ത് സൈസ്

 കുറഞ്ഞഫയലുകളാക്കാം.

Eg: WinZip, WinRAR

(ii)   ഡിസ്ക് ഡീഫ്രാഗ്ഗ്മെന്റർ (Disk defragmenter):    കമ്പ്യൂട്ടർ ഹാർഡ് ഡിസ്കിൽ

  പലഭാഗങ്ങളിലായി ചിതറികിടക്കുന്ന  ഫയലുകളെ ക്രമീകരിക്കുന്നു.

(iii)  ബാക്കപ്പ്  സോഫ്റ്റ്‌വെയർ (Backup software):    ഹാർഡ് ഡിസ്കിൽസൂക്ഷിച്ചു

     വച്ചിരിക്കുന്നഫയലുകളുടെ പകർപ്പ് എടുക്കുവാൻസഹായിക്കുന്ന സോഫ്റ്റ്‌വെയറാണിത്.  ഡിസ്ക്

   പ്രവർത്തനരഹിതമാവുമ്പോൾഈബാക്കപ്പ് ഉപയോഗിക്കാം.

(iv)   ആന്റിവൈറസ്  സോഫ്റ്റ്‌വെയർ (Antivirus software):  കമ്പ്യൂട്ടറിന്റെ  പ്രവർത്തനത്തെ

   ദോഷകരമായി ബാധിക്കുന്ന പ്രോഗ്രാമുകളാണ്  കമ്പ്യൂട്ടർ വൈറസുകൾ.   ആന്റിവൈറസ് സോഫ്റ്റ്‌വെയർ

      ഉപയോഗിച്ച്അവയെ കണ്ടെത്താനും നീക്കം ചെയ്യാനും സാധിക്കും.

Eg: Norton Antivirus, Kaspersky

  ആപ്ലിക്കേഷൻ സോഫ്റ്റ്‌വെയർ (Application software)

•       ഒരു പ്രത്യേകആവശ്യത്തിനായി വികസിപ്പിച്ചെടുക്കുന്ന സോഫ്റ്റ്‌വെയറുകളെയാണ് ആപ്ലിക്കേഷൻ
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  സോഫ്റ്റ്‌വെയർ എന്നു വിളിക്കുന്നത്. 

•       പൊതുവായആവശ്യങ്ങൾക്കായുള്ള സോഫ്റ്റ്‌വെയർ പാക്കേജുകളും പ്രത്യേകആവശ്യങ്ങൾക്കായുള്ള

  സോഫ്റ്റ്‌വെയറുകളും ഇതിൽ പെടുന്നു. 

a.    പൊതുവായആവശ്യങ്ങൾക്കുള്ള പാക്കേജുകൾ (General purpose software)

•    വിവിധ ജോലികൾക്കായി ഉപയോഗിക്കാവുന്ന സോഫ്റ്റ്‌വെയർ. 

  ഇത് തരം തിരിച്ചിരിക്കുന്നു:

Word processing software Eg: MS Word, Open Office Writer

Spreadsheet software Eg: Microsoft Excel, Open Office Calc

Presentation software Eg: Microsoft PowerPoint, Open Office Impress.

Database software Eg: Microsoft Access, Oracle

Multimedia software Eg: Adobe Flash, Media Player

b.    പ്രത്യേകആവശ്യങ്ങൾക്കുള്ള സോഫ്റ്റ്‌വെയർ (Specific purpose software)

•        ഒരുസ്ഥാപനത്തിനുവേണ്ടി പ്രത്യേകം തയ്യാറാക്കിയിരിക്കുന്നഈ സോഫ്റ്റ്‌വെയറിനെ ടെയ്ലർ - 

   മെയ്ഡ് സോഫ്റ്റ്‌വെയർ എന്നു വിളിക്കുന്നു. 

•    കസ്റ്റമൈസ്ഡ് സോഫ്റ്റ്‌വെയർ എന്നുംഅറിയപ്പെടുന്നു

Eg: Payroll System, Inventory Management System, HR Management System.

     സ്വതന്ത്രഓപ്പൺ സോഴ്സ് സോഫ്റ്റ് വെയർ (Free and open source software)

• ഉപയോഗിക്കുന്നതിനും,  പകർപ്പ് എടുക്കുന്നതിനും,  വിതരണം ചെയ്യുന്നതിനും, പരിശോധിക്കുന്നതിനും, 

 മാറ്റങ്ങൾ വരുത്തുന്നതിനും,     മെച്ചപ്പെടുത്തുന്നതിനും ഉപയോക്താവിന് സ്വാതന്ത്ര്യം നൽകുന്ന

സോഫ്റ്റ്‌വെയർ.

ഉദാ: -  ഗ്നു / ലിനക്സ്, ജിമ്പ്,  മോസില്ല ഫയർ‌ഫോക്സ്, ഓപ്പൺ‌ഓഫീസ്.ഒആർജി

      സ്വതന്ത്ര സോഫ്റ്റ് വെയർ നൽകുന്ന നാല് സ്വാതന്ത്ര്യങ്ങൾ (Four Freedoms of Free 

Software)

Freedom 0 -     ഏത്ആവശ്യത്തിനും പ്രോഗ്രാം ഉപയോഗിക്കാനുള്ളസ്വാതന്ത്ര്യം.

Freedom 1 -     പ്രോഗ്രാം എങ്ങനെ പ്രവർത്തിക്കുന്നുവെന്ന് പഠിക്കാനുള്ളസ്വാതന്ത്ര്യം. 

Freedom 2 -     സോഫ്റ്റ്‌വെയറിന്റെ പകർപ്പുകൾ വിതരണം ചെയ്യാനുള്ളസ്വാതന്ത്ര്യം.

Freedom 3 -   പ്രോഗ്രാം മെച്ചപ്പെടുത്തുന്നതിനുള്ളസ്വാതന്ത്ര്യം.
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  ഫ്രീവെയറും ഷെയർവെയറും (Freeware and Shareware)

 ഫ്രീവെയർ (Freeware)  ഷെയർവെയർ (Shareware)

  പരിധിയൊന്നുമില്ലാതെ സൗജന്യമായി

  ഉപയോഗിക്കാൻസാധിക്കുന്ന

  പകർപ്പവകാശം ഉള്ള സോഫ്റ്റ്‌വെയർ.

 കൊമേർഷ്യൽ സോഫ്റ്റ്‌വെയർ. 

   വാങ്ങുന്നതിന് മുമ്പ് തന്നെ

  സോഫ്റ്റ്‌വെയറിനെ പരിചയപ്പെടാൻ

സാധിക്കുന്നു.

  എല്ലാ സവിശേഷതകളും സൗജന്യമാണ്.   എല്ലാ സവിശേഷതകളും ലഭ്യമാവുകയില്ല.

  ഫ്രീവെയർ പ്രോഗ്രാമുകൾ

  വിലയില്ലാതെയാണ് വിതരണം ചെയ്യുന്നത്.

   ഷെയർവെയർ വില കൊടുത്തും

  അല്ലാതെയും വിതരണം ചെയ്യുന്നു.

  ഉടമസ്ഥാവകാശമുള്ള സോഫ്റ്റ്‌വെയർ (Proprietary software)

•     ഡെവലപ്പറുടെ പൂർണ്ണഅധികാരപരിധിയിൽ വരുന്ന സോഫ്റ്റ്‌വെയറാണിത്.  അനുമതിയില്ലാതെ

   പകർത്താനോ വിതരണം ചെയ്യാനോ പാടുള്ളതല്ല.

• ഉദാ:-    മൈക്രോസോഫ്റ്റ് വിൻഡോസ് ഓപ്പറേറ്റിംഗ് സിസ്റ്റം,  എംഎസ് ഓഫീസ്

 ഹ്യൂമൻവെയർ (Humanware)

•     കമ്പ്യൂട്ടർ ഉപയോഗിക്കുന്നആളുകളെയാണ് ഹ്യൂമൻവെയർ /  ലൈവ്‌വെയർ എന്നുപറയുന്നത്. 

• ഉദാ:-  കമ്പ്യൂട്ടർ പ്രോഗ്രാമർ,  കമ്പ്യൂട്ടർ ഓപ്പറേറ്റർ,  സിസ്റ്റം അഡ്‌മിനിസ്‌ട്രേറ്റർ.

 മാതൃക ചോദ്യങ്ങൾ

1. 1  ബൈറ്റ് =...............ബിറ്റ്‌സ്.

2.        അസംബ്ലി ഭാഷയെ യന്ത്രഭാഷയിലേക്ക് തർജ്ജമ ചെയ്യുന്ന സോഫ്റ്റ് വെയറിന്റെ പേരെഴുതുക

3. HDMI    യുടെ പൂർണ്ണ രൂപം എഴുതുക.

4. OMR   ന്റെ പൂർണ്ണരൂപം ............... ആകുന്നു.

5.      ഒരു കമ്പ്യൂട്ടർ സിസ്‌റ്റത്തിൽ രജിസ്റ്ററുകളുടെ പ്രാധാന്യത്തെക്കുറിച്ച് എഴുതുക.   ഏതെങ്കിലും രണ്ട്

  രജിസ്റ്ററുകളുടെ പേര് പറയുക.

6.      മദർബോർഡിലെ ഏതെങ്കിലും നാല് പോർട്ടുകളുടെ പേര് പറയുക.

7.         സ്വതന്ത്രഓപ്പൺ സോഴ്സ് സോഫ്റ്റ് വെയറിന് രണ്ട് ഉദാഹരണങ്ങൾ നൽകുക.

8. RAM, ROM    എന്നിവ തമ്മിലുള്ള വ്യത്യാസം എഴുതുക

9.    ഇൻപുട്ട് ഉപകരണം എന്നാൽഎന്ത്?      ഏതെങ്കിലും രണ്ട് ഇൻപുട്ട് ഉപകരണങ്ങളെക്കുറിച്ച് ചുരുക്കി

വിശദീകരിക്കുക.
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10.    ഔട്ട്പുട്ട് ഉപകരണങ്ങൾഎന്നാൽഎന്ത്?     സാധാരണയായി ഉപയോഗിക്കുന്നഔട്ട്പുട്ട് ഉപകരണങ്ങൾ

പട്ടികപ്പെടുത്തുക.

11.        താഴെ കൊടുത്തിരിക്കുന്ന ഉപകരണങ്ങളെ ഇൻപുട്ട് ഉപകരണങ്ങളായുംഔട്ട്പുട്ട് ഉപകരണങ്ങളായും തരം

തിരിക്കുക.

(Joystick, Scanner, Plotter, Microphone, Printer, Mouse, VDU, Speaker)

12. dot matrix printers  ഉം and laser printers   ഉം താരതമ്യം ചെയ്യുക.

13. Non-impact     പ്രിന്ററുകൾക്ക് രണ്ട് ഉദാഹരണങ്ങൾ നൽകുക.

14.       ഏത് പ്രിന്ററാണ്‌പോർട്ടബിൾ പ്രിന്ററായി വ്യാപകമായി ഉപയോഗിക്കുന്നത് ? എന്തുകൊണ്ട്?

15. നിർവചിക്കുക.    (a) പ്ലോട്ടർ (b) 3D പ്രിന്റർ

16. ഇ-   വേസ്റ്റ് എന്നാൽ എന്താണ്? ഇ-    വേസ്റ്റ് നിർമാർജനം പട്ടികപ്പെടുത്തി വിശദീകരിക്കുക

17.     ഗ്രീൻ കമ്പ്യൂട്ടിംഗ് എന്ന പദം നിർവചിക്കുക.      നിങ്ങൾക്ക് എങ്ങനെയാണ് ഗ്രീൻ കമ്പ്യൂട്ടിംഗ് നടപ്പിലാക്കാൻ

കഴിയുക?

18. നിർവചിക്കുക. (a) അസംബ്ലർ (b) ഇന്റർപ്രറ്റർ (c) കംപൈലർ

19.   ഓപ്പറേറ്റിങ്ങ് സിസ്റ്റം നിർവചിക്കുക.     ഓപ്പറേറ്റിങ്ങ് സിസ്റ്റത്തിന് രണ്ട് ഉദാഹരണം നൽകുക.

20.     ഓപ്പറേറ്റിംഗ് സിസ്റ്റത്തിന്റെ നാല് ധർമ്മങ്ങൾഎഴുതുക.

21.       ഫ്രീആന്റ് ഓപ്പൺ സോഴ്സ് സോഫ്റ്റ് വെയർ എന്നാലെന്ത്?     രണ്ട് ഉദാഹരണങ്ങൾ നൽകുക.

22.         സോഫ്റ്റ് വെയറുകൾസ്വതന്ത്രമായും ഓപ്പൺ സോഴ്സായും നിർമ്മിക്കുമ്പോൾ ഉണ്ടായിരിക്കേണ്ട നാല്

 സ്വാതന്ത്ര്യങ്ങൾഏതെല്ലാമാണ്?

23.    ഫ്രീവെയറും ഷെയർവെയറും താരതമ്യം ചെയ്യുക.
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അധ്യായം 3

ഡാറ്റാ പ്രോസസിങ്‌ ഇലക്ട്രോണിക് സ്‌പ്രെഡ്ഷീറ്റിലൂടെ

  സ്പ്രെഡ്ഷീറ്റ് സോഫ്റ്റ് വെയർ(Spreadsheet Software)

ടാബുലാർ രൂപത്തിൽ നമ്പറുകളും പ്രതീകങ്ങളും പ്രോസസ്സ് ചെയ്യുന്നതിനുള്ള സോഫ്റ്റ് വെയർ 
പാക്കേജ്. 

ഉദാഹരണം: Lotus1-2-3, Quattro Pro, Microsoft Excel, Open Office Calc.

ഒരു ഇലക്ട്രോണിക് സ്പ്രെഡ്ഷീറ്റിന്റെ സവിശേഷതകൾ (Features of an electronic 
spreadsheet)

മാർക്ക്ലിസ്റ്റുകൾ പോലെ വലിയ അളവിലുള്ള ഡാറ്റ ടാബുലാർ രൂപത്തിൽ സംഭരിക്കുന്നു.

സമവാക്യങ്ങൾ ഉപയോഗിച്ച ്സംഖ്യാ കണക്കുകൂട്ടലുകൾ, താരതമ്യങ്ങൾ, വിശകലനം എന്നിവ നടത്തുന്നു.

അനുബന്ധ ഡാറ്റയിൽ എന്തെങ്കിലും മാറ്റം വരുത്തിയാൽ ഫലങ്ങൾ സ്വയം അപ്‌ഡേറ്റുചെയ്യുന്നു.   

ടെക്സ്റ്റ് ഫോർമാറ്റിംഗ് സവിശേഷതകൾ നൽകുന്നു.

സോർട്ടിംഗ്, ഫിൽ‌ട്ടറിംഗ് മുതലായ സൗകര്യങ്ങൾ  വാഗ്ദാനം ചെയ്യുന്നു.

ഗ്രാഫിക്കൽ ഡാറ്റ വിശകലനത്തിനായി ചാർട്ടുകൾ സൃഷ്ടിക്കുന്നു.

വർക്ക്‌ഷീറ്റ് (Worksheet)

ഒരു സ്പ്രെഡ്‌ഷീറ്റിൽ ഒന്നോ അതിലധികമോ വർക്ക്‌ഷീറ്റുകൾ അടങ്ങിയിരിക്കാം. സാധാരണയായി, 
നമുക്ക് Sheet1, Sheet2, Sheet3 എന്നീ പേരുള്ള മൂന്ന് വർക്ക്‌ഷീറ്റുകൾ കാണാം.

വരികളും നിരകളൂം (Rows and columns)

വരികളിലും നിരകളിലും ഒരു വർക്ക്‌ഷീറ്റ് ക്രമീകരിച്ചിരിക്കുന്നു. കോളം ഹെഡർ നിരകളുടെ പേരുകൾ A,
B, C, .., Z, AA, AB, .... മുതലായവ പ്രദർശിപ്പിക്കുന്നു. റോ  ഹെഡർ വരി നമ്പറുകൾ 1, 2, 3 ,. . . 
തുടങ്ങിയവ പ്രദർശിപ്പിക്കുന്നു.

സെൽ (Cell)

ഒരു നിരയും വരിയും കൂടിചേരുന്നതാണ് സെൽ. വർക്ക്ഷീറ്റിന്റെ ഏറ്റവും ചെറിയ യൂണിറ്റാണ് ഇത്. 
ഓരോ സെല്ലിനും ഒരു അഡ്രസ്സ് ഉണ്ട്. (ഉദാ: A5).
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റേഞ്ച് (Range)

ഒരു ചതുരാകൃതിയിലുള്ള ഏരിയ സൃഷ്ടിക്കുന്ന അടുത്തുള്ള സെല്ലുകളുടെ ഒരു കൂട്ടമാണ് റേഞ്ച്. 
ഏറ്റവും ചെറിയ റേഞ്ച് ഒരൊറ്റ സെല്ലും, ഏറ്റവും വലിയ റേഞ്ച് മുഴുവൻ വർക്ക്ഷീറ്റും ആണ്. ആദ്യ 
സെല്ലിന്റെ അഡ്രസ്സും അവസാനത്തെ സെല്ലിന്റെ അഡ്രസ്സും ചേർത്താണ് ഒരു  റേഞ്ച് 
കാണിക്കുന്നത്.

ഉദാ:   B3: E10

ഒരു സ്പ്രെഡ്‌ഷീറ്റ് ജാലകത്തിന്റെ ഘടകങ്ങൾ (Components of a Spreadsheet window)
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മെനു ബാർ - File, Edit, View, Insert, Format, Tools, Data, Window, Helpഎന്നിവ പോലുള്ള 
മെനു ഓപ്‌ഷനുകൾ‌ അടങ്ങിയിരിക്കുന്നു. ഓരോന്നിലും സ്പ്രെഡ്ഷീറ്റിൽ പ്രവർത്തനങ്ങൾ നടത്താനുള്ള  
വിവിധ ഓപ്ഷനുകൾ അടങ്ങിയിരിക്കുന്നു.

ടൂൾബാറുകൾ (സ്റ്റാൻഡേർഡ് & ഫോർമാറ്റിംഗ്) - സാധാരണയായി ഉപയോഗിക്കുന്ന മെനു 
കമാൻഡുകൾക്കായി ഐക്കണുകളോ ഷോർട്ട് കട്ട് ബട്ടണുകളോ അടങ്ങിയിരിക്കുന്നു.

ഫോർമുല ബാർ - നെയിം ബോക്സ്, ഫംഗ്ഷൻ വിസാർഡ്, സം ബട്ടൺ, ഫംഗ്ഷൻ ബട്ടൺ, ഇൻപുട്ട് ലൈൻ 
എന്നിവ ഉൾപ്പെടുന്നു.

ഷീറ്റ് ടാബ് - സ്പ്രെഡ്ഷീറ്റിൽ ലഭ്യമായ വർക്ക്ഷീറ്റുകൾ കാണിക്കുന്നു.

സ്റ്റാറ്റസ് ബാർ - വർക്ക്‌ഷീറ്റിനെക്കുറിച്ചുള്ള നിലവിലെ നില പ്രദർശിപ്പിക്കുന്നു.

വർക്ക് ഷീറ്റിൽ ഡാറ്റ രേഖപ്പെടുത്തൽ (Entering Data in a Worksheet)

ഒരു സെല്ലിൽ ഡാറ്റ നൽകുന്നതിന്, ആവശ്യമുള്ള സെല്ലിൽ സെൽ പോയിന്റർ സ്ഥാപിക്കുക, തുടർന്ന്
ഡാറ്റ ടൈപ്പുചെയ്യുക. ഒരു സെല്ലിൽ നൽകാവുന്ന വ്യത്യസ്ത തരം ഡാറ്റകൾ ഇനിപ്പറയുന്നവയാണ്:

സംഖ്യകൾ(Numbers) –   സംഖ്യകൾ ഒരു cell    ൻറെ വലതുഭാഗത്തേക്ക് ചേർന്നിരിക്കും. ഉദാ: 35, 225.75, 
-50

ടെക്സ്റ്റ് (Text) –   സാധാരണയായി Text   ഒരു cell    ൻറെ ഇടതുഭാഗത്തേക്ക് ചേർന്നിരിക്കും. ഉദാ: Mark1, 
Mark2

തീയതിയും സമയവും(Date and Time) –       ഒരു തീയതിയുടെ യുടെ വിത്യസ്ത ഭാഗങ്ങൾ വേർതിരിക്കുവാൻ / 
(slash)  – ചിഹ്നമോ (hyphen)  ചിഹ്നമോ ഉപയോഗിക്കുന്നു.    സമയത്തിൻറെ വിവിധ ഭാഗങ്ങൾ

 വേർതിരിക്കുവാൻ : (colon) ഉപയോഗിക്കുന്നു. ഉദാ: 12/01/2014, 10:00:00 AM

സൂത്രവാക്യം(Formula) – ‘=’      ചിഹ്നത്തിൽ തുടങ്ങുന്ന ഗണിതസമവാക്യങ്ങൾആണ് ഫോർമുല. 
     സൂത്രവാക്യങ്ങൾ ഉള്ള സെല്ലുകൾഅതാതിൻറെ ഫലം കാണിക്കുന്നു.  ഉദാ: = A1 + B1.

സ്പ്രെഡ് ഷീറ്റ് സേവ് ചെയ്യൽ(Saving a Spreadsheet)

ഒരു സ്പ്രെഡ്ഷീറ്റ് 3 തരത്തിൽ സേവ് ചെയ്യാം.

File ---> Save

സ്റ്റാൻഡേർഡ് ടൂൾബാറിലെ Save ബട്ടൺ ഉപയോഗിച്ച ്  

Ctrl+S (കീബോർഡ് ഷോർട് കട്ട് )

ഫയൽ .ods എന്ന എക്സ്റ്റൻഷൻ ഉപയോഗിച്ച ്സേവ് ചെയ്യുന്നു.
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സ്പ്രെഡ് ഷീറ്റ് അടക്കുന്നതും തുറക്കുന്നതും 

സ്പ്രെഡ്ഷീറ്റ് ക്ലോസ് ചെയ്യുന്നതിന് File->close.

ഒരു സ്പ്രെഡ്ഷീറ്റ് അപ്ലിക്കേഷൻ അവസാനിപ്പിക്കണമെങ്കിൽ File -> Exit.

നേരത്തെ സേവ് ചെയ്തിട്ടുള്ള ഒരു സ്പ്രെഡ് ഷീറ്റ് ഫയൽ തുറക്കുവാൻ  File ->Open

സ്പ്രെഡ്ഷീറ്റ് ഫോർമാറ്റിംഗ് (Formatting a spreadsheet)

സെൽ

ഫോർമാറ്റിംഗ്

Format->cells.

നമ്പർ ഫോർമാറ്റിംഗ് Format cell 
ഡയലോഗ് ബോക്സിലെ 
numbers ടാബ് 
ഉപയോഗിക്കുന്നു

സെല്ലിലെ നമ്പറിന്റെ  രൂപം , 
Percentage, Currency, 
Date, Time, Scientific  
മുതലായവയിലേക്ക് മാറ്റാം.

ഫോണ്ട്  
ഫോർമാറ്റിംഗ്

Format cell 
ഡയലോഗ് ബോക്സിലെ 
font ടാബ് 
ഉപയോഗിക്കുന്നു

ഒരു സെല്ലിൽയോ  റേഞ്ചിലെയോ
fontൻറെ  പേര്, വലിപ്പം, 
രൂപഭംഗി എന്നിവ മാറ്റുന്നു.

 ഉള്ളടക്ക വിന്യാസം Format cell 
ഡയലോഗ് ബോക്സിലെ 
Alignment ടാബ് 
ഉപയോഗിക്കുന്നു

ഒരു സെല്ലിലെ ഉള്ളടക്കം 
തിരശ്ചീനമായും ലംബമായും 
വിന്യസിക്കുവാൻ 
ഇതുപയോഗിക്കുന്നു

ബോർഡർ 
ചിട്ടപ്പെടുത്താൻ 

Format cell 
ഡയലോഗ് ബോക്സിലെ  
Borders tab 
ഉപയോഗിക്കുന്നു

ബോർഡറും ടെക്സ്റ്റും തമ്മിലുള്ള 
അകലം കൊടുക്കുവാൻ 
ഉപയോഗിക്കുന്നു.

പശ്ചാത്തല നിറം 
നൽകാൻ

Format cell 
ഡയലോഗ് ബോക്സിലെ  
Background  tab 
ഉപയോഗിക്കുന്നു

ഒരു cell നെ പശ്ചാത്തല നിറം 
നൽകുവാൻ ഇത് 
ഉപയോഗിക്കുന്നു.

നിരകളുടെ 
ഫോർമാറ്റിംഗ്

Format -> 
Column

ഒരു നിരയുടെ വീതി 
വ്യത്യാസപ്പെടുത്തുവാൻ

ആവശ്യമായ കോളം സെലക്ട് ചെയ്യുക.
Format -> Column  -> Width 

ഒരു നിരയെ 
മറയ്ക്കുവാൻ

ആവശ്യമായ കോളം സെലക്ട് ചെയ്യുക.
Format -> Column  -> Hide

ഒരു നിരയെ വീണ്ടും 
കാണുവാൻ

അടുത്തുള്ള നിരകൾ തെരഞ്ഞെടുക്കുക 
Format -> Column  -> Show

വരികളുടെ 
ഫോർമാറ്റിംഗ്

ഒരു വരിയുടെ ഉയരം 
നല്കാൻ

Format -> Row ->Height

ഒരു വരിയുടെ Format -> Row ->OptimalHeight
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Format -> Row

ഉചിതമായ കുറഞ്ഞ 
ഉയരം കൊടുക്കുവാൻ

ഒരു വരിയെ 
മറയ്ക്കുവാൻ

വരിയിലെ ഒരു സെൽ തിരഞ്ഞെടുക്കുക.
Format -> Row -> Hide

ഒരു വരിയെ വീണ്ടും  
കാണുവാൻ

മറഞ്ഞിരിക്കുന്ന വരിയുടെ മുകളിലും താഴെയുമുള്ള വരികൾ 
തിരഞ്ഞെടുക്കുക.
Format ->Row -> Show.

ഷീറ്റ്  ഫോർമാറ്റിംഗ്

ഒരു ഷീറ്റിന്റെ 
പേരുമാറ്റാൻ

Format->Sheet->Rename

ഒരു ഷീറ്റ് മറയ്ക്കാൻ Format->Sheet->Hide

മറഞ്ഞിരിക്കുന്ന 
ഷീറ്റുകൾ 
കാണുന്നതിന്

Format->Sheet->Show

സെൽ ലയനം ഒന്നിലധികം സെല്ലുകളെ ലയിപ്പിച്ച ്ഒന്ന് ആക്കുന്നതിനെ സെൽ ലയനം  എന്ന് 
പറയുന്നു
Format -> Merge Cells.

സെൽ കൂട്ടി ചേർക്കൽ (Inserting cell) 

ഒരു സെൽ ചേർക്കാൻ, Insert മെനുവിൽ നിന്ന് Cells ഓപ്ഷൻ തിരഞ്ഞെടുക്കുക(Insert -> 
Cells).

വരി  കൂട്ടി ചേർക്കൽ  (Inserting row)

Insert മെനുവിന്റെ Rows ഓപ്ഷൻ ഉപയോഗിച്ച ്വരികൾ കൂട്ടിചേർക്കാം(Insert ->Rows).

നിര കൂട്ടി ചേർക്കൽ(Inserting column)

Insert മെനുവിന്റെ Columns ഓപ്ഷൻ ഉപയോഗിച്ച ്നിരകൾ കൂട്ടിചേർക്കാൻ കഴിയും (Insert-> 
Columns).

വർക്ക് ഷീറ്റ് കൂട്ടി ചേർക്കൽ(Inserting a worksheet)

Insert-> Sheet തിരഞ്ഞെടുക്കുക അല്ലെങ്കിൽ ഷീറ്റ് ടാബിൽ (+) അമർത്തുക.

സെല്ലുകൾ/വരികൾ/നിരകൾ എന്നിവ നീക്കം ചെയ്യൽ (Deleting Cells/Row/ Column)

ഇല്ലാതാക്കേണ്ട സെൽ, വരി അല്ലെങ്കിൽ നിര തിരഞ്ഞെടുക്കുക. Edit മെനുവിൽ നിന്ന് Delete 
Cells എന്ന ഓപ്ഷൻ തിരഞ്ഞെടുക്കുക (Edit-> Delete Cells).

വർക്ക് ഷീറ്റ്  നീക്കം ചെയ്യൽ (Deleting a worksheet)

Edit മെനുവിൽ നിന്ന്, Sheet ഉപമെനുവിൽ നിന്ന് Delete ഓപ്ഷൻ തിരഞ്ഞെടുക്കുക(Edit-> 
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Sheet-> Delete).

സ്പ്രെഡ് ഷീറ്റിലെ എഡിറ്റിംഗ് സവിശേഷതകൾ

റേഞ്ച് നിറയ്ക്കൽ

സെല്ലുകളുടെ റേഞ്ച്  ഒരേ വില കൊണ്ട്
നിറയ്ക്കുവാൻ

ഒരു വില സെല്ലിൽ കൊടുത്തതിനു ശേഷം 
അത് നിറക്കേണ്ട റേഞ്ച് 
തെരഞ്ഞെടുക്കുക. അതിനുശേഷം Edit 
Fill ഓപ്ഷൻ ക്ലിക്ക് ചെയ്യുക . പിന്നീട് 
നിറക്കേണ്ട ദിശ തെരഞ്ഞെടുക്കുക.

സെല്ലുകളുടെ റേഞ്ച്  ഒരു സംഖ്യാ 
ശ്രേണി കൊണ്ട് നിറയ്ക്കുവാൻ

ആരംഭ വില കൊടുത്തതിനു ശേഷം  
സെല്ലുകളുടെ റേഞ്ച് തെരഞ്ഞെടുക്കുക. 
Edit FillSeries എന്ന ഓപ്ഷൻ 
തെരഞ്ഞെടുക്കുക. അതിനുശേഷം 
കാണുന്ന ഡയലോഗ് ബോക്സിൽ ,ദിശ, 
സീരീസ്, തരം, ആരംഭ വില, അവസാന 
വില എന്നിവ കൊടുക്കാവുന്നതാണ്.

സെൽ പകർത്തലും 
നീക്കലും

ഒരു സെല്ലിലെയോ റേഞ്ചിലെയോ ഉള്ളടക്കങ്ങൾ മറ്റൊരു സെല്ലിലേക്കോ
റേഞ്ചിലേക്കോ പകർത്താൻ  റേഞ്ച്  തെരഞ്ഞെടുത്ത ശേഷം Edit copy  എന്ന
ഓപ്ഷൻ തെരഞ്ഞെടുക്കുക.
എവിടെയാണോ പകർത്തേണ്ടത് ആ cell    തെരഞ്ഞെടുത്തു Edit  paste
ഓപ്ഷൻ തെരഞ്ഞെടുക്കുക.
ഒരു സെല്ലിലെയോ റേഞ്ചിലെയോ ഉള്ളടക്കങ്ങൾ മറ്റൊരു സെല്ലിലേക്കോ
റേഞ്ചിലേക്കോ മാറ്റുവാൻ,  റേഞ്ച്  തെരഞ്ഞെടുത്ത ശേഷം Edit   cut  എന്ന
ഓപ്ഷൻ തെരഞ്ഞെടുക്കുക.

സെൽ ഉള്ളടക്കം 
നീക്കം ചെയ്യൽ

സെൽ ഉള്ളടക്കം നീക്കം ചെയ്യുന്നതിനായി Edit  DeleteContents എന്ന മെനു 
ഓപ്ഷൻ ഉപയോഗിക്കാം.

സെൽ റഫറൻസ്
സ്പ്രെഡ് ഷീറ്റിലെ ഓരോ സെല്ലിനും ഒരു സെൽ റഫറൻസ് ഉണ്ട്. അത് സെല്ലിന്റെ വിലാസമാണ്. രണ്ട് 
തരത്തിലുള്ള സെൽ റഫറൻസ് ഉണ്ട്.  1) Relative സെൽ റഫറൻസ് 2) Absolute സെൽ റഫറൻസ്
1) Relative സെൽ റഫറൻസ്
സ്പ്രെഡ് ഷീറ്റിലെ മിക്കവാറും എല്ലാ റഫറൻസും റിലേറ്റീവ് ആണ്. കോപ്പി ചെയ്യുമ്പോഴോ  Autofill 
സവിശേഷതയുടെ കൂടെ ഉപയോഗിക്കുമ്പോഴോ റഫറൻസ് തനിയെ മാറുകയും ക്രമീകരിക്കപ്പെടുകയും ചെയ്യുന്ന
റഫറൻസ് ആണ് റിലേറ്റീവ് റഫറൻസ്.
2)Absolute സെൽ റഫറൻസ് 
Absolute സെൽ   റഫറൻസ് എല്ലായിപ്പോഴും എവിടെയൊക്കെ കോപ്പി ചെയ്താലും മാറ്റമില്ലാതെ ഇരിക്കും. 
ഒരു റഫറൻസ് absolute  ആക്കുവാൻ  ‘$’ ചിഹ്നം നിരയുടെയും വരിയുടെയും മുൻപിൽ ചേർക്കുക. A3 എന്ന 
സെൽ അബ്സല്യൂട്ട് റഫറൻസ് ആക്കുവാൻ  $A$3 എന്ന് സൂത്രവാക്യത്തിൽ  ഉപയോഗിക്കുക.

വർ‌ക്ക്‌ഷീറ്റിലെ വരികളും നിരകളും നിശ്ചലമാക്കൽ (Freezing rows and columns in a 
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worksheet)

വർക്ക്ഷീറ്റ് സ്ക്രോൾ ചെയ്യുമ്പോൾ തിരഞ്ഞെടുത്ത നിരകളോ വരികളോ നിശ്ചലമാക്കി മാറ്റുന്ന 
പ്രവർത്തനമാണ് ഫ്രീസുചെയ്യൽ. വരികൾ / നിരകൾ മരവിപ്പിക്കാൻ, റോ ഹെഡർ/ കോളം ഹെഡർ 
ക്ലിക്കുചെയ്യുക. അതിനു ശേഷം Window മെനുവിൽ നിന്ന് Freeze ഓപ്ഷൻ തിരഞ്ഞെടുക്കുക.

ഹെഡറുകളും ഫൂട്ടറുകളും (Headers and footers)

ഒരു ഡോക്യൂമെന്റിലെ  എല്ലാ പേജിന്റെയും മുകളിൽ ദൃശ്യമാകുന്ന വാചകമാണ് ഹെഡറുകൾ. ഓരോ 
പേജിന്റെയും ചുവടെ ദൃശ്യമാകുന്ന വാചകമാണ് ഫൂട്ടറുകൾ. Insert മെനുവിന്റെ Headers & 

Footers എന്ന ഓപ്ഷൻ ഉപയോഗിച്ച ്അവ ഒരു സ്പ്രെഡ്ഷീറ്റിൽ നൽകാം(Insert-> Headers & 
Footers).

ഒരു സ്പ്രെഡ്‌ഷീറ്റ് പ്രിന്റ് ചെയ്യൽ (Printing a Spreadsheet)

ഒരു സ്പ്രെഡ്‌ഷീറ്റ് 3 തരത്തിൽ പ്രിന്റ് ചെയ്യാൻ കഴിയും:

File->Print

Ctrl+P (കീബോർഡ് ഷോർട് കട്ട്)

സ്റ്റാൻഡേർഡ് ടൂൾ ബാറിലെ Print ബട്ടൺ ഉപയോഗിച്ച്

PDF ആയി എക്‌സ്‌പോർട്ടുചെയ്യൽ (Export as PDF)

ഏത് പ്ലാറ്റ്ഫോമിലും PDF ഫയലുകൾ കാണാൻ കഴിയും. ഇത് എളുപ്പത്തിൽ എഡിറ്റുചെയ്യാനാകില്ല. 

File->Export As PDF എന്ന മെനു ഓപ്ഷൻ ഉപയോഗിച്ച ്ഒരു വർക്ക്ഷീറ്റ് PDF ഫോർമാറ്റിലേക്ക് 
എക്സ്പോർട്ട് ചെയ്യാൻ കഴിയും.

                         മാതൃക ചോദ്യങ്ങൾ
1. ഒരു വർക്ക് ഷീറ്റിൽ വരിയും നിരയും കൂടിച്ചേരുമ്പോൾ --------------- ഉണ്ടാകുന്നു.

2. ഒരു വർക്ക്‌ഷീറ്റിൽ D10:H25 എന്നതിനെ ----------- എന്ന് വിളിക്കുന്നു.

3. പ്രധാനപ്പെട്ട കമാൻഡുകളുടെ ഷോർട്ട് കട്ട് ബട്ടണുകൾ ------------------- ൽ ഉണ്ട്.

4. വർക്ക്ഷീറ്റ് വിൻഡോയുടെ ______ മെനുവിൽ സേവ്, പ്രിന്റ് കമാൻഡുകൾ ലഭ്യമാണ്.

5. ഒരു വർക്ക്ഷീറ്റിൽ നിങ്ങൾ എങ്ങനെ ഒരു സെൽ കൂട്ടിച്ചേർക്കും?

6. ഒരു നിരയോ വരിയോ നിശ്ചലമാക്കി മാറ്റുന്നതിനുള്ള പ്രവർത്തനം -------------എന്ന് 

അറിയപ്പെടുന്നു.

7. വർക്ക്ഷീറ്റ് വിൻഡോയുടെ പ്രധാന ഘടകങ്ങൾ വിശദീകരിക്കുക.

8. ഒരു സ്‌പ്രെഡ്‌ഷീറ്റിലെ ഹെഡറും ഫൂട്ടറും എന്നത് കൊണ്ട് നിങ്ങൾ എന്താണ് അർത്ഥമാക്കുന്നത്?
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അധ്യായം 4

    ഡേറ്റാ അനാലിസിസ് യൂസിങ് സ്പ്രെഡ്ഷീറ്റ്

       ‍ ഒരു പ്രത്യേക ക്രമത്തിൽ നിർദ്ദിഷ്ട മൂല്യങ്ങൾ ഉപയോഗിച്ച് കണക്കുകൂട്ടലുകൾ നടത്തുവാന് വേണ്ടി

  നിർവചിച്ചിരിക്കുന്ന സൂത്രവാക്യമാണ് ഫംഗ്ഷൻ.   ഒരു ഫംഗ്‌ഷൻ ഉപയോഗിക്കുന്നതിന്,  സെൽ

   തിരഞ്ഞെടുത്തതിന് ശേഷം ടൂൾബാറിലെ f(x)       ബട്ടണിൽ ക്ലിക്ക് ചെയ്ത് ഫംഗ്ഷൻ വിസാർഡിൽ നിന്ന്

  ഉചിതമായ ഫംഗ്‌ഷനുകൾ തിരഞ്ഞെടുക്കാം.

Built-in Functions in Spreadsheet

Mathematical Functions

Function Syntax Description Example

1 SUM( )

SUM(Num1,Num2,Num
3, ...)                
SUM(cell address : cell 
address)

   ഒരു സെൽ പരിധിക്കുള്ളിൽ

   വരുന്നഎല്ലാ മൂല്യങ്ങളുടേയും

  ‍   ആകെ തുക കണ്ടെത്താന് ഈ

 ഫംഗ്ഷൻ ഉപയോഗിക്കുന്നു.

2 ROUND( )
=ROUND (Number, 
num_digits)

     ദശാംശ സംഖ്യകളെ റൗണ്ട്

    ചെയ്ത് മാറ്റുന്നതിന് വേണ്ടിഈ

 ഫംഗ്ഷൻ ഉപയോഗിക്കുന്നു.

3 ROUNDUP ( ) =ROUNDUP (umber, 
num_digits)

   തന്നിരിക്കുന്ന ദശാംശ സംഖ്യയുടെ

‍ ‍  മൂല്യത്തേക്കാള് ഉയര്ന്ന

     വിലയിലേക്ക് റൗണ്ട് ചെയ്ത്

   മാറ്റുന്നതിന് വേണ്ടിഈഫംഗ്ഷൻ

ഉപയോഗിക്കുന്നു.

4 ROUNDDOW
N( )

=ROUNDDOWN 
(number, num_digits)    തന്നിരിക്കുന്ന ദശാംശ സംഖ്യയുടെ

‍  മൂല്യത്തേക്കാള് കുറഞ്ഞ
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      വിലയിലേക്ക് റൗണ്ട് ചെയ്ത്

   മാറ്റുന്നതിന് വേണ്ടിഈഫംഗ്ഷൻ

ഉപയോഗിക്കുന്നു.

5 COUNTIF ( ) =COUNTIF(Range, 
Criteria)

   ഒരു നിശ്ചിത മാനദണ്ഡത്തിന്റെ

‍  ‍ അടിസ്ഥാനത്തില് ഒരു സെല്

  പരിധിക്കുള്ളിലെ മൂല്യങ്ങളുടെ

   എണ്ണം കണ്ടെത്തുന്നതിന് വേണ്ടി

  ഈഫംഗ്ഷൻ ഉപയോഗിക്കുന്നു.

Statistical functions - Operate on a set of data and give summarised results.

Functio
n

Syntax Description Example

1 AVERAG
E( )

AVERAGE(num
1,[num2], .)

 ‍ ‍   ഒരു സെല് പരിധിക്കുള്ളിലെ മൂല്യങ്ങളുടെ

     ശരാശരി കണ്ടെത്തുന്നതിന് വേണ്ടിഈ

 ഫംഗ്ഷൻ ഉപയോഗിക്കുന്നു.

2 MAX ( ) MAX(num1,
[num2], ..)

 ‍ ‍  ‍  ഒരു സെല് പരിധിക്കുള്ളിലെ മൂല്യങ്ങളില് നിന്ന്

     ഏറ്റവും വലിയ വില കണ്ടെത്തുന്നതിന് വേണ്ടി

  ഈഫംഗ്ഷൻ ഉപയോഗിക്കുന്നു.

3 MIN ( ) MIN(num1, 
[num2], ...)

 ‍ ‍  ‍  ഒരു സെല് പരിധിക്കുള്ളിലെ മൂല്യങ്ങളില് നിന്ന്

     ഏറ്റവും ചെറിയ വില കണ്ടെത്തുന്നതിന് വേണ്ടി

  ഈഫംഗ്ഷൻ ഉപയോഗിക്കുന്നു.

4 COUNT 
( )

COUNT 
(Value1, 
Value2, Value3,
...)

 ‍    ഒരു സെല് പരിധിക്കുള്ളിലെ മൂല്യങ്ങളുടെ എണ്ണം

    കണ്ടെത്തുന്നതിന് വേണ്ടിഈഫംഗ്ഷൻ

ഉപയോഗിക്കുന്നു.
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Logical functions - Used for checking a test condition.

Func
tion

Syntax Description Example

1 IF ( )

IF (Test, 
Then_value,
Otherwise_v
alue)

    ഒരു നിശ്ചിത മാനദണ്ഡം ശെരിയോ

  ‍  തെറ്റോ എന്നതിന്റെഅടിസ്ഥാനത്തില്

‍   ‍ സെല് പരിധിക്കുള്ളിലെ രണ്ട് മൂല്യങ്ങളില്

     ഒന്ന് കണ്ടെത്തുന്നതിന് വേണ്ടിഈ

 ഫംഗ്ഷൻ ഉപയോഗിക്കുന്നു.

2 AND 
( )

AND (Logical
value1, 
Logical 
value2, .....)

AND( )    ഫംഗഷനുള്ളിലെ എല്ലാ

 ‍ മാനദണ്ഡങ്ങളും ശെരിയാണെങ്കില്

TRUE    എന്നും ഏതെങ്കിലും ഒരു

 ‍ മാനദണ്ഡം തെറ്റായാല് FALSE  എന്നും

 ‍ ‍ഈഫംഗ്ഷന് നല്കുന്നു.

3 OR 
( )

OR(Logical 
value1, 
Logical 
value2, .....)

OR( )    ഫംഗഷനുള്ളിലെ ഏതെങ്കിലും

    ‍ ഒരു മാനദണ്ഡം ശെരിയാണെങ്കില്

TRUE       എന്നും എല്ലാ മാനദണ്ഡങ്ങളും

‍ തെറ്റായാല് FALSE   എന്നുംഈ

‍ ‍ഫംഗ്ഷന് നല്കുന്നു.

4 NOT 
( )

NOT(Logical 
value)

NOT( )   ഫംഗഷനുള്ളിലെ മാനദണ്ഡം

‍ ശെരിയാണെങ്കില് FALSE  എന്നും

 ‍ മാനദണ്ഡം തെറ്റായാല് TRUE  എന്നും

 ‍ ‍ഈഫംഗ്ഷന് നല്കുന്നു.
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Text functions 

Functi
on

Syntax Description Example

1 UPPER
( )

UPPER(Tex
t)

UPPER( ) ‍  ഫംഗഷനുള്ളിള് നൽകിയിരിക്കുന്ന

  വാചകം വലിയക്ഷരത്തിലേക്ക് മാറ്റുന്നു.

2 LOWE
R ( )

LOWER(Tex
t)

LOWER( ) ‍  ഫംഗഷനുള്ളിള് നൽകിയിരിക്കുന്ന

  വാചകം ചെറിയക്ഷരത്തിലേക്ക് മാറ്റുന്നു.

3 LEN ( ) LEN(Text)
LEN( ) ‍  ഫംഗഷനുള്ളിള് നൽകിയിരിക്കുന്ന

   വാചകത്തിലെ അക്ഷ്രങ്ങളുടെ എണ്ണം

 കണ്ടെത്തുന്നതിന് ഉപയോഗിക്കുന്നു.

Nested functions -  ‍  ‍  ‍ ഒരു ഫംഗ്ഷനുള്ളില് മറ്റൊരു ഫംഗ്ഷന് ഉപയോഗിക്കുന്നതിനെ ഫംഗ്ഷന്
  നെസ്റ്റിഗ് എന്ന് പറയുന്നു.

Example Result

=IF ( AND ( 60>20, 67>=20,  ) ,"Pass", "Fail") Pass

=IF ( AND ( 60>20, 67>=80,  ) ,"Pass", "Fail") Fail

Sorting - ആരോഹണക്രമത്തിലോ അവരോഹണക്രമത്തിലോ ഒരു പട്ടികയിലെ ഡാറ്റ 
ക്രമീകരിക്കാൻ സോർട്ടിംഗ് ഉപയോഗിക്കുന്നു.

The following steps are used for sorting
1. Select the entire table
2. Click Data à Sort from the menu bar. 
3. Select the column from the Sort by drop down list.
4.Choose either Ascending or Descending option.

Filtering -        ‍  ചില മാനദണ്ഡങ്ങൾ പാലിക്കുന്ന പട്ടികയിലെ ഡാറ്റ മാത്രം പ്രദർശിപ്പിക്കാൻ ഫില്ട്ടറിംഗ്
ഉപയോഗിക്കുന്നു.

Autofilter
         ഓരോ നിരയിലെയും എല്ലാ മൂല്യങ്ങളും അടങ്ങുന്ന ഒരു ഡ്രോപ്പ്ഡൗൺ ലിസ്റ്റ് ഓട്ടോഫിൽട്ടർ

       പ്രദർശിപ്പിക്കുകയും ലിസ്റ്റിലെ മൂല്യങ്ങളെ അടിസ്ഥാനമാക്കി വരികൾ ഫിൽട്ടർ ചെയ്യാൻ

 അനുവദിക്കുകയും ചെയ്യുന്നു.

വിജയഭേരി എഡ്യൂക്കേഷണൽ പ്രൊജക്റ്റ്, ജില്ലാ പഞ്ചായത്ത് മലപ്പുറം                                                                             33

Join Telegram Channel: https://t.me/hsslive Downloaded from www.Hsslive.in ®



The steps for filtering:
1. Select the entire table.
2. Click on the Data menu.
3. Select Autofilter from the Filter option.
To cancel data filter and display all data, reselect choose Data à Filter à 
AutoFilter again.

Standard 
Filter     ഫിൽട്ടറിംഗിനായി ഒന്നിലധികം വ്യവസ്ഥകൾ ലോജിക്കൽ AND   അല്ലെങ്കിൽ ലോജിക്കൽ

OR ‍  ‍ ഓപ്പറേറ്ററുകള് ഉപയോഗിച്ച് സംയോജിപ്പിക്കാന് സാധിക്കുന്നു.

Charts

     സംഖ്യാ ഡാറ്റയുടെ ഗ്രാഫിക്കൽരൂപമണ് ചാർട്ടുകൾ.     സ്റ്റാറ്റിസ്റ്റിക്കൽഡാറ്റ താരതമ്യം ചെയ്യാനും

 മനസ്സിലാക്കാനും ,     ഡാറ്റ വിശകലനത്തിനും ചാർട്ടുകൾ ഉപയോഗിക്കാം.

Steps to create a chart:
1. Select the data range.
2. Select Chart from the Insert menu or click on the chart icon on the Tool bar. 
3. Choose a Chart Type . 
4. Click on the Data Range .

Chart elements

1.Chart Area
‍ ‍    ‍ഇതില് ചാര്ട്ടിലെ എല്ലാ ഘടകങ്ങളും ഉള്പ്പെടുന്നു.

2.Chart Title
‍     ചാര്ട്ടിന് ഒരു തലക്കെട്ട് നല്കുന്നതിനുള്ളസ്ഥലം.

3.X-Axis Title
‍  ചാര്ട്ടിന്റെ X-     ആക്സിസ് ഡാറ്റ ശ്രേണിക്ക് നൽകിയിരിക്കുന്ന തലക്കെട്ട്.

4.Y-Axis Title
‍  ചാര്ട്ടിന്റെ Y-  ആക്സിസ്     ഡാറ്റ ശ്രേണിക്ക് നൽകിയിരിക്കുന്ന തലക്കെട്ട്.

5.X-Axis Category
         ഡാറ്റാ ശ്രേണിയുടെആദ്യ നിരയിൽ നിന്നോആദ്യ വരിയിൽ നിന്നോ എടുക്കുന്ന

‍ വിലകള് .

6.Y-Axis Value
  ‍   ഡാറ്റ ശ്രേണി തയ്യാറാക്കാന് ചെയ്യാൻഅടയാളപ്പെടുത്തിയഡാറ്റയാണിത്.

7.Data Labels
‍     ചാര്ട്ട് തയ്യാറാക്കിയ ഡാറ്റ ശ്രേണിയുടെ മൂല്യങ്ങൾ.

8.Legends
  ‍   ഒരു ബോക്സിന്റെ രൂപത്തില് ഡാറ്റ ശ്രേണിയെ നിറമോ,ചിഹ്നമോ,  പാറ്റേണോ

 ‍     കൊണ്ട് പ്രദര്ശിപ്പിക്കുന്നതിനെയാണ് ലെജൻഡ് എന്ന് പറയുന്നത്.
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Chart Types

1
Colum
n 
Charts

   ലംബ നിരകളിൽ ഡാറ്റയെ പ്രതിനിധീകരിക്കുന്നു.  താരതമ്യേന

  ചെറിയ ഡാറ്റയ്ക്ക് മികച്ചത്.    മൂല്യങ്ങൾ താരതമ്യം ചെയ്യാൻ

ഉപയോഗിക്കുന്നു

2 Bar 
Charts

       ഒരു ബാർ ചാർട്ട് നിർമ്മിക്കാൻഡാറ്റ വരികളുടെയും നിരകളുടെയും

 രൂപത്തിൽ ക്രമീകരിക്കണം.    വ്യക്തിഗത ഇനങ്ങൾ തമ്മിലുള്ള

  താരതമ്യം കാണിക്കാൻ ഉപയോഗിക്കുന്നു. 

3 Line 
Charts

      ഒരു പൊതു സ്കെയിലുമായി ബന്ധപ്പെട്ട് കാലക്രമേണ തുടർച്ചയായ

  ഡാറ്റ പ്രദർശിപ്പിക്കാൻ ഉപയോഗിക്കുന്നു.   സമയത്തിന്റെ തുല്യ

     ഇടവേളകളിൽ ഡാറ്റ ട്രെൻഡുകൾ കാണുന്നതിന് ലൈൻ

 ചാർട്ടുകൾ മികച്ചതാണ്.

4 Pie 
Charts

‍       ചാര്ട്ടിന്റെ ഓരോ ഭാഗവും മൊത്തം മൂല്യത്തിലേക്ക് എത്രത്തോളം

    സംഭാവന ചെയ്യുന്നുഎന്ന് പ്രദർശിപ്പിക്കാൻ ഉപയോഗിക്കുന്നു.  ഇത്

   കൂടുതൽ ദൃശ്യ വ്യക്തത നൽകുന്നു.
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 അധ്യായം 5

 അവതരണ സോഫ്റ്റ്‌വെയർ

 അവതരണ സോഫ്റ്റ്‌വെയർ

ചിത്രങ്ങൾ, ഓഡിയോ,       വീഡിയോ എന്നിവയുടെ സഹായത്തോടെ ഒരുആശയംഅല്ലെങ്കിൽ വിഷയം

     മറ്റുള്ളവരുടെ മുന്നിൽ പ്രദർശിപ്പിക്കുന്നതിന് അവതരണ സോഫ്റ്റ്‌വെയർ ഉപയോഗിക്കുന്നു.

•   ഓപ്പൺഓഫീസ് ഇബ്ര        സുംമൈക്രോസോഫ്റ്റ് പവർപോയിന്റുമാണ് രണ്ട് ജനപ്രിയ

സോഫ്റ്റ്‌വെയറുകൾ.

  അവതരണ സോഫ്റ്റ്‌വെയർ IDE

 അവതരണം തയ്യാറാക്കുക

     ഇബ്രസ് ജാലകം തുറന്നതിനുശേഷം അതിൽ നിന്നും Empty presentation  തിരഞ്ഞെടുത്ത്

create        ബട്ടൺക്ലിക്ക് ചെയ്യുമ്പോൾ ജാലകത്തിൻ്റെ മധ്യഭാഗത്ത് പ്രസൻ്റേഷനിലെആദ്യത്തെ

 സ്ലൈഡ് തെളിയുന്നു.

  അവതരണ സോഫ്റ്റ്‌വെയറിന്റെ ഘടകങ്ങൾ

•   ശീർഷകബാർ

•  മെനു ബാർ

•  ടൂൾബാർ

•  ടാസ്‌ക് പെയിൻ
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•   സ്ലൈഡ് പെയിൻ

•  സ്റ്റാറ്റസ് ബാർ

  സ്ലൈഡ് ഫോർമാറ്റ് ചെയ്യുക(Formatting a slide)

1)  ടെക്സ്റ്റ് ഫോർമാറ്റിംഗ്

    ഒരുസ്ലൈഡിലെ ടെക്സ്റ്റിലേക്ക് ഇഫക്റ്റുകൾ പ്രയോഗിക്കുന്നു.     ടെക്സ്റ്റ് ഫോർമാറ്റിംഗ് എന്നത് ക്യാരക്ടർ

ഫോർമാറ്റിംഗ്,  പാരഗ്രാഫ് ഫോർമാറ്റിംഗ്,     ലിസ്റ്റ് ഫോർമാറ്റിംഗ് എന്നിങ്ങനെ തരം തിരിക്കാം.

        ക്യാരക്ടർ ഫോർമാറ്റിംഗ്->      സ്ലൈഡിലെ അക്ഷരങ്ങളുടെ ഫോണ്ട് ഫെയ്സ് , വലുപ്പം,   നിറം എന്നിവ

ക്രമീകരിക്കുന്നതാണ്(Format -> Character)

        പാരഗ്രാഫ് ഫോർമാറ്റിംഗ്->        മാർജിനിൽ നിന്നുള്ളഅകലം സ്പേസിംഗ് വിന്യാസം ടാബ് ക്രമീകരണം

 എന്നിവയെല്ലാം ചെയ്യാം(Format->Paragraph)

2)  ബുളളറ്റകളും നമ്പറിംഗും(Bullets and numbering )  :- Format -> Bullets

3)  പശ്ചാത്തലം ക്രമീകരിക്കുക(Setting background )
       (i)    സ്ലൈഡിൻ്റെ പശ്ചാത്തലം ക്രമീകരിക്കുക(Setting slide background)

          Format->page->Select the Background tab->Fill box using appropriate 
option(colour, gradient, hatching pattern)

       (ii)    ഒരു വസ്തുവിൻ്റെ പശ്ചാത്തലം സജ്ജീകരിയ്ക്കുക( Setting  Object background ) 

                   Format->area

 സ്ലൈഡ് മാസ്റ്ററുകൾ(Slide masters)

          സ്ലൈഡുകളുടെ അടിസ്ഥാന ഫോർമാറ്റിംഗ് നിയന്ത്രിക്കുന്നു.Task pane->Master page                    

   
പ്രവർത്തനം ഓപ്ഷൻ   ഷോർട്ട്കട്ട് കീ

  അവതരണം സേവ് ചെയ്യുക File ->Save Ctrl + S

തുറക്കുക File->Open Ctrl + O

  പുതിയസ്ലൈഡുകൾ

കൂട്ടിച്ചേർക്കുക
Insert->Slide Enter Key

 സ്ലൈഡുകളുടെ പകർപ്പെടുക്കുക,  നീക്കം ചെയ്യുക

പകർപ്പ് Right Click on slide -> Duplicate
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 നീക്കം ചെയ്യുക Right Click on slide -> Delete

 ഒബ്ജക്റ്റുകൾ ചേർക്കുന്നു.

പട്ടിക Insert -> Table

   ശബ്ദഫയൽ Insert-> Movie and Sound option -> select audio file.

  വീഡിയോ ക്ലിപ്പ്  Insert-> Movie and Sound option ->select video file.

 ഹൈപ്പർ ലിങ്ക് Insert ->Hyperlinks

  ആക്ഷൻ ഒബ്ജക്ടുകൾ ചേർക്കുക(Adding action objects)

1.      ബട്ടൺ ഉൾപ്പെടുത്തുന്ന തിനായി ഒരുസ്ലൈഡ് തെരഞ്ഞെടുക്കുക.

2.     ഡ്രോയിങ് ടൂൾ ബാറിൽ നിന്ന് rectangle     ടൂൾ തിരഞ്ഞെടുത്ത് സ്ലൈഡിങ് അനുയോജ്യമായ

  സ്ഥലത്തേക്ക് ഡ്രാഗ് ചെയ്യുക.

3,            ചതുരത്തിൽ മൗസ് റൈറ്റ് ക്ലിക്ക് ചെയ്യുമ്പോൾ ലഭിക്കുന്ന പോപ് അപ്പ് മെനുവിൽ നിന്ന് interaction 
തെരഞ്ഞെടുക്കുക.

4.Action at mouse click      എന്നതിന്റെ ഡ്രോപ് ഡൗൺ ബോക്സിൽ നിന്നും Go to first slide 
 തെരഞ്ഞെടുത്തു ok   ബട്ടൺക്ലിക്ക് ചെയ്യുക.

   വിവിധതരം സ്ലൈഡ് വ്യൂകൾ (Views in Presentation)

•  നോർമൽ വ്യൂ (  സ്ലൈഡ് വ്യൂ)-      വസ്തുക്കൾരൂപകല്പന ചെയ്യാനും ഫോർമാറ്റ് ചെയ്യാനും ഉപയോഗിക്കുന്നു.

•   ഔട്ട് ലൈൻ വ്യൂ -    സ്ലൈഡിലെ ടെക്സ്റ്റ് മാത്രം കാണിക്കുന്നു.

•  നോട്ട്സ് വ്യൂ-     ഓരോ സ്ലൈഡിലേക്ക് കുറിപ്പുകൾ ചേർക്കുന്നതിന് ഉപയോഗിക്കുന്നു.

•  ഹാൻഡ്ഔട്ട് വ്യൂ -    അച്ചടിച്ച ഹാൻഡ്ഔട്ടിന്റെ ലേഔട്ട് സജ്ജീകരിക്കാൻ.

•   സ്ലൈഡ് സോർട്ടർ വ്യൂ-       സ്ലൈഡ് ഷോയുടെ സമയത്ത് സ്ലൈഡുകളുടെ ക്രമം പുനഃക്രമീകരിക്കാൻ

ഉപയോഗിക്കുന്നു.

 സ്ലൈഡ് ട്രാൻസിഷൻസ്(Slide Transitions)

           ഒരുസ്ലൈഡ് ഷോയിൽസ്ലൈഡ് ദൃശ്യം ആകുമ്പോൾ നൽകാൻ കഴിയുന്ന സ്പെഷ്യൽ ഇഫക്ടുകൾആണ്

  സ്ലൈഡ് ട്രാൻസിഷൻഎന്നറിയപ്പെടുന്നത്.    റോൾ ഡോൺഫ്രം ടോപ്പ്(Roll down from top),  ഫ്ളൈ

   ഇൻഫ്രം ലെഫ്റ്റ് (Fly in from left )  എന്നിവ ഉദാഹരണങ്ങളാണ്. 

 സ്ലൈഡ് ട്രാൻസിഷനുകൾ(Slide animation) Task pane -> Custom 
Animation.
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 സ്ലൈഡ്അനിമേഷൻ(Slide transitions) Task pane -> Slide 
Transition

   സ്വയം പ്രേരിതമായസ്ലൈഡ്
ട്രാൻസിഷൻ(Automatic slide transition)

Task pane -> Advance slide
-> Automatically after

  സമയ നിർണയ പരിശീലനം(Rehearse timings) Slide Show ->
Rehearse ->Timings.

  അവതരണം സ്വപ്രേരിതമായി
ആവർത്തിക്കുക(Auto-repeat presentation)

Slide Show ->Slide Show 
Settings -> Auto from Type
.

 പശ്ചാത്തല ശബ്ദം(Background sound)
Slide Transition pane -> 
Modify transition -> Other 
Sound

   അവതരണം പ്രിൻ്റ് ചെയ്യുന്ന രീതി(Printing a 
presentation) File ->Print

 മാതൃക ചോദ്യങ്ങൾ

1.       പ്രചാരം നേടിയ രണ്ട് പ്രസൻ്റേഷൻ സോഫ്റ്റ്‌വെയറുകളുടെ പേര് എഴുതുക?

2.    പ്രസൻ്റേഷൻ സോഫ്റ്റ് വെയറിൻ്റെ IDE      യിൽ കാണപ്പെടുന്ന വ്യത്യസ്തഘടകങ്ങളുടെ പേര്

എഴുതുക?

3.       ഒരു ഫയൽ തുറക്കാനുള്ള ഷോർട്ട് കട്ട് കീ ഏത്?

4.     ഒരുസ്ലൈഡിൽഹൈപ്പർലിങ്ക് ചേർക്കുന്നത് എങ്ങനെ?

5.         ഒരുസ്ലൈഡിൽ ശബ്ദഫയൽ ചേർക്കുന്നതിനുള്ള വിവിധ മാർഗങ്ങൾ ചർച്ച ചെയ്യുക?

6.     വിവിധ തരം സ്ലൈഡ് വ്യൂകൾ വിവരിക്കുക

7.    അവതരണത്തിലേക്കു പുതിയസ്ലൈഡ് ചേർക്കുന്നതെങ്ങനെ?

           8.    ഒരുസ്ലൈഡ് പകർപ്പ് (Duplicate)     എടുക്കുന്നത് കൊണ്ട് എന്താണ് ഉദേശിക്കുന്നത് ?

                    ഒരുസ്ലൈഡ് പകർപ്പ് എടുക്കണ്ടതിനുള്ളഘട്ടങ്ങൾഎഴുതുക? 

            9.       ഒരുസ്ലൈഡിൽആക്ഷൻബട്ടണുകൾ ചേർക്കുന്നതിനുള്ളഘട്ടങ്ങൾ നൽകുക.

                  ഉപയോഗം വിശദീകരിക്കുക. 
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 അധ്യായം 6
GIMPപരിചയപ്പെടാം

    ഇമേജ് എഡിറ്റിംഗ് സോഫ്റ്റ് വെയർ (Image editing Software)
        ഒരു ഇമേജ് അല്ലെങ്കിൽ ഗ്രാഫിക് എഡിറ്റുചെയ്യാനോ കൈകാര്യം ചെയ്യാനോ ഉപയോഗിക്കുന്ന

 സോഫ്റ്റ് വെയർ.      അത്തരം സോഫ്റ്റ് വെയറിന്റെ ഉപയോഗങ്ങളിൽ ഇനിപ്പറയുന്നവ ഉൾപ്പെടുന്നു:
•    ഡിജിറ്റൽ ഇമേജുകളുടെ വലുപ്പം മാറ്റൽ, ക്രോപ്പിംഗ്, കളറിംഗ്,   സംയോജിപ്പിച്ച് മാറ്റം വരുത്തുക
•   ചിത്രങ്ങളിൽ നിന്ന് പോറലുകൾ, ചുളിവുകൾ, അഴുക്കുകൾ,   അപൂർണതകൾഎന്നിവ നീക്കംചെയ്യുക
•     ഇമേജുകളുടെ വ്യക്തത വർദ്ധിപ്പിക്കുകഅല്ലെങ്കിൽ മങ്ങിക്കുക
•    ഇമേജുകൾ തിരിക്കുകഅല്ലെങ്കിൽ ഫ്ലിപ്പുചെയ്യുക
•        ഒരു ഇമേജ് ഫോർമാറ്റിൽ നിന്ന് മറ്റൊന്നിലേക്ക് പരിവർത്തനം ചെയ്യുക

     ഇമേജ് എഡിറ്റർ സോഫ്റ്റ് വെയറുകളുടെ വർഗ്ഗീകരണം (Classification of Image Editors)
1.    – റാസ്റ്റർ ഗ്രാഫിക്സ് എഡിറ്റർ ഉദാ: GIMP, Photoshop, gThumb Image Viewer
2.     വെക്റ്റർ ഗ്രാഫിക് എഡിറ്റർ - ഉദാ: Adobe Illustrator, Corel DRAW, Inkscape
3. 3D  – മോഡലെർ ഉദാ: 3D Studio MAX, Animation Master, K-3D

      റാസ്റ്റർ ചിത്രങ്ങളും വെക്റ്റർ ചിത്രങ്ങളും തമ്മിലുള്ള താരതമ്യം (Comparison between Raster and 
Vector images)

റാസ്റ്റർ വെക്റ്റർ

    റാസ്റ്റർ ചിത്രം പിക്സലുകൾ ഉപയോഗിച്ചാണ്
നിർമ്മിച്ചിരിക്കുന്നത്.

   വെക്റ്റർ ഇമേജുകൾസൂത്രവാക്യങ്ങൾ ഉപയോഗിച്ച്
 ഗണിതശാസ്ത്രപരമായി സൃഷ്ടിക്കുന്നു.

    വലുപ്പം മാറ്റുന്നതിനനുസരിച്ച് റാസ്റ്റർ ചിത്രങ്ങളുടെ
 ഗുണനിലവാരം കുറയുന്നു.

   ചിത്രത്തിന്റെ ഗുണനിലവാരം നഷ്‌ടപ്പെടുത്താതെ
   വെക്റ്റർ ചിത്രങ്ങളുടെ വലുപ്പം മാറ്റാനാകും.

    റാസ്റ്റർ ഇമേജുകൾക്ക് ഏത് നിറവും
 പ്രദർശിപ്പിക്കാൻ കഴിയും.

   റാസ്റ്റർ ഇമേജുകളിലേതുപോലെ നിറങ്ങൾ മാറ്റാൻ
  വെക്ടർ ഇമേജുകളിൽ കഴിയില്ല. 

    റാസ്റ്റർ ഇമേജുകൾ പലപ്പോഴും വലിയ
ഫയലുകളാണ്.    വെക്റ്റർ ഇമേജുകൾ താരതമ്യേന ചെറുതാണ്.

   റാസ്റ്റർ ചിത്രങ്ങൾ വെബ്‌സൈറ്റുകളിലും
 പ്രിന്റിങ്ങിലും ഉപയോഗിക്കുന്നു.

   വെക്റ്റർ ഇമേജുകൾ വെബ്‌സൈറ്റുകൾക്കും
    പ്രിന്റിംഗിനും ഉപയോഗിക്കുന്നതിന് മുമ്പ് റാസ്റ്റർ

  ചിത്രങ്ങളിലേക്ക് പരിവർത്തനം ചെയ്യുന്നു.

GIMP (GNU Image Manipulation Program)
    ഫോട്ടോകളിൽ ചെറിയ മാറ്റങ്ങൾ വരുത്തുക,    പുതിയ ഇമേജുകൾസൃഷ്ടിക്കുക   തുടങ്ങിയവയ്ക്കു

    അനുയോജ്യമായ സോഫ്റ്റ് വെയർആണ് GIMP.

GIMP-   ന്റെസവിശേഷതകൾ (Features of GIMP)
• ബ്രഷുകൾ, പെൻസിൽ,  എയർബ്രഷ്,     ക്ലോണിംഗ് മുതലായവ ഉൾപ്പെടെയുള്ള പെയിന്റിംഗ്
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  ഉപകരണങ്ങളുടെ പൂർണ്ണസ്യൂട്ട്.
•   ഒന്നിലധികം തവണ undo/redo  ചെയ്യുവാൻസാധിക്കും.
• Rectangle, ellipse, free, fuzzy   എന്നീ സെലക്ഷൻ ടൂളുകൾ.
• Rotate, scale, shear, flip   എന്നീ ട്രാൻസ്ഫർമേഷൻ ടൂളുകൾ
•    ഒന്നിലധികം ലെയർ സൗകര്യം പിന്തുണയ്ക്കുന്നു.
• GIF, JPEG, PNG, TIFF, BMP    പോലുള്ളഫയൽ ഫോർമാറ്റുകൾ പിന്തുണയ്ക്കുന്നു.
•   വിപുലമായ സ്ക്രിപ്റ്റിംഗ് കഴിവുകൾ

  കാൻവാസ് നിർമ്മാണം (Canvas Creation)
   ഒരു പുതിയ കാൻവാസ് സൃഷ്ടിക്കുന്നതിന്, File  മെനുവിൽ New  ക്ലിക്കുചെയ്യുക (File-> New). 

    അനുയോജ്യമായ ക്യാൻവാസ് വലുപ്പം നൽകി OK ക്ലിക്കുചെയ്യുക.   

   ഒരു ക്യാൻവാസിനുള്ള വർണ്ണക്രമീകരണങ്ങൾ
   പോസ്റ്ററിന്റെ പശ്ചാത്തല നിറം മാറ്റാൻ:-
•       ടൂൾബോക്സിലെ ബാക്ക് ഗ്രൗണ്ട് കളർഐക്കണിൽ ക്ലിക്ക് ചെയ്യുക.
•      വർണ്ണ പാലറ്റിൽ നിന്ന് അനുയോജ്യമായ നിറം തിരഞ്ഞെടുക്കുക.
•        പശ്ചാത്തലം പൂരിപ്പിക്കുന്നതിന് ബക്കറ്റ് ഫിൽ ടൂൾ തിരഞ്ഞെടുത്ത് ക്യാൻവാസിൽ

 ക്ലിക്ക് ചെയ്യുക

   ഇമേജ് സേവ് ചെയ്യാം (Saving images)
File   മെനുവിൽ നിന്ന് Save   ഓപ്ഷൻ തിരഞ്ഞെടുക്കുക (File-> Save).   ഫയൽ .xcf  എന്ന

    എക്സ്റ്റൻഷൻ ചേർത്ത് സേവ് ചെയ്യും (Experimental Compact Facility).

GIMP-  ലെ ലെയറുകൾ.
        നിങ്ങൾക്ക് ഒരു വസ്തുവോ ചിത്രമോസ്ഥാപിക്കാൻ കഴിയുന്ന വ്യത്യസ്ത തലങ്ങളാണ് ലെയറുകൾ.  ചിത്രങ്ങൾ

  വ്യത്യസ്ത ലെയറുകളിൽസ്ഥാപിക്കുമ്പോൾ,   അവഎളുപ്പത്തിൽ പരിഷ്‌ക്കരിക്കാനാകും.

   ലെയർ ഡയലോഗ് ബോക്സ് ദൃശ്യമാക്കുന്നതിന് - Windows ->Dockable dialogs ->Layers( Ctrl+L). 

   ലെയർ ഡയലോഗിന്റെ ചുവടെയുള്ളഐക്കണുകൾ
1   പുതിയ ലെയർ സൃഷ്ടിക്കുക.
2.   ലെയർ മുകളിലേക്ക് നീക്കുക.
3.   പാളി താഴേക്ക് നീക്കുക.
4.    ഒരു ലെയറിന്റെ തനിപ്പകർപ്പ് സൃഷ്ടിക്കുക.
5.    ഫ്ലോട്ടിംഗ് ലെയർആങ്കർ ചെയ്യുക.
6.   ഒരു ലെയർ ഇല്ലാതാക്കുക.

   ലിങ്കിംഗ് ചെയിൻഐക്കൺ -
    ഒരു ഇമേജ് സ്കെയിൽ ചെയ്യുമ്പോൾ Aspect ratio constant    ആയി നിലനിർത്താൻ ഉപയോഗിക്കുന്ന

     സ്കെയിൽഡയലോഗ് ബോക്സിലെ ഒരുഐക്കൺആണ്.
  ഫ്ലോട്ടിംഗ് ലെയറും ആങ്കറിംഗും
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    ഫ്ലോട്ടിംഗ് ലെയർ ഒരു താൽക്കാലിക പാളിയാണ്.       ആങ്കറിംഗ് എന്നത് ഒരു ഫ്ലോട്ടിംഗ് ലെയർ സാധാരണ
 ലെയറുമായി (  ഫ്ലോട്ടിംഗ് അല്ലാത്ത)  അറ്റാച്ച് ചെയ്യുന്നതാണ്

 സെലക്ഷൻ ടൂളുകൾ(Selection Tools)
       സജീവമായ ലെയറിൽ നിന്ന് ഭാഗങ്ങൾ തിരഞ്ഞെടുക്കുന്നതിനാണ് സെലക്ഷൻ ടൂളുകൾ
 രൂപകൽപ്പന ചെയ്തിരിക്കുന്നത്,     അതിനാൽ തിരഞ്ഞെടുക്കാത്തപ്രദേശങ്ങളെ ബാധിക്കാതെ

   അവയിൽ പ്രവർത്തിക്കാൻ കഴിയും. Tools-> Selection Tools    എന്ന മെനു ഉപയോഗിച്ച്
     അല്ലെങ്കിൽ ടൂൾബോക്സിൽ നിന്ന്ഈ ടൂളുകൾ തിരഞ്ഞെടുക്കാവുന്നതാണ്. 

GIMP-      ൽ ലഭ്യമായ വ്യത്യസ്ത സെലക്ഷൻ ടൂളുകൾ ഇവയാണ്:
i.   റെക്റ്റാംഗിൾ സെലക്ട് (Rectangle Select)-

    സജീവ ലെയറിന്റെ ചതുരാകൃതിയിലുള്ള പ്രദേശങ്ങൾ തിരഞ്ഞെടുക്കുന്നതിന്.
ii.   എലിപ്സ് സെലക്ട് (Ellipse Select)  -

      ഒരു ചിത്രത്തിൽ നിന്ന് വൃത്താകൃതിയിലുള്ളതോ ദീർഘവൃത്താകൃതിയിലുള്ളതോആയ പ്രദേശങ്ങൾ
തിരഞ്ഞെടുക്കുന്നതിന്.

iii.   ഫ്രീ സെലക്ട് (  ലാസ്സോ ടൂൾ) (Free Select(Lasso Tool))-
      മൗസ് ഉപയോഗിച്ച് സ്വതന്ത്രമായി വരച്ച് ഒരു തിരഞ്ഞെടുപ്പ് സൃഷ്ടിക്കാൻ

iv.    ഫോർഗ്രൗണ്ട് സെലക്ട് (Foreground Select)-
     ഒരു ചിത്രത്തിലെ പിക്സലുകളുടെ മികച്ച തിരഞ്ഞെടുക്കലിനായി ഉപയോഗിക്കുന്നു.

v.   ഫസ്സി സെലക്ട് (  മാജിക് വാൻഡ്) (Fuzzy Select(Magic Wand))-
       വർണ്ണസാമ്യതയെഅടിസ്ഥാനമാക്കി സജീവ ലെയറിന്റെയോ ചിത്രത്തിന്റെയോ ഏരിയകൾ

തിരഞ്ഞെടുക്കുന്നതിന്.
vi.    ബൈകളർ സെലക്ട് (By Color Select)-

     വർണ്ണസാമ്യതയെഅടിസ്ഥാനമാക്കി തുടർച്ചയായ പ്രദേശങ്ങൾ തിരഞ്ഞെടുക്കുന്നതിന്
vii.   ഇന്റലിജന്റ് സിസ്സേഴ്‌സ് (Intelligent Scissors)  -

  അരികുകളിൽ ശക്തമായ വർണ്ണ-     മാറ്റങ്ങളാൽ നിർവചിക്കപ്പെട്ട ഒരു പ്രദേശം
തിരഞ്ഞെടുക്കുന്നതിന്

GIMP-    ൽ ചിത്രങ്ങളിലേക്ക് വാചകം ചേർക്കുന്നത്
1   ടെക്‌സ്‌റ്റ് ടൂൾ ( Tools->Text    അല്ലെങ്കിൽ ടൂൾബോക്‌സ്ഐക്കൺ ഉപയോഗിച്ച)് 

   തിരഞ്ഞെടുത്ത് ക്യാൻവാസിൽ ക്ലിക്ക് ചെയ്യുക.
2       ടെക്‌സ്‌റ്റ് ടൂളിന്റെ ടൂൾ ഓപ്ഷനുകളിൽ ടെക്‌സ്‌റ്റിന്റെ ഫോണ്ട് തരം, വലുപ്പം, നിറം,  വിന്യാസം

 എന്നിവ സജ്ജമാക്കുക
3      ടെക്സ്റ്റ് ടൈപ്പ് ചെയ്ത് ക്ലോസ് ബട്ടൺഅമർത്തുക.

GIMP-    ൽ ചിത്രങ്ങൾഎക്‌സ്‌പോർട്ട് ചെയ്യുന്നതൈങ്ങിനെ
GIMP-     ലെ എക്‌സ്‌പോർട്ട് സൗകര്യം ഒരു GIMP       പ്രോജക്‌റ്റിൽ നിന്ന് മറ്റ് വിവിധ ഇമേജ് ഫയൽ

     ഫോർമാറ്റുകളിലേക്ക് ചിത്രം എക്‌സ്‌പോർട്ട് ചെയ്യുന്നതിനുള്ളഓപ്ഷനുകൾ നൽകുന്നു.

   എക്‌സ്‌പോർട്ട് ചെയ്യാൻ രണ്ട് വഴികൾ
1 File->Save As ഉപയോഗിച്ച.്  തുറക്കുന്നഡയലോഗിൽ, click the Select File Type.   ഫയൽ

  തരം തിരഞ്ഞെടുക്കുക ,  ക്ലിക്ക് ചെയ്യുക.   എന്നിട്ട് സേവ് ചെയ്യുക.
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2 File ->Export option  ഉപയോഗിച്ച്

 ട്രാൻസ്‌ഫോം ടൂളുകൾ (Transform Tools)
 ട്രാൻസ്‌ഫോം ടൂളുകൾ     ചിത്രത്തിന്റെ വലുപ്പവുംസ്ഥാനവും കോണും മാറ്റുന്നു.   ഈടൂളുകൾ
 ടൂൾബോക്സിൽഅല്ലെങ്കിൽ Tools-> Transform Tools  നിന്ന് ലഭ്യമാണ്. 

     ജിം‌പിൽ‌ലഭ്യമായ വ്യത്യസ്ത ട്രാൻസ്‌ഫോം ടൂളുകൾ ഇനിപ്പറയുന്നവയാണ്:  
•  അലൈൻ (Align)-       വിവിധ ഇമേജ് ഒബ്‌ജക്‌റ്റുകൾ ഉപയോഗിച്ച് ഇമേജ് ലെയറുകൾ
വിന്യസിക്കാൻ.  ടോപ്പ് എഡ്ജ്, മിഡിൽ,  താഴത്തെഅറ്റങ്ങൾ, മധ്യഭാഗം,  ഇടത് എഡ്ജ്,  വലത്

    അറ്റങ്ങൾഎന്നിവയാണ് വ്യത്യസ്തഅലൈൻഓപ്ഷനുകൾ.
(Tools ->Transform Tools ->Align .)

ഓട്ടോക്രോപ്പ്-      ലെയറിലെ ചിത്രത്തിന്റെ വലുപ്പത്തിന് അനുയോജ്യമായ രീതിയിൽ
  ലെയറിന്റെ വലുപ്പം മാറ്റുക.

•  മൂവ് (Move)-      ലെയറുകളെയോ തിരഞ്ഞെടുത്ത ഭാഗങ്ങളെയോ നീക്കാൻ ഉപയോഗിക്കുന്നു.
•  ക്രോപ് (Crop)-       ഒരു ചിത്രം ക്രോപ്പ് ചെയ്യാനോ ക്ലിപ്പ് ചെയ്യാനോ ഉപയോഗിക്കുന്നു

(Tools-> Transform Tools-> Crop)
•  റൊട്ടേറ്റ് (Rotate)-        ഒരു മുഴുവൻ ലെയറും അല്ലെങ്കിൽ ഒരു ചിത്രത്തിന്റെ തിരഞ്ഞെടുത്ത  ഭാഗം

  മാത്രം തിരിക്കാൻ ഉപയോഗിക്കുന്നു.Tools->Transform Tools->Rotate .
•  സ്കെയിൽ (Scale)-      ചിത്രത്തിലെ ലെയറുകളോ തിരഞ്ഞെടുത്ത ഭാഗങ്ങളെയോ സ്കെയിൽ

 ചെയ്യാൻ ഉപയോഗിക്കുന്നു.

 ലിങ്കിംഗ് ചെയിൻ -     സ്കെയിലിംഗിൽ വീതിയുടെയും ഉയരത്തിന്റെയും വീക്ഷണാനുപാതം
  സ്ഥിരമായി നിലനിർത്താൻ ഉപയോഗിക്കുന്നു

•  ഷിയർ (Shear)-    ഒരു ചിത്രത്തിന്റെ ഒരു ഭാഗം,      ഒരു ലെയർ അല്ലെങ്കിൽ സെലക്ഷൻ ഒരു
      ദിശയിലേക്കും മറ്റേ ഭാഗം വിപരീത ദിശയിലേക്കും മാറ്റാൻ ഉപയോഗിക്കുന്നു.

•  ഫ്ളിപ് (Flip)-     ലെയറുകളോ തിരഞ്ഞെടുത്ത ഭാഗങ്ങളെയോ തിരശ്ചീനമായോ  ലംബമായോ
ഫ്ലിപ്പുചെയ്യുക.

 മാതൃക ചോദ്യങ്ങൾ

1.        ചുവടെയുള്ള സോഫ്റ്റ് വെയറുകൾ തരംതിരിക്കുകയും അനുയോജ്യമായ തലക്കെട്ടുകൾ  നൽകുകയും
ചെയ്യുക.

CorelDRAW, GIMP, Photoshop, Inkscape, 3D Studio MAX
2. റാസ്റ്റർ,     വെക്റ്റർ ഗ്രാഫിക്സ് എന്നിവ താരതമ്യം ചെയ്യുക.
3. GIMP    ഇമേജ് എഡിറ്ററിന്റെ സവിശേഷതകൾ പട്ടികപ്പെടുത്തുക.
4. GIMP-        ൽ ലഭ്യമായ ഏതെങ്കിലും അഞ്ച് സെലക്ഷൻ ടൂളുകളുടെ പേര് നൽകുക.

5. GIMP-       ലെ ഏതെങ്കിലും മൂന്ന് ട്രാൻസ്‌ഫോം ടൂളുകൾ പട്ടികപ്പെടുത്തുക.
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                                     അധ്യായം 7
                      ‍ഇമേജ് എഡിറ്റിംഗിനുള്ള മികച്ച ടൂളുകള്

   പാത്ത് ടൂളിന്റെ ഉപയോഗം(Use of Path Tool)
●   ‍     നേർരേഖയുള്ളതും വക്രതയാര്ന്ന വ്യോമഗതിയിലുള്ളതുമായ മിനുസമാർന്നതുമായആകൃതികളും

    പാതകളും സൃഷ്‌ടിക്കാൻ പാത്ത് ടൂൾ ഉപയോഗിക്കുന്നു.

●         വ്യത്യസ്‌ത തരത്തിലുള്ള പാറ്റേണുകൾസൃഷ്‌ടിക്കുന്നതിന് ഈ ഉപകരണം വളരെ

ഉപയോഗപ്രദമാണ്.

●             ഇതിനകം നിലവിലുള്ള ചിത്രത്തിൽ നിന്ന് വ്യത്യസ്‌ത രൂപത്തിലുള്ള ഒരു ചിത്രത്തിന്റെ ഒരു ഭാഗം

   തിരഞ്ഞെടുക്കുന്നതിനും പാത്ത് ടൂൾ ഉപയോഗിക്കുന്നു

 Tools --> Paths 

   ‍‍  ‍  ചിത്രത്തിന്റെഅരിക് ഡ്രാഗ് ചെയ്യുമ്പോള് രേഖാഖണ്ഡം വളയും.    ‍ വളവിന്റെ ദിശ സൂചിപ്പിച്ചുകൊണ്ട് ബിന്ദുവില്

    നിന്നുംആരംഭിക്കുന്ന പുതിയ രേഖാഖണ്ഡം ( Line Segment ) ‍ ഇപ്പോള് ദൃശ്യമാകും.   ഈരേഖാഖണ്ഡത്തെ

 ദിശാസൂചക രേഖ ( Direction Line )  എന്ന് വിളിക്കുന്നു.    ദിശാസൂചക രേഖയുടെ അവസാനഭാഗത്ത്

 സമചതുരചിഹ്നം കാണാം.    ‍ ‍ ഇതിനെ ദിശാസൂചക രേഖയുടെ ഹാന്ഡില് ( Handle )  എന്ന് വിളിക്കുന്നു. 

 ‍     ‍ ‍  വളവിന്റെആകൃതിയില് മാറ്റം വരുത്തുന്നതിന് നമുക്ക്ഈഹാന്ഡില് ഡ്രാഗ് ചെയ്യാവുന്നതാണ്.  പാതയിലെ

  ഓരോ ബിന്ദുവിനെയും ‍ ആങ്കര് ( Anchor ) പോയിന്റ്  എന്ന് വിളിക്കുന്നു.

         ഒരു പാതയിൽ നിന്ന് ആങ്കർ പോയിന്റുകൾ ചേർക്കുകയും നീക്കം ചെയ്യുകയും ചെയ്യുന്നു(Adding and 
removing anchor points from a path)
       ഈപാതയിൽ ഒരുആങ്കർ പോയിന്റ് കൂടി ചേർക്കുന്നതിന്,  ‍ ഒരു രേഖാഖണ്ഡത്തില് ( Line Segment ) 

   മൗസ് പോയിന്റർ നീക്കി Ctrl കീ അമർത്തുക.     അപ്പോൾ മൗസ് പോയിന്ററിന് + ചിഹ്നമുണ്ട്.    തുടർന്ന് നമുക്ക്

       ഈസ്ഥാനത്ത് ഒരു പുതിയആങ്കർ പോയിന്റ് ചേർക്കാൻ കഴിയും.     ഇത് ചെയ്യാൻ നിങ്ങൾക്ക് നീക്കം

ചെയ്യണമെങ്കിൽ,     ദിശാരേഖയിലെ ഹാൻഡിലിനു മുകളിലൂടെ മൗസ് നീക്കുക.  Ctrl, Shift   കീകൾ ഒരുമിച്ച്

അമർത്തുക,      ഇപ്പോൾ മൗസ് പോയിന്ററിൽ ഒരുമൈനസ് (-) ചിഹ്നം.      തുടർന്ന് നിങ്ങൾക്ക്ഈഹാൻഡിൽ
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   ക്ലിക്ക് ചെയ്യുന്നതിലൂടെ നീക്കം ചെയ്യാം.

       പാത്ത് ടൂൾ ഉപയോഗിച്ച് ഒരു ചിത്രത്തിന്റെ ഒരു ഭാഗം തിരഞ്ഞെടുക്കുന്നു(Selecting a portion of an 
image using Path tool)
        ഈപാതയിൽ വലത് ക്ലിക്ക് ചെയ്ത് മെനു ഇനം തിരഞ്ഞെടുക്കുക

 Select --> From Pathഅഥവാ

  ടൂൾബോക്സിലെ Selection From Path   ബട്ടണിൽ ക്ലിക്ക് ചെയ്യുക.

       ‍ ‍  തിരഞ്ഞെടുത്ത ഭാഗം പകർത്തി ഒരു പുതിയ ക്യാൻവാസിൽ ചേര്ക്കാന് Ctrl+C  അമർത്തിക്കൊണ്ട്

  ചിത്രത്തിന്റെ ഭാഗം തിരഞ്ഞെടുക്കുക.

   വാചകം ഒരു പാതയിലേക്ക് വിന്യസിക്കുന്നു(Aligning text to a path)
      നമുക്ക് ഒരു ടെക്‌സ്‌റ്റ് ഒരു പാതയിൽ വിന്യസിക്കാം,      ഇത് പാത്ത് ടൂൾ ഉപയോഗിക്കുന്നതിന്റെ മറ്റൊരു

നേട്ടമാണ്.  ആദ്യം   ടൂൾബോക്സിൽ നിന്ന്

  ടെക്സ്റ്റ് ടൂൾ      തിരഞ്ഞെടുത്ത് ക്യാൻവാസിൽ ഒരു ടെക്സ്റ്റ് ടൈപ്പ് ചെയ്യുക,  തുടർന്ന്   പാത്ത് ടൂൾ  ഉപയോഗിച്ച്

   ക്യാൻവാസിൽ ഒരു പാത വരയ്ക്കുക.         ടൂൾബോക്‌സിൽ നിന്ന് വീണ്ടും ടെക്‌സ്‌റ്റ് ടൂൾ തിരഞ്ഞെടുത്ത് ടൈപ്പ്

   ചെയ്‌ത ടെക്‌സ്‌റ്റിൽ ക്ലിക്ക് ചെയ്യുക. Layer-->Text Along Path    മെനുവിലും ഇതേ ഫീച്ചർ ലഭ്യമാണ്.

 GIMP-    ൽ നിറങ്ങൾകൈകാര്യം ചെയ്യാം(Managing colours in GIMP)
 GIMP-      ൽ നിറങ്ങൾ തിരഞ്ഞെടുക്കാനും നിയന്ത്രിക്കാനും വ്യത്യസ്‌ത മാർഗങ്ങളുണ്ട്.   കളർ ഡയലോഗ്

  ബോക്‌സ് 5   ‍ വ്യത്യസ്ത രീതികളിൽ നിറങ്ങള് പ്രദർശിപ്പിക്കുന്നു.

    അവ താഴെ പറയുന്നവയാണ് : 

 1.  ജിമ്പ് ( GIMP )

 2. CMYK

 3.   വാട്ടർ കളർ ( Water Color )

 4. ‍ വീല് ( Wheel )

 5.  പാലറ്റ് ( Palette )

  സബ്ട്രാക്റ്റീവ് ,  ‍  അഡിക്ടീവ് കളര് സ്കീമുകളുടെ താരതമ്യം
(Comparison of subtractive and additive colour schemes)
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    ഒരു ചിത്രത്തിന്റെ തെളിച്ചവും വൈപരീത്യവും ക്രമീകരിക്കുന്നു
(Setting the brightness and contrast of an image)
Tools --> Colour Tools -->Brightness --> Contrast

  നിറങ്ങളുടെ സമീകരണം(Colour balancing)
      നിറങ്ങൾസമീകരിച്ചുകൊണ്ട് ഒരു ചിത്രം ശരിയാക്കാൻ Colour Balance Option  നമ്മെഅനുവദിക്കുന്നു.  

      കളർ ബാലൻസിങ് മാറ്റാൻഈ മെനു ഇനം ഉപയോഗിക്കുക
 Color --> Color Balance
 

ഫിൽട്ടറുകൾ
           ഒരു ഇമേജിൽ വിവിധ ഇഫക്റ്റുകൾ പരിഷ്കരിക്കാനും ചേർക്കാനും ഉപയോഗിക്കുന്ന വളരെ ശക്തമായ ഒരു

 ടൂളാണ് ഫിൽട്ടർ.         ഫിൽട്ടറുകൾ ഒരുസമ്പൂർണ്ണ ലെയറിലേക്കോ തിരഞ്ഞെടുത്ത ഭാഗത്തേക്കോ

 പ്രയോഗിക്കാൻ കഴിയും.    ജിമ്പിൽ ഉപയോഗിക്കുന്നഫിൽട്ടറുകൾ ഇവയാണ്:

 1. ‍ ബ്ലര് ( Blur )

 2. ‍ ‍ ഷാര്പ്പെന് ( Sharpen )

 3. ‍  ഡിസ്റ്റോര്ട്സ് ( Distorts )

 4.    നിഴലും വെളിച്ചവും ( Light And Shadow )

 5. ‍  ആര്ട്ടിസ്റ്റിക് ( Artistic )

 ‍ ബ്ലര് (Blur Filter)
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      ഈഫിൽട്ടറുകൾ വിവിധ രീതികളിൽ ചിത്രങ്ങൾ മങ്ങിക്കുന്നു.    ഈഫിൽട്ടറുകൾ  Filters -->  Blur  എന്ന
  മെനു ഇനത്തിൽ ലഭ്യമാണ്

 1.    ഗോസിയൻ ബ്ലർ (Gaussian Blur)
 2. ‍ ‍ സിമ്പിള് ബ്ലര് (Simple Blur)
 3. ‍ ‍ മോഷന് ബ്ലര് (Motion Blur)
 4   പിക്സലൈസ് (Pixelize)
 5.    സെലക്ടീവ് ഗോസിയൻ ബ്ലർ (Selective Gaussian Blur)
 ‍ ‍ഷാര്പ്പെന്(Sharpen Filter)

  ‍  ‍  ‍ ‍ ഒരു ചിത്രത്തിന്റെഅരികുകള് വളരെ കൃത്യതയുള്ളതാക്കാന് ഈഫില്ട്ടര് ഉപയോഗിക്കുന്നു
Filters -->Enhance -->Sharpen  ‍ മെനു ഇനത്തില് ലഭ്യമാണ്.

‍ഡിസ്റ്റോര്ട്സ്(Distorts Filter)
      ഈഫിൽട്ടറുകൾ ചിത്രത്തെ വ്യത്യസ്ത രീതികളിൽ രൂപാന്തരപ്പെടുത്തുന്നു. Filters --> Distorts   എന്ന

   മെനു ഇനത്തിൽ ലഭ്യമാണ്
 1.  എംബോസ് ( Emboss )
 2.   മൊസൈക്ക് ( Mosaic )
 3.  റിപ്പിൾ ( Ripple )
 4.   ഷിഫ്റ്റ് ( Shift )
 5.   വേവ്സ് ( Waves )
 6.  ‍  വിന്ഡ് ( Wind )

 നിഴലും വെളിച്ചവും(Light and Shadow Filter)
         ചിത്രത്തിൽ വിവിധ ഇഫക്റ്റുകൾസൃഷ്ടിക്കുന്നതിന് ഈഫിൽട്ടറുകൾ പ്രകാശവും നിഴലും ഫലപ്രദമായി

ഉപയോഗിക്കുന്നു.   അവ
Filters --> Light And Shadow   ‍ എന്ന മെനു ഇനത്തില് ലഭ്യമാണ്.
 1.   ലെൻസ് ഫ്ലെയർ ( Lens Flare)
 2.   മിന്നൽ പ്രഭാവം ( Lightning Effects)
 3.  സൂപ്പർനോവ ( Supernova)

‍  ആര്ട്ടിസ്റ്റിക് ഫിൽട്ടർ(Artistic Filter)
       ചിത്രത്തിൽ കലാപരമായ ഇഫക്റ്റുകൾസൃഷ്ടിക്കാൻഈഫിൽട്ടറുകൾ ഉപയോഗിക്കുന്നു.    ഈഫിൽട്ടറുകൾ
Filters -->Artistic   ‍ എന്ന മെനു ഇനത്തില് ലഭ്യമാണ്. 
 1.  ക്ലോത്തിഫൈ (Clothify)
 2.  ക്യൂബിസം (Cubism)
 3.   ഓയിലിഫൈ (Oilify)
 4.    സോഫ്റ്റ് ഗ്ലോ (Soft Glow)
 5.  വീവ് (Weave)

     ജിമ്പ് ഉപയോഗിച്ച് ലളിതമായആനിമേഷൻസൃഷ്ടിക്കുന്നു
(Creating simple animation using GIMP)
 GIMP      ഉപയോഗിച്ച് വ്യത്യസ്ത തരത്തിലുള്ളആനിമേഷനുകൾസൃഷ്ടിക്കാൻ കഴിയും.    അവ താഴെ

 പറയുന്നവയാണ് : 
 1.  ‍ റിപ്ലിങ് അനിമേഷന് (Rippling Animation)
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 2.  ബേൺ -  ‍ ഇൻഅനിമേഷന് ( Burn–In-Animation)
        ഈആനിമേഷനുകളെല്ലാം താഴെ പറയുന്ന മെനു ഇനത്തിൽ ലഭ്യമാണ്
 Filters --> Animations

 മാതൃകാ ചോദ്യങ്ങൾ

 1.     പാത്ത് ടൂളിലെ ഓരോ ബിന്ദുവിനെയും ..........  എന്ന് വിളിക്കുന്നു.
 2.  ‍           അഡിറ്റീവ് കളര് സ്കീമും സബ്‌ട്രാക്റ്റീവ് കളർ സ്കീമും തമ്മിൽ വേർതിരിക്കുക.
 3.     പാത്ത് ടൂളിന്റെ ഉപയോഗം എന്താണ് ?
 4.       അഡിറ്റീവ് കളർ സ്കീമിൽ എല്ലാ നിറങ്ങളുടെയും സാന്നിധ്യം ..........  ‍നിറം നല്കുന്നു.
 5.  ‍     സബ്ട്രീക്ടീവ് കളര് സ്കീമിൽ എല്ലാ നിറങ്ങളുടെയും അഭാവം ..........  ‍നിറം നല്കുന്നു.
 6.      ജിമ്പിലെ വിവിധ തരം ഫിൽട്ടറുകൾ ലിസ്റ്റ് ചെയ്യുക.
 7. GIMP-ൽ,        ഒരു ചിത്രത്തിന്റെഅരികുകൾക്ക് കൂടുതൽ വ്യക്തത നൽകാൻ ഉപയോഗിക്കാവുന്നഫിൽറ്റർ
.......... ആണ്.
 8.   ‍  ‍ വ്യത്യസ്ത തരം ബ്ലര് ഫിൽട്ടറുകളുടെ പേരുകള് എഴുതുക.
 9.     ‍ വിവിധ തരംആർട്ടിസ്റ്റിക് ഫിൽട്ടറുകളുടെ പേരുകള് എഴുതുക.
 10.       ജിമ്പ് ഉപയോഗിച്ച് ലളിതമായആനിമേഷൻസൃഷ്ടിക്കുന്നതിനുള്ളഘട്ടങ്ങൾഎഴുതുക.
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CHAPTER 8

 കമ്പ്യൂട്ടർ ശൃംഖലകൾ

•        ഒരുആശയവിനിമയ മാധ്യമത്തിലൂടെ ഇലക്ട്രോണിക് ആയി പരസ്പരം ബന്ധിപ്പിച്ചിരിക്കുന്ന

    കമ്പ്യൂട്ടറുകളുടെയും മറ്റ് ഉപകരണങ്ങളുടെയും ഒരു കൂട്ടമാണിത്

 നെറ്റ്‌വർക്കിന്റെആവശ്യം

 വിഭവങ്ങൾ പങ്കിടൽ

•    ഒരു സിസ്റ്റത്തിലെ ഏത് ഹാർഡ്‌വെയർ/     സോഫ്റ്റ്‌വെയർ റിസോഴ്‌സും നെറ്റ്‌വർക്കിലെ മറ്റ്

  സിസ്റ്റങ്ങളുമായി പങ്കിടാൻ കഴിയും.

  വില പ്രകടനഅനുപാതം

•      ഓരോ കമ്പ്യൂട്ടറിനും ലൈസൻസുള്ള സോഫ്റ്റ്‌വെയർ വാങ്ങുന്നതിനുള്ള ചെലവ്,  ഒരു

      നെറ്റ്‌വർക്കിൽഅത്തരം സോഫ്റ്റ്‌വെയറിന്റെ നെറ്റ്‌വർക്ക് പതിപ്പുകൾ വാങ്ങുന്നതിലൂടെ

കുറയ്ക്കാനാകും.

ആശയവിനിമയം

• ഇ-മെയിൽ, ചാറ്റിംഗ്,     വീഡിയോ കോൺഫറൻസിങ് തുടങ്ങിയ സേവനങ്ങളിലൂടെ

       നെറ്റ്‌വർക്കിലെ മറ്റേതൊരു കമ്പ്യൂട്ടറുമായുംആശയവിനിമയം നടത്താൻ കമ്പ്യൂട്ടർ നെറ്റ്‌വർക്ക്

 ഉപയോക്താക്കളെ സഹായിക്കുന്നു.

വിശ്വാസ്യത

•  ഒരു നെറ്റ്‌വർക്കിൽ,      ഒന്നിലധികം കമ്പ്യൂട്ടറുകളിൽ ഡാറ്റ ബാക്കപ്പ് ചെയ്യാൻസാധിക്കും.  ഡാറ്റ

       ആക്‌സസ് ചെയ്യുന്നതിൽ പരാജയപ്പെട്ടാൽഡാറ്റ വീണ്ടെടുക്കാൻ ഇത് ഉപയോക്താക്കളെ

സഹായിക്കുന്നു.

വ്യാപ്തി

•        നെറ്റ്‌വർക്കിലേക്ക് കമ്പ്യൂട്ടറുകൾ ചേർക്കുകയോ നീക്കം ചെയ്യുകയോ ചെയ്തുകൊണ്ട് കമ്പ്യൂട്ടിംഗ്

   ശേഷി കൂട്ടുകയോ കുറയ്ക്കുകയോ ചെയ്യാം.

key terms

ബാൻഡ്‌വിഡ്ത്ത്:        ഒരു നിശ്ചിത സമയത്തിനുള്ളിൽ ഒരു നിർദ്ദിഷ്ട കണക്ഷനിലൂടെ അയയ്ക്കാനാകുന്ന
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   ഡാറ്റയുടെ അളവ് ഇത് അളക്കുന്നു.

നോയ്‌സ്:         ഡാറ്റ സിഗ്നലുകളുടെ ശക്തി കുറക്കുന്നവൈദ്യുത കാന്തികഊർജ്‌ജമാണിത്

നോഡ്:        ഒരു നെറ്റ്‌വർക്കിലേക്ക് നേരിട്ട് ബന്ധിപ്പിച്ചിരിക്കുന്നഏതൊരു ഉപകരണത്തെയും നോഡ്

 എന്ന് വിളിക്കുന്നു.

  ഡാറ്റാ കമ്മ്യൂണിക്കേഷൻസിസ്റ്റം

•         ഡാറ്റാ കമ്മ്യൂണിക്കേഷൻഎന്നത് ഏതെങ്കിലും രണ്ട് ഉപകരണങ്ങൾക്കിടയിൽ ഒരു ട്രാൻസ്മിഷൻ

    മാധ്യമത്തിലൂടെ ഡിജിറ്റൽഡാറ്റ കൈമാറ്റം ചെയ്യുന്നതാണ്

• 5  അടിസ്ഥാനഘടകങ്ങൾ

Message:   ഇത് അറിയിക്കേണ്ട വിവരമാണ്

Sender:     സന്ദേശങ്ങൾഅയയ്ക്കാൻ ഉപയോഗിക്കുന്ന കമ്പ്യൂട്ടറോ ഉപകരണങ്ങളോ

Receiver:     സന്ദേശങ്ങൾസ്വീകരിക്കുന്ന കമ്പ്യൂട്ടർ അല്ലെങ്കിൽ ഉപകരണം

Medium:        അയക്കുന്നയാളിൽ നിന്ന് സ്വീകർത്താവിലേക്ക് ഒരുസന്ദേശം സഞ്ചരിക്കുന്ന ഭൗതിക

പാതയാണിത്

Protocol:      ഡാറ്റ ട്രാൻസ്മിഷൻ നടക്കുമ്പോൾ പാലിക്കേണ്ട നിയമങ്ങൾ

 കമ്മ്യൂണിക്കേഷൻ മീഡിയം

•         ഒരു കമ്പ്യൂട്ടർ ശൃംഖലയിലൂടെ ഡാറ്റാ കൈമാറ്റത്തിനുള്ള മാധ്യമത്തെ കമ്മ്യൂണിക്കേഷൻ ചാനൽ

    അല്ലെങ്കിൽ കമ്മ്യൂണിക്കേഷൻ മീഡിയം എന്ന് വിളിക്കുന്നു

•   രണ്ട് തരം (1)  ഗൈഡഡ് (2)   അൺഗൈഡഡ്

 ഗൈഡഡ് മീഡിയം

• Coaxial cable, twisted pair cable (Ethernet cable) and optical fibre cable

(a) Twisted pair cable (Ethernet cable)

•   ഏറ്റവും വ്യാപകമായി ഉപയോഗിക്കപ്പെടുന്നു

•   രണ്ട് തരം (1) Unshielded Twisted pair(UTP) (2) Shielded Twisted Pair (STP)

UTP  കേബിളിന്റെ സവിശേഷതകൾ

• ചെലവുകുറഞ്ഞത്

•   കനം കുറഞ്ഞതും വഴക്കമുള്ളതുമാണ്
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•  എളുപ്പത്തിലുള്ള ഇൻസ്റ്റലേഷൻ

• 100     മീറ്റർ വരെ ഡേറ്റ കൊണ്ടുപോകാം

STP  കേബിളിന്റെ സവിശേഷതകൾ

•    നോയ്‌സിനെതിരെ മെച്ചപ്പെട്ട പ്രതിരോധശേഷി

• ചെലവേറിയത്

•   ഇൻസ്റ്റാൾ ചെയ്യാൻ പ്രയാസം

• യുടിപി/       എസ്ടിപി ട്വിസ്റ്റഡ് പെയർ കേബിൾ കമ്പ്യൂട്ടറുമായി ബന്ധിപ്പിക്കാൻ RJ-45  കണക്റ്റർ

ഉപയോഗിക്കുന്നു

(b) Coaxial cable

• 185-500    മീറ്റർ വരെ ഡാറ്റ കൊണ്ടുപോകുന്നു

•    ഉയർന്നബാൻഡ് വിഡ്ത്

•   കുറഞ്ഞ നോയ്‌സ്

• Twisted pair cable  നേക്കാൾ കട്ടിയുള്ളതാണ്

•  കുറഞ്ഞവഴക്കം

•   ഇൻസ്റ്റാൾ ചെയ്യാൻ ബുദ്ധിമുട്ട്

(c) Optical fibre cable

•     ഡാറ്റ പ്രകാശം പോലെ വേഗത്തിൽസഞ്ചരിക്കുന്നു

•  ഉയർന്നബാൻഡ്‌വിഡ്ത്ത്

•    വളരെ ദൂരത്തേക്ക് ഡാറ്റ കൊണ്ടുപോകുന്നു

•    ഡാറ്റാ ട്രാൻസ്മിഷനായി പ്രകാശം ഉപയോഗിക്കുന്നു

•   ഏറ്റവും ചെലവേറിയതും കാര്യക്ഷമവുമാണ്

•   ഇൻസ്റ്റാളേഷനും പരിപാലനവും ബുദ്ധിമുട്ടാണ്

  അൺഗൈഡഡ് മീഡിയം 

•     വയർലെസ് ആശയവിനിമയത്തിന് വൈദ്യുതകാന്തിക തരംഗങ്ങൾ ഉപയോഗിക്കുന്നു

(a) Radio Waves

•   ഫ്രീക്വൻസി ശ്രേണി 3KHz  മുതൽ 3 GHz വരെയാണ്
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•    ഹ്രസ്വവും ദീർഘദൂരവുമായആശയവിനിമയത്തിന് ഉപയോഗിക്കുന്നു

•       റേഡിയോ തരംഗങ്ങൾ എല്ലാ ദിശകളിലേക്കും കൈമാറ്റം ചെയ്യപ്പെടുന്നു

•   വയർഡ് മീഡിയയേക്കാൾ ചെലവുകുറഞ്ഞത്

•    ഒട്ടുമിക്ക വസ്തുക്കളിലൂടെയും തുളച്ചുകയറാൻ കഴിയും

•      മോട്ടോറുകളും മറ്റ് ഇലക്ട്രിക് ഉപകരണങ്ങളും ട്രാൻസ്മിഷൻ ബാധിക്കും

•  സുരക്ഷിതത്വം കുറവാണ്

•     റേഡിയോ തരംഗ പ്രക്ഷേപണത്തിന് അനുമതി ആവശ്യമാണ്

(b) Microwaves

•   ഫ്രീക്വൻസി ശ്രേണി 300MHz  മുതൽ 300GHz വരെയാണ്

•  നേർരേഖയിൽ സഞ്ചരിക്കുന്നു

•     ഏതെങ്കിലും ഖര വസ്തുവിലേക്ക് തുളച്ചുകയറാൻ കഴിയില്ല

•     വയർഡ് മീഡിയയേക്കാൾ ചെലവ് കുറവാണ്

(c) Infrared Waves

•   ഫ്രീക്വൻസി ശ്രേണി 300GHz  മുതൽ 400THz വരെയാണ്

•   ഹ്രസ്വദൂരആശയവിനിമയത്തിന് ഉപയോഗിക്കുന്നു

•  നേർരേഖയിൽ സഞ്ചരിക്കുന്നു

•       ഒരേസമയം രണ്ട് ഉപകരണങ്ങൾക്ക് മാത്രമേ ആശയവിനിമയം നടത്താൻ കഴിയൂ

•    ഖര വസ്തുക്കളെ മറികടക്കാൻ കഴിയില്ല

•    ദൂരം കൂടുന്തോറും പ്രകടനം ദുർബലമാകും

     റേഡിയോ തരംഗങ്ങൾ ഉപയോഗിക്കുന്ന വയർലെസ് കമ്മ്യൂണിക്കേഷൻസാങ്കേതികവിദ്യകൾ

(a) Bluetooth

•   ആവൃത്തി ശ്രേണി 2.402GHz  മുതൽ 2.480GHz വരെയാണ്

•   ഹ്രസ്വദൂരആശയവിനിമയത്തിന് ഉപയോഗിക്കുന്നു

•  സെൽ ഫോണുകൾ, ലാപ്ടോപ്പുകൾ, മൗസ്,   കീബോർഡ് മുതലായവയിൽ ഉപയോഗിക്കുന്നു.

•   ഇത് ഒരേസമയം 8  ഉപകരണങ്ങളിലേക്ക് കണക്റ്റുചെയ്യാനാകും

•     വേഗത കുറഞ്ഞഡാറ്റ കൈമാറ്റ നിരക്ക്

(b) Wi-Fi
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•   ഫ്രീക്വൻസി ശ്രേണി 2.4GHz  മുതൽ 5GHz വരെയാണ്

•    ഡാറ്റ ട്രാൻസ്മിഷൻ വേഗത 54Mbps വരെ

•      ഒരേസമയം കൂടുതൽ ഉപകരണങ്ങൾബന്ധിപ്പിക്കാൻ ഇത് ഉപയോഗിക്കാം

• 375     അടി വരെആശയവിനിമയം നടത്തുന്നതിന് ഉപയോഗിക്കുന്നു

(c) Wi-MAX

•       വേൾഡ് വൈഡ് ഇന്ററോപബിലിറ്റി ഫോർ മൈക്രോവേവ് അക്സസ്സ്

•   ഫ്രീക്വൻസി ശ്രേണി 2GHz  മുതൽ 11GHz വരെയാണ്

•        വളരെ ദൂരത്തേക്ക് അതിവേഗ വയർലെസ് ഇന്റർനെറ്റ് ആക്സസ് നൽകാൻ ഉപയോഗിക്കുന്നു

•     നൂറുകണക്കിന് ഉപയോക്താക്കൾക്ക് ഒരൊറ്റ സ്റ്റേഷനിലേക്ക് കണക്റ്റുചെയ്യാനാകും

• 70Mbps    വരെയുള്ളഹൈസ്പീഡ് കണക്ഷൻ

•    കാലാവസ്ഥാസാഹചര്യങ്ങൾസിഗ്നലിനെ തടസ്സപ്പെടുത്തിയേക്കാം

•   ഉയർന്നവൈദ്യുതി ഉപഭോഗം

(d) Satellite link

•   ഭൂസ്ഥിര ഉപഗ്രഹങ്ങൾ ഉപയോഗിക്കുന്നു

•       ഈഉപഗ്രഹങ്ങളിൽ ട്രാൻസ്‌പോണ്ടർ എന്ന ഇലക്ട്രോണിക് ഉപകരണംഅടങ്ങിയിരിക്കുന്നു

•        ഭൂമിയിലേക്ക് സിഗ്നലുകൾ വർദ്ധിപ്പിക്കാനും വീണ്ടും പ്രക്ഷേപണം ചെയ്യാനും ട്രാൻസ്‌പോണ്ടറുകൾ

ഉപയോഗിക്കുന്നു

•           ഭൂമിയിൽ നിന്ന് ഒരു ഉപഗ്രഹത്തിലേക്ക് സിഗ്നലുകൾസംപ്രേക്ഷണം ചെയ്യുന്നതിനെ അപ് ലിങ്ക്

 എന്ന് വിളിക്കുന്നു

•         ഉപഗ്രഹത്തിൽ നിന്ന് ഭൂമിയിലേക്ക് സിഗ്നലുകൾസംപ്രേക്ഷണം ചെയ്യുന്നതിനെ ഡൗൺലിങ്ക് എന്ന്

വിളിക്കുന്നു

•   അപ്‌ലിങ്ക് ഫ്രീക്വൻസി 106GHz  മുതൽ 30.0GHz വരെയാണ്

•   ഡൗൺലിങ്ക് ഫ്രീക്വൻസി 1.5GHz  മുതൽ 20.0GHz വരെയാണ്

•       ഭൂമിയുടെ ഒരു വലിയ പ്രദേശം ഉൾക്കൊള്ളാൻ ഇതിന് കഴിയും

• ചെലവേറിയത്

•     ഉപയോഗത്തിന് നിയമപരമായഅനുമതിയും അംഗീകാരവും ആവശ്യമാണ്

  ഡാറ്റാ കമ്മ്യൂണിക്കേഷൻ ഉപകരണങ്ങൾ
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•        കമ്പ്യൂട്ടറും ആശയവിനിമയ ചാനലുകളും തമ്മിലുള്ള ഒരു ഇന്റർഫേസ്ആണ് ഇത്

   നെറ്റ്‌വർക്ക് ഇന്റർഫേസ് കാർഡ് (NIC)

•      ഇത് ഡാറ്റയെ മാനേജ് ചെയ്യാവുന്ന യൂണിറ്റുകളായി വിഭജിക്കുന്നു

•  പ്രോട്ടോക്കോൾ പരിഭാഷപ്പെടുത്തുക

•  ചില NIC   കാർഡുകൾക്ക് വയർലെസ് കണക്ഷനുണ്ട്

•    ഡാറ്റാ ട്രാൻസ്ഫർ നിരക്ക് 1Gbps ആണ്

Hub

•     ഒരേ നെറ്റ്‌വർക്കിന്റെ ഉപകരണങ്ങൾബന്ധിപ്പിക്കാൻ ഉപയോഗിക്കുന്നു

•       അതുമായി ബന്ധിപ്പിച്ചിട്ടുള്ള മറ്റെല്ലാ കമ്പ്യൂട്ടറുകളിലേക്കും ഇത് പാക്കറ്റ് കൈമാറുന്നു

•         ഇത് നെറ്റ്‌വർക്ക് ട്രാഫിക് വർദ്ധിപ്പിക്കുകയും ഫലപ്രദമായ ബാൻഡ് വിഡ്ത് കുറയ്ക്കുകയും ചെയ്യുന്നു

Switch

•         ഒരു നെറ്റ്‌വർക്ക് രൂപീകരിക്കുന്നതിന് നിരവധി കമ്പ്യൂട്ടറുകളെ ബന്ധിപ്പിക്കുന്ന ഒരു ഉപകരണമാണ്

സ്വിച്ച.്

• ഇത്ഒരുബുദ്ധിമാനായഉപകരണമാണ്,   കാരണംസ്വീകരിച്ചഡാറ്റലക്ഷ്യസ്ഥാനത്തേക്ക് മാത്രം

  കൈമാറാൻ ഇതിന് കഴിയും.

•      ഇത് കണക്റ്റുചെയ്‌തിരിക്കുന്നഎല്ലാ ഉപകരണങ്ങളുടെയും വിലാസങ്ങൾസംഭരിക്കും

Repeater

•      ഒരുആശയവിനിമയ മാധ്യമത്തിലൂടെ സിഗ്നലുകൾ പുനരുജ്ജീവിപ്പിക്കാൻ ഉപയോഗിക്കുന്നു

Bridge

•      ഒരു ശൃംഖലയെ തരംതിരിക്കുന്നതിന് ഉപയോഗിക്കുന്ന ഉപകരണമാണ് ബ്രിഡ്ജ്.

•         ഒരു നെറ്റ്‌വർക്കിനെ വ്യത്യസ്ത സെഗ്‌മെന്റുകളായി വിഭജിക്കാനും ബ്രിഡ്ജ് ഉപയോഗിച്ച് പരസ്പരം

 ബന്ധിപ്പിക്കാനും കഴിയും.

•      ഇത് ഒരു നെറ്റ്‌വർക്കിലെ ട്രാഫിക്കിന്റെ അളവ് കുറയ്‌ക്കുന്നു.

Router

•          ഒരേ പ്രോട്ടോക്കോൾ ഉപയോഗിച്ച് ഒരേ തരത്തിലുള്ള രണ്ട് നെറ്റ്‌വർക്കുകൾ പരസ്പരം ബന്ധിപ്പിക്കാൻ

   കഴിയുന്ന ഒരു ഉപകരണമാണ് റൂട്ടർ.
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•         ഡാറ്റാ പാക്കറ്റുകൾക്ക് യാത്ര ചെയ്യുന്നതിനും ഒരു നെറ്റ്‌വർക്കിലെ ട്രാഫിക്കിന്റഅളവ്കുറയ്ക്കുന്നതിനും

   ഇത് അനുയോജ്യമായ പാത കണ്ടെത്താനാകും.

Gateway

•          വ്യത്യസ്ത പ്രോട്ടോക്കോൾ ഉള്ള രണ്ട് വ്യത്യസ്ത നെറ്റ്‌വർക്കുകൾ പരസ്പരം ബന്ധിപ്പിക്കാൻ കഴിയുന്ന ഒരു

 ഉപകരണമാണ് ഗേറ്റ്‌വേ.

•       ഇതിന് ഒരു പ്രോട്ടോക്കോൾ മറ്റൊന്നിലേക്ക് വിവർത്തനം ചെയ്യാൻ കഴിയും.

•      ലക്ഷ്യസ്ഥാനത്തെത്താൻ പാക്കറ്റുകൾക്ക് അനുയോജ്യമായ പാത ഇതിന് കണ്ടെത്താനാകും.

Data Terminal equipments

•           ഒരു കമ്പ്യൂട്ടറിലേക്കോ അതിൽ നിന്നോ ഉള്ളഡാറ്റ നിയന്ത്രിക്കുന്ന ഒരു ഉപകരണമാണ് ഡാറ്റ

 ടെർമിനൽ ഉപകരണങ്ങൾ.

Modem

•        ടെലിഫോൺലൈനുകൾ വഴി കമ്പ്യൂട്ടറുകൾ തമ്മിലുള്ളആശയവിനിമയത്തിന് ഉപയോഗിക്കുന്ന

 ഉപകരണമാണ് മോഡം.

• മോഡുലേറ്റർ,     ഡെമോഡ്യൂലേറ്റർ എന്നിവയിൽ നിന്നാണ് പേര് രൂപപ്പെടുന്നത്.

•          ഇത് ഒരു കമ്പ്യൂട്ടറിൽ നിന്ന് ലഭിച്ച ഡിജിറ്റൽസിഗ്നലുകളെ ടെലിഫോൺലൈനുകൾക്കായുള്ള

    അനലോഗ് സിഗ്നലുകളിലേക്കും തിരിച്ചും പരിവർത്തനം ചെയ്യുന്നു.

Multiplexer/Demultiplexer

•         മൾട്ടിപ്ലെക്സിംഗ് ഫിസിക്കൽ മീഡിയയെഫ്രീക്വൻസി ചാനലുകൾ എന്ന് വിളിക്കുന്ന ലോജിക്കൽ

 സെഗ്മെന്റുകളായി വിഭജിക്കുന്നു

•         മൾട്ടിപ്ലക്‌സർ വിവിധ സ്രോതസ്സുകളിൽ നിന്നുള്ളഇൻപുട്ടുകൾസംയോജിപ്പിച്ച് ഒരു മാധ്യമത്തിന്റെ

  വിവിധ ചാനലുകളിലൂടെ അയയ്ക്കുന്നു

•  ഒരു demultiplexer    സിഗ്നലിനെ വേർതിരിച്ച് ലക്ഷ്യസ്ഥാനത്തേക്ക് അയയ്ക്കുന്നു

Network Topologies

•        ഒരു നെറ്റ്‌വർക്ക് രൂപീകരിക്കുന്നതിന് നോഡുകൾ പരസ്പരം ബന്ധിപ്പിച്ചിരിക്കുന്ന രീതി.

• ബസ്, സ്റ്റാർ, റിംഗ്,    മെഷ് എന്നിവയാണ് പ്രധാന ടോപ്പോളജികൾ.

Bus Topology
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•         ബസ് ടോപ്പോളജിയിൽ എല്ലാ നോഡുകളും ബസ് എന്നപ്രധാന കേബിളുമായി ബന്ധിപ്പിച്ചിരിക്കുന്നു.

•          ടെർമിനേറ്റർ എന്ന് വിളിക്കുന്ന ഒരു ചെറിയ ഉപകരണം ബസിന്റെ ഓരോ അറ്റത്തും ഘടിപ്പിച്ചിരിക്കുന്നു.

•      ഒരു നോഡിന് മറ്റൊരു നോഡിലേക്ക് ഡാറ്റ അയയ്‌ക്കേണ്ടിവന്നാൽ,    അത് ബസിലേക്ക് ഡാറ്റ

അയയ്‌ക്കുന്നു.   സിഗ്നൽബസ്സിലൂടെ സഞ്ചരിക്കുന്നു,    ഓരോ നോഡും ബസ് പരിശോധിക്കുന്നു, ഉദ്ദേശിച്ച

   നോഡ് മാത്രമേ ഡാറ്റ സ്വീകരിക്കുകയുള്ളൂ.     സിഗ്നൽ ബസിന്റെ അവസാനത്തിൽ എത്തുമ്പോൾ,

     ടെർമിനേറ്റർ ബസ്സിൽ നിന്നുള്ളസിഗ്നൽആഗിരണം ചെയ്യുന്നു.

Characteristics of bus topology

1)   ഇൻസ്റ്റാൾ ചെയ്യാൻ എളുപ്പമാണ്.

2)   കേബിൾദൈർഘ്യം കുറവാണ്,    അതിനാൽ ഇത് ചെലവ് കുറഞ്ഞതാണ്.

3)     ഒരു നോഡിന്റെ പരാജയം നെറ്റ്‌വർക്കിനെ ബാധിക്കില്ല.

4)  കേബിൾ (ബസ്)                         അല്ലെങ്കിൽ ടെർമിനേറ്റർ എന്നിവയുടെ പരാജയം മുഴുവൻ

  നെറ്റ്‌വർക്കിന്റെയും തകർച്ചയിലേക്ക് നയിക്കുന്നു.

5)   തെറ്റുകൾ നിർണ്ണയിക്കാൻ ബുദ്ധിമുട്ടാണ്.

6)        ഒരു സമയം ഒരു നോഡിന് മാത്രമേ ഡാറ്റ കൈമാറാൻ കഴിയൂ.

Star Topology
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•        സ്റ്റാർ ടോപ്പോളജിയിൽ ഓരോ നോഡും നേരിട്ട് ഒരു ഹബ് /  സ്വിച്ചിലേക്ക് ബന്ധിപ്പിച്ചിരിക്കുന്നു.

•        ഏതെങ്കിലും നോഡിന് മറ്റേതെങ്കിലും നോഡിലേക്ക് കുറച്ച് വിവരങ്ങൾഅയയ്‌ക്കേണ്ടി വന്നാൽ, 

  അത് ഹബ് /   സ്വിച്ചിലേക്ക് സിഗ്നൽഅയയ്ക്കുന്നു.

•    സിഗ്നൽഎല്ലാ നോഡുകളിലേക്കും (   ഒരു ഹബിന്റെ കാര്യത്തിൽ)  പ്രക്ഷേപണം ചെയ്യുന്നു,  പക്ഷേ

   ഉദ്ദേശിച്ച നോഡ് മാത്രമേ സ്വീകരിക്കുകയുള്ളൂ.

•   ഒരു സ്വിച്ചിന്റെ കാര്യത്തിൽ,     ഉദ്ദേശിച്ച നോഡിലേക്ക് മാത്രമേ സിഗ്നൽഅയയ്ക്കൂ.

Characteristics of star topology 

1)     ബസ് ടോപ്പോളജിയുമായി താരതമ്യപ്പെടുത്തുമ്പോൾ കൂടുതൽ കാര്യക്ഷമമാണ്.

2)   ഇൻസ്റ്റാൾ ചെയ്യാൻ എളുപ്പമാണ്.

3)   തെറ്റുകൾ നിർണ്ണയിക്കാൻ എളുപ്പമാണ്.

4)   സെൻട്രൽ ഹബ് /     സ്വിച്ചിന്റെ സവിശേഷതകളെആശ്രയിച്ച് വികസിപ്പിക്കാൻ

എളുപ്പമാണ്.

5)  ഹബ് /      സ്വിച്ച് പരാജയം മുഴുവൻ നെറ്റ്‌വർക്കിന്റെയും പരാജയത്തിലേക്ക്

നയിക്കുന്നു.

6)         ബസ് ടോപ്പോളജിയുമായി താരതമ്യപ്പെടുത്തുമ്പോൾ കൂടുതൽ കേബിൾദൈർഘ്യം

 ആവശ്യമാണ്.

Ring Topology

•           റിംഗ് ടോപ്പോളജിയിൽ എല്ലാ നോഡുകളും റിംഗ് അല്ലെങ്കിൽ സർക്കിൾ ലൂപ്പ് ചെയ്യുന്ന കേബിൾ

 ഉപയോഗിച്ച് ബന്ധിപ്പിച്ചിരിക്കുന്നു.

•      ഒരു റിംഗ് ടോപ്പോളജി ഒരു സർക്കിളിന്റെ രൂപത്തിലാണ്.

•       ഒരു റിംഗിൽ ഒരു ദിശയിൽ മാത്രമേ ഡാറ്റ സഞ്ചരിക്കൂ.
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•         ഓരോ നോഡും സിഗ്നലിനെ പുനരുജ്ജീവിപ്പിക്കുകയും ഉദ്ദേശിച്ച നോഡ് എത്തുന്നതുവരെഅടുത്ത

  നോഡിലേക്ക് കടക്കുകയും ചെയ്യുന്നു.

Characteristics of ring topology

1)       ഓരോ നോഡും സിഗ്നൽ വർദ്ധിപ്പിക്കുന്നതിനാൽ സിഗ്നൽആംപ്ലിഫിക്കേഷൻആവശ്യമില്ല.

2)   കേബിൾദൈർഘ്യം കുറവാണ്,   അതിനാൽ ചെലവ് കുറവാണ്.

3)   ഒരു നോഡ് പരാജയപ്പെടുകയാണെങ്കിൽ,   മുഴുവൻ നെറ്റ്‌വർക്കും പരാജയപ്പെടും.

4)    നെറ്റ്‌വർക്കിലേക്ക് നോഡുകൾ ചേർക്കുന്നത് ബുദ്ധിമുട്ടാണ്.

Mesh Topology

•  മെഷ് ടോപ്പോളജിയിൽ,     ഓരോ നോഡും മറ്റ് നോഡുകളുമായി ബന്ധിപ്പിച്ചിരിക്കുന്നു.

•      രണ്ട് നോഡുകൾക്കിടയിൽ ഒന്നിൽ കൂടുതൽ പാത ഉണ്ടാകും.

•   ഒരു പാത്ത് പരാജയപ്പെട്ടാൽ,     ഡാറ്റ മറ്റൊരു പാതയിലൂടെ ലക്ഷ്യസ്ഥാനത്ത് എത്തും

Characteristics of mesh topology

1)      നോഡുകൾക്കിടയിലുള്ള ഒരു പാത പരാജയപ്പെട്ടാലും നെറ്റ്‌വർക്ക്

പരാജയപ്പെടുകയില്ല.

2)    അധിക കേബിളുകൾആവശ്യമുള്ളതിനാൽ ചെലവേറിയത്.

3)     വളരെ സങ്കീർണ്ണവും കൈകാര്യം ചെയ്യാൻ പ്രയാസവുമാണ്.

Types of network

•   ഉൾപ്പെടുന്ന പ്രദേശത്തിന്റെഅടിസ്ഥാനത്തിൽ,    കമ്പ്യൂട്ടർ നെറ്റ്‌വർക്കുകൾ ഇങ്ങനെ തരംതിരിക്കുന്നു:

PAN - Personal Area Network

LAN - Local Area Network 
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MAN - Metropolitan Area Network

WAN - Wide Area Network

1) Personal Area Network (PAN)

•      ഒരു വ്യക്തിയുടെ സാമീപ്യത്തിലുള്ളആശയവിനിമയ ഉപകരണങ്ങളുടെ (കമ്പ്യൂട്ടർ, മൊബൈൽ, 

ടാബ്‌ലെറ്റ്,  പ്രിന്റർ മുതലായവ)   ഒരു ശൃംഖലയാണ് പാൻ.

•        കുറച്ച് മീറ്ററുള്ള ദൂരത്തിന്റെ വിസ്തീർണം ഇതിന് ഉൾകൊള്ളാൻ കഴിയും

2) LAN (Local Area Network)

•         ഒരു മുറി കെട്ടിടത്തിലോ കാമ്പസിലോ ഉള്ള ഉപകരണങ്ങളുടെ ഒരു ശൃംഖലയാണ് ലാൻ.

•          ഇതിന് കുറച്ച് മീറ്റർ മുതൽഏതാനും കിലോമീറ്റര് വരെ ദൂരം സഞ്ചരിക്കാനാകും

3) MAN (Metropolitan Area Network):

•   ഒരു നഗരത്തിനുള്ളിലെ കമ്പ്യൂട്ടിംഗ്,     ആശയവിനിമയ ഉപകരണങ്ങളുടെ ഒരു ശൃംഖലയാണ്

MAN.

•          ഇതിന് ഏതാനും കിലോമീറ്റർ മുതൽഏതാനും നൂറു കിലോമീറ്റർ ദൂരം വരെ സഞ്ചരിക്കാനാകും.

•        നിരവധി ലാനുകളും വ്യക്തിഗത കമ്പ്യൂട്ടറുകളും പരസ്പരം ബന്ധിപ്പിച്ചാണ് സാധാരണയായിMAN 

രൂപപ്പെടുന്നത്

4) WAN (Wide Area Network):

•  ഒരു നഗരം,      രാജ്യം അല്ലെങ്കിൽ ഭൂഖണ്ഡത്തിന്റെ പരിധി ലംഘിക്കുന്ന കമ്പ്യൂട്ടിംഗ്, ആശയവിനിമയ

   ഉപകരണങ്ങളുടെ ഒരു ശൃംഖലയാണ് WAN.

•      നൂറുകണക്കിന് കിലോമീറ്ററിലധികം ദൂരം ഇതിന് ഉൾക്കൊള്ളാൻ കഴിയും.

Summary of PAN, LAN, MAN, WAN

Parameter PAN LAN MAN WAN

വിസ്തീർണ്ണം

 ചെറിയ

 വിസ്തീർണ്ണം (10 

  മീറ്റർ ദൂരം വരെ)

  കുറച്ച് മീറ്റർ മുതൽ

 കുറച്ച് കിലോമീറ്റർ

 വരെ (10 Km 

 ദൂരം വരെ)

  ഒരു നഗരവും

 പരിസരവും

(100 Km  ദൂരം

വരെ)

 മുഴുവൻ രാജ്യം, 

ഭൂഖണ്ഡം,

 അല്ലെങ്കിൽ

ഗ്ലോബ്
പ്രക്ഷേപണ

വേഗത
 ഉയർന്ന വേഗത  ഉയർന്ന വേഗത  മിതമായ വേഗത  കുറഞ്ഞ വേഗത

നെറ്റ്‌വർക്കിംഗ് നിസാരമാണ് ചെലവുകുറഞ്ഞ  മിതമായ ചെലവേറിയത്
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ചെലവ് ചെലവേറിയത്

  നെറ്റ്‌വർക്കുകളുടെ ലോജിക്കൽ വർഗ്ഗീകരണം

•    നെറ്റ്‌വർക്കിലെ കമ്പ്യൂട്ടറിന്റെ പങ്കിനെ അടിസ്ഥാനമാക്കി

•  രണ്ട് വിഭാഗങ്ങൾ:   പിയർ ടു പിയർ,  ക്ലയന്റ് സെർവർ

  പിയർ ടു പിയർ

•  സമർപ്പിത സെർവറുകളൊന്നുമില്ല

•          ഏതൊരു കമ്പ്യൂട്ടറിനും ഒരു ക്ലയന്റ് ആയി അല്ലെങ്കിൽ ഒരു സെർവറായി പ്രവർത്തിക്കാൻ കഴിയും

•   ചെറിയ നെറ്റ്‌വർക്കുകൾക്ക് അനുയോജ്യം

ക്ലയന്റ്-സെർവർ

•         ക്ലയന്റ് സെർവർആർക്കിടെക്ചറിൽ സെർവർ എന്ന് വിളിക്കപ്പെടുന്ന ഉയർന്ന നിലവാരമുള്ള

 കമ്പ്യൂട്ടർ അടങ്ങിയിരിക്കുന്നു

•   സെർവറുകളുടെ വർഗ്ഗീകരണം ഇവയാണ്:

 ഫയൽ സെർവർ:      ഒരു നെറ്റ്‌വർക്കിൽ ഫയലുകൾസൂക്ഷിക്കുകയും നിയന്ത്രിക്കുകയും

  ചെയ്യുന്ന ഒരു കമ്പ്യൂട്ടർ

 വെബ് സെർവർ:    വെബ്‌പേജുകൾക്കായുള്ളഅഭ്യർത്ഥനകളോട് പ്രതികരിക്കാൻ

  സമർപ്പിതമായ ഒരു കമ്പ്യൂട്ടർ

 പ്രിന്റ് സെർവർ:        ക്ലയന്റുകളിൽ നിന്ന് പ്രത്യേക പ്രിന്ററുകളിലേക്ക് പ്രിന്റ് ജോലി റീഡയറക്‌ട്

ചെയ്യുക

 ഡാറ്റാബേസ് സെർവർ:       ഒരു പൊതു ഡാറ്റാബേസിൽഡാറ്റ പരിഷ്കരിക്കാനോ കാണാനോ

  ഇല്ലാതാക്കാനോ ക്ലയന്റുകളെ അനുവദിക്കുക

 നെറ്റ്‌വർക്ക് പ്രോട്ടോക്കോളുകൾ

        നെറ്റ്‌വർക്കിലെ ഉപകരണങ്ങൾ പരസ്പരം ഡാറ്റ കൈമാറ്റം ചെയ്യുമ്പോൾ നെറ്റ്‌വർക്കിൽ പാലിക്കേണ്ട

  നിയമങ്ങളുടെ ഒരു കൂട്ടമാണിത്

TCP/IP

  ട്രാൻസ്മിഷൻ കൺട്രോൾ പ്രോട്ടോക്കോൾ/  ഇന്റർനെറ്റ് പ്രോട്ടോക്കോൾ

       ലോക്കൽ നെറ്റ്‌വർക്കുകളിലും ഇന്റർനെറ്റിലും നെറ്റ്‌വർക്ക് ഉപകരണങ്ങൾ പരസ്പരം ബന്ധിപ്പിക്കാൻ

ഉപയോഗിക്കുന്നു
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      ഡാറ്റആദ്യം ടിസിപി വഴി ചെറിയ പാക്കറ്റുകളായി വിഭജിക്കപ്പെടുന്നു,    തുടർന്ന് ഇന്റർനെറ്റ് പ്രോട്ടോക്കോൾ (IP) 

അയയ്ക്കുക,        ഈഓരോ പാക്കറ്റുകളും ശരിയായ ലക്ഷ്യസ്ഥാനത്തേക്ക് ഡെലിവറി ചെയ്യുന്നതിനുള്ള

ഉത്തരവാദിത്തമാണ്.

HTTP, FTP, DNS  എന്നിവയാണ് TCP/IP    പ്രോട്ടോക്കോളിന്റെ മൂന്ന് ഉപ പ്രോട്ടോക്കോളുകൾ 

HTTP

  ഹൈപ്പർടെക്സ്റ്റ് ട്രാൻസ്ഫർ പ്രോട്ടോക്കോൾ

         ക്ലയന്റ് ഭാഗത്ത് നിന്ന് അഭ്യർത്ഥനകൈമാറുന്നതിനും സെർവർ ഭാഗത്ത് നിന്ന് പ്രതികരണങ്ങൾ

     സ്വീകരിക്കുന്നതിനുമുള്ള ഒരുസ്റ്റാൻഡേർഡ് പ്രോട്ടോക്കോൾആണ് ഇത്

HTTP    അഭ്യർത്ഥനയുടെയും പ്രതികരണത്തിന്റെയും ജോഡിയെ HTTP   സെഷൻഎന്ന് വിളിക്കുന്നു

HTTP   ട്രാൻസ്മിഷൻ മീഡിയം സ്വതന്ത്രമാണ്

FTP

  ഫയൽ ട്രാൻസ്ഫർ പ്രോട്ടോക്കോൾ

    ഇന്റർനെറ്റിലൂടെ കമ്പ്യൂട്ടറുകൾക്കിടയിൽ ഫയലുകൾകൈമാറുന്നതിനുള്ളഎളുപ്പവഴിയാണിത്

      ഫയലുകൾഅപ്‌ലോഡ് ചെയ്യാനും ഡൗൺലോഡ് ചെയ്യാനും ഒരു FTP    ക്ലയന്റ് പ്രോഗ്രാം ഉപയോഗിക്കാം

(FileZilla, CuteFTP മുതലായവ)

DNS

  ഡൊമെയ്ൻ നെയിം സിസ്റ്റം

          ബ്രൗസറിന്റെഅഡ്രസ് ബാറിൽ നമ്മൾടൈപ്പ് ചെയ്യുന്ന ഡൊമെയ്ൻ നെയിമിന്റെഐപി വിലാസം

നൽകുന്നു

     ഇന്റർനെറ്റിലെ എല്ലാ വെബ്‌സൈറ്റുകളുടെയും ഡൊമെയ്‌ൻ നാമങ്ങളും IP   വിലാസ വിവരങ്ങളും

 സംഭരിക്കുന്നതിന് DNS   ഒരു ഡാറ്റാബേസ് പരിപാലിക്കുന്നു

   ഒരു നെറ്റ്‌വർക്കിലൂടെയുള്ള കമ്പ്യൂട്ടറുകളുടെ തിരിച്ചറിയൽ

Media Access Control (MAC) addresses

  ഓരോ എൻ‌ഐ‌സിക്കും (   നെറ്റ്‌വർക്ക് ഇന്റർ‌ഫേസ് കാർഡ്)    അതിന്റെ നിർമ്മാതാവ് നൽകിയിട്ടുള്ള

    സാർ‌വ്വത്രികമായി സവിശേഷമായഅഡ്രസ് (12   അക്ക ഹെക്സാഡെസിമൽ നമ്പർ).

MAC       വിലാസങ്ങൾസാധാരണയായി ഇനിപ്പറയുന്ന രണ്ട് ഫോർമാറ്റുകളിൽ ഒന്നിൽ എഴുതുന്നു:

MM: MM: MM: SS: SS: SS  അല്ലെങ്കിൽMM - MM - MM - SS - SS - SS
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 ഒരുMAC      അഡ്രസിന്റെ ആദ്യ പകുതിയിൽ (MM: MM: MM)    അഡാപ്റ്റർ നിർമ്മാതാവിന്റെഐഡി

 നമ്പർഅടങ്ങിയിരിക്കുന്നു.

 ഒരുMAC     അഡ്രസിന്റെ രണ്ടാം പകുതി (SS: SS: SS)    അതിന്റെ നിർമ്മാതാവ് അഡാപ്റ്ററിലേക്ക്

(എൻ‌ഐ‌സി)    നിയോഗിച്ചിട്ടുള്ളസീരിയൽ നമ്പറിനെ പ്രതിനിധീകരിക്കുന്നു.

eg. 00:A0:C9 : 14:C8:35

Internet Protocol (IP) Address

        ഒരു നെറ്റ്‌വർക്കിലെ ഓരോ നോഡിനും അവരുടെ അദ്വിതീയ തിരിച്ചറിയലിനായി നിയുക്തമാക്കിയിരിക്കുന്ന 4 

     ഭാഗങ്ങളുള്ള ഒരുഅദ്വിതീയ വിലാസമാണ്ഐപി അഡ്രെസ്സ്.

  നാല് ബൈറ്റുകളുടെ (  അല്ലെങ്കിൽ 32 ബിറ്റുകൾ)     ഒരു ഗ്രൂപ്പാണ്ഐപി അഡ്രെസ്സ് ,   അവയിൽ ഓരോന്നും 0 

 മുതൽ 255  വരെയുള്ളസംഖ്യകളാകാം.

  യൂണിഫോം റിസോഴ്സ് ലൊക്കേറ്റർ(URL)

        ഇൻറർനെറ്റിലെ ഒരു നെറ്റ്‌വർക്ക് റിസോഴ്‌സ് തിരിച്ചറിയാൻ ഉപയോഗിക്കുന്ന ഫോർമാറ്റ് ചെയ്‌ത

സ്ട്രിംഗാണിത്

URL-     ൽഅക്ഷരങ്ങളും അക്കങ്ങളും വിരാമചിഹ്നങ്ങളും അടങ്ങിയിരിക്കുന്നു

 മൂന്ന് ഭാഗങ്ങൾ

(1)  നെറ്റ്‌വർക്ക് പ്രോട്ടോക്കോൾ

(2)                                                               ഡൊമെയ്ൻ നാമം

(3)  ഫയലിന്റെ പേര്
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Protocol

      ഡൊമെയ്‌നിൽ വ്യക്തമാക്കിയ വിവരങ്ങൾആക്‌സസ് ചെയ്യാൻ പ്രോട്ടോക്കോൾ

  ഉപയോഗിക്കുന്നുണ്ടെന്ന് സൂചിപ്പിക്കുന്നു

Domain Name

      ഡൊമെയ്ൻ നെയിം സിസ്റ്റം വഴി സെർവറിന് നൽകിയിരിക്കുന്ന പേരാണിത്

File Name

   തുറക്കാനുള്ളഫയലിനെ സൂചിപ്പിക്കുന്നു
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CHAPTER 9

ഇന്റർനെറ്റ്

 ഇന്റർനെറ്റിന്റെ ചരിത്രം

      യുണൈറ്റഡ് സ്റ്റേറ്റ്സ് ഡിപ്പാർട്ട്മെന്റ് ഓഫ് ഡിഫൻസ്ആണ് ARPANET (   അഡ്വാൻസ്ഡ് റിസർച്ച്

  പ്രോജക്ട് ഏജൻസി നെറ്റ്‌വർക്ക്)    എന്ന പേരിൽ ഇന്റർനെറ്റ് വികസിപ്പിച്ചത്.

 ആശയവിനിമയത്തിനായി ARPANET  TCP/IP  പ്രോട്ടോക്കോൾ ഉപയോഗിക്കുന്നു

     ആദ്യത്തെവൈഡ് ഏരിയ കണക്ഷനായി അർപാനെറ്റ് കണക്കാക്കപ്പെടുന്നു

     വിൻസെന്റ് ഗ്രേ സെർഫിനെ ഇന്റർനെറ്റിന്റെ പിതാവായി കണക്കാക്കുന്നു

      ടിം ബെർണേഴ്സ് ലീ വേൾഡ് വൈഡ് വെബ് (WWW)   എന്നആശയം മുന്നോട്ടുവച്ചു.

HTTP, HTML       എന്നിവ കണ്ടുപിടിച്ചതിന്റെ ബഹുമതി അദ്ദേഹത്തിനും അദ്ദേഹത്തിന്റെസംഘത്തിനുമാണ്

       ലോകമെമ്പാടുമുള്ള ഉപയോക്താക്കൾക്ക് സേവനം നൽകുന്ന കമ്പ്യൂട്ടർ നെറ്റ്‌വർക്കുകളുടെ പരസ്പരബന്ധിത

 സംവിധാനമാണ് ഇന്റർനെറ്റ്

      ഇന്റർനെറ്റിന് സമാനമായ ഒരുസ്വകാര്യ കമ്പ്യൂട്ടർ ശൃംഖലയാണ് ഇൻട്രാനെറ്റ്

         ഒരു കമ്പനിയുടെ സ്വകാര്യ നെറ്റ്‌വർക്കിന്റെ ഭാഗമല്ലാത്ത ചില കമ്പ്യൂട്ടറുകളിലേക്ക് ഒരു ഇൻട്രാനെറ്റ്

     ആക്‌സസ് ചെയ്യപ്പെടുമ്പോൾഅതിനെ എക്‌സ്‌ട്രാനെറ്റ് എന്ന് വിളിക്കുന്നു.

Connecting the computer to the internet

       ഒരു കമ്പ്യൂട്ടറിനെ ഇന്റർനെറ്റുമായി ബന്ധിപ്പിക്കുന്നതിന് ഇനിപ്പറയുന്നഹാർഡ്‌വെയറും സോഫ്റ്റ്‌വെയറും

ആവശ്യമാണ്

1.     നെറ്റ്‌വർക്ക് ഇന്റർഫേസ് കാർഡുള്ള ഒരു കമ്പ്യൂട്ടർ

2. മോഡം

3.  ടെലിഫോൺ കണക്ഷൻ

4.     ഒരു ഇന്റർനെറ്റ് സേവന ദാതാവ് (ISP)   നൽകിയ ഇന്റർനെറ്റ് അക്കൗണ്ട്

5.  ബ്രൗസർ സോഫ്റ്റ്‌വെയർ

Types of connectivity

Dial-up Connectivity
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         ഇന്റർനെറ്റ് സേവന ദാതാവിലെ സെർവറിലേക്ക് ഡയൽ ചെയ്യാനും കണക്‌റ്റ് ചെയ്യാനും പരമ്പരാഗത

     ടെലിഫോൺലൈനും ഡയൽഅപ്പ് മോഡവും ഉപയോഗിക്കുന്നു

   ഈതരത്തിലുള്ള കണക്ഷനുകൾ 56kbps  മോഡം ഉപയോഗിക്കുന്നു

  പരമാവധി വേഗത 56kbps ആണ്

 ചെലവ് കുറവാണ്

    ടെലിഫോൺ കണക്ഷന്റെഎക്സ്ക്ലൂസീവ് ഉപയോഗം ആവശ്യമാണ്

Wired broadband Connectivity

 എല്ലായ്‌പ്പോഴും ഓൺ'   ആയകണക്ഷനുകൾ

    ഡയൽ ചെയ്ത് കണക്റ്റ് ചെയ്യേണ്ടആവശ്യമില്ല

        ഒരു ബ്രോഡ്‌ബാൻഡ് മോഡം ഉപയോഗിക്കുകയും ഇന്റർനെറ്റ് ഉപയോഗിക്കുമ്പോൾ പോലും ടെലിഫോൺ

  ഉപയോഗിക്കാൻസാധിക്കുകയും ചെയ്യുന്നു

Dial-up connection Wired broadband connection

  വേഗത കുറഞ്ഞകണക്ഷൻ, 56kbps  വരെ വേഗത   ഉയർന്ന വേഗതയുള്ളകണക്ഷൻ, വേഗത

256kbps  ൽ കൂടുതലാണ്

ISP-     യിലേക്ക് കണക്റ്റുചെയ്യാൻഡയലിംഗ്

ആവശ്യമാണ്

   എപ്പോഴും ഓൺആയ കണക്ഷൻ

   ടെലിഫോൺ കണക്ഷന്റെഎക്സ്ക്ലൂസീവ് ഉപയോഗം     ഫോണിന്റെയും ഇന്റർനെറ്റിന്റെയും ഒരേസമയ

ഉപയോഗം

ഡയൽ-   അപ്പ് മോഡം ഉപയോഗിക്കുന്നു   ബ്രോഡ്ബാൻഡ് മോഡം ഉപയോഗിക്കുന്നു

    ഇന്റഗ്രേറ്റഡ് സർവീസ് ഡിജിറ്റൽ നെറ്റ്‌വർക്ക് (ISDN),  കേബിൾ ഇന്റർനെറ്റ്,   ഡിജിറ്റൽസബ്‌സ്‌ക്രൈബർ

 ലൈൻ (DSL),  ലീസ്ഡ് ലൈനുകൾ,     ഫൈബർ ടു ദ ഹോം (FTTH)   എന്നിവയാണ് ജനപ്രിയ

 ബ്രോഡ്‌ബാൻഡ് സാങ്കേതികവിദ്യകൾ.

1. Integrated Services Digital Network(ISDN)

       ഒരേ സമയം ഡാറ്റയും ശബ്ദവും കൈമാറാൻ സാധിക്കുന്നു

  രണ്ട് ചാനലുകൾ ഉപയോഗിക്കുന്നു,    ഒന്ന് ശബ്ദത്തിനും മറ്റൊന്ന് ഡാറ്റയ്ക്കും

2Mbps    വരെയുള്ളഡാറ്റാ ട്രാൻസ്ഫർ നിരക്ക്

2. Cable Internet
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       വീട്ടിലേക്ക് ടെലിവിഷൻസിഗ്നൽസംപ്രേഷണത്തിനായിസ്ഥാപിച്ചിരിക്കുന്ന കോക്സിയൽ കേബിളുകൾ

ഉപയോഗിക്കുന്നു

   ഒരു കേബിൾ മോഡം ഉപയോഗിക്കുന്നു

 ഇതിന് 1Mbps  മുതൽ 10Mbps    വരെ വേഗത നൽകാൻ കഴിയും

3. Digital Subscriber Line (DSL)

   സാധാരണ ടെലിഫോൺലൈനുകൾ ഉപയോഗിക്കുന്നു

        ഇന്റർനെറ്റ് ആശയവിനിമയത്തിനും ഒരേസമയം വോയ്‌സ് കോളുകൾ ചെയ്യുന്നതിനും കോപ്പർ ടെലിഫോൺ

   ലൈനുകൾ ഉപയോഗിക്കുന്നു

ADSL (    അസിമട്രിക് ഡിജിറ്റൽസബ്സ്ക്രൈബർലൈൻ)   ആണ് പൊതുവായ ഉപവിഭാഗം

 വേഗത 256Kbps  മുതൽ 24Mbps വരെയാണ്

     ഇന്ത്യയിൽ ലഭ്യമായ ഏറ്റവും ജനപ്രിയമായ ബ്രോഡ്‌ബാൻഡ് സേവനം

4. Leased line

     ഇന്റർനെറ്റ് സൗകര്യം ലഭ്യമാക്കാൻ ഉപയോഗിക്കുന്നസമർപ്പിതലൈനുകളാണിത്

 വേഗത 2Mbps  മുതൽ 100Mbps വരെയാണ്

5. Fibre To The Home (FTTH)

    ഡാറ്റാ ട്രാൻസ്മിഷനായി ഒപ്റ്റിക്കൽഫൈബറുകൾ ഉപയോഗിക്കുന്നു

  ഹൈസ്പീഡ് കണക്റ്റിവിറ്റി

Wireless broadband connectivity

 മൊബൈൽ ബ്രോഡ്‌ബാൻഡ്, വൈ-മാക്‌സ്,  സാറ്റലൈറ്റ് ബ്രോഡ്‌ബാൻഡ്,   വൈഫൈഎന്നിവയാണ്

   ജനപ്രിയ വയർലെസ് ബ്രോഡ്‌ബാൻഡ് ആക്‌സസ്സ്

1. Mobile Broadband

     മൊബൈൽ ഫോൺ ഉപയോഗിച്ചുള്ള വയർലെസ് ഇന്റർനെറ്റ് ആക്സസ്

 മൊബൈൽ ഫോണുകൾ,     ടാബ്‌ലെറ്റ് തുടങ്ങിയ ഉപകരണങ്ങളിലാണ് മോഡം നിർമ്മിച്ചിരിക്കുന്നത്.

       യാത്രയിൽ എവിടെനിന്നും ഇന്റർനെറ്റ് ആക്‌സസ് ചെയ്യാൻ ഉപയോക്താവിനെഅനുവദിക്കുന്നതിനുള്ള

  സ്വാതന്ത്ര്യം വാഗ്ദാനം ചെയ്യുക

       ഡാറ്റാ ട്രാൻസ്മിഷനായി ഇത് മൊബൈൽ ഫോണുകളുടെ സെല്ലുലാർ നെറ്റ്‌വർക്ക് ഉപയോഗിക്കുന്നു
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2. Wi-Max

       വേൾഡ് വൈഡ് ഇന്റർ ഓപെറബിലിറ്റി ഫോർ മൈക്രോവേവ് ആക്‌സസ്

  വയർഡ് ബ്രോഡ്‌ബാൻഡിനുള്ളബദലാണിത്

50        കിലോമീറ്റർ വരെ വയർലെസ് ഇന്റർനെറ്റ് ആക്‌സസ് നൽകാൻ ഇതിന് കഴിയും

 ഇതിന് 70Mbps    വരെ വേഗത നൽകാൻ കഴിയും

3. Satellite broadband

    സാറ്റലൈറ്റ് വഴിയാണ് ഇന്റർനെറ്റ് കണക്ടിവിറ്റി നൽകുന്നത്

    വളരെ ചെറിയ അപ്പേർച്ചർ ടെർമിനൽ (VSAT)     ഡിഷ് ആന്റിനയും ഒരു ട്രാൻസ്‌സിവറും (  ട്രാൻസ്മിറ്ററും

റിസീവറും)   ഉപയോക്താക്കളുടെ ലൊക്കേഷനിൽആവശ്യമാണ്.

1Gbps  വരെ വേഗത

    ബ്രോഡ്‌ബാൻഡ് ഇന്റർനെറ്റിന്റെ ഏറ്റവും ചെലവേറിയ രൂപങ്ങൾ

ബാങ്കുകൾ,  സ്റ്റോക്ക് എക്സ്ചേഞ്ചുകൾ,   സർക്കാരുകൾ തുടങ്ങിയവ ഉപയോഗിക്കുന്നു.

Internet Access sharing methods

1. Using LAN

    ഒരു കമ്പ്യൂട്ടറിലെ ഇന്റർനെറ്റ് കണക്ഷൻ LAN-    ലെ മറ്റ് കമ്പ്യൂട്ടറുകൾക്കിടയിൽ പങ്കിടാം

       ഓപ്പറേറ്റിംഗ് സിസ്റ്റത്തിന്റെസവിശേഷതകൾ ഉപയോഗിച്ചോ പ്രോക്സി സെർവർ സോഫ്റ്റ്വെയർ ഉപയോഗിച്ചോ

  ഇത് ചെയ്യാൻ കഴിയും

2. Using Wi-Fi network

Wi-Fi          റൂട്ടർ അല്ലെങ്കിൽ വയർലെസ് നെറ്റ്‌വർക്ക് ആക്‌സസ് പോയിന്റ് ഉപയോഗിച്ച് ഇന്റർനെറ്റ് കണക്റ്റിവിറ്റി

 പങ്കിടാൻ കഴിയും,    ഇതിനെ ഹോട്ട്‌സ്‌പോട്ട് എന്ന് വിളിക്കുന്നു

  ഇതിന് ഏകദേശം 100  മീറ്റർ പരിധിയുണ്ട്

   വയർഡ് കണക്ഷനേക്കാൾസുരക്ഷിതത്വം കുറവാണ്

3. Using Li-Fi network

   വൈഫൈയുടെ ഫാസ്റ്റ് ഒപ്റ്റിക്കൽ പതിപ്പ്

  ഡാറ്റ നിരക്ക് 100Mbps ആണ്

   എയർക്രാഫ്റ്റുകളിലും ഹോസ്പിറ്റലുകളിലും ഇത് ഉപയോഗിക്കാം
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Services on Internet

www, ഇ-മെയിൽ,  സെർച്ച് എഞ്ചിനുകൾ,       സോഷ്യൽ മീഡിയ തുടങ്ങി വിവിധ സേവനങ്ങൾ ഇന്റർനെറ്റ്

 വാഗ്ദാനം ചെയ്യുന്നു

1) World Wide Web (WWW)

       ദശലക്ഷക്കണക്കിന് ക്ലയന്റുകളും സെർവറുകളും പരസ്പരം ബന്ധിപ്പിച്ചിരിക്കുന്ന ഒരു വലിയ ക്ലയന്റ്-  സെർവർ

 സിസ്റ്റമാണ് WWW.

a) Browser : 

        വിവരങ്ങൾ വീണ്ടെടുക്കാനോ അവതരിപ്പിക്കാനോ വേൾഡ് വൈഡ് വെബിലെ വെബ് പേജുകളിലൂടെ

     നാവിഗേറ്റുചെയ്യാനോ ഉപയോഗിക്കുന്ന ഒരു സോഫ്റ്റ്വെയറാണ് web browser. Google Chrome, 

Internet Explorer, Mozilla Firefox, Opera, Safari   എന്നിവയാണ് browsers.

b) Web browsing:

         വേൾഡ് വൈഡ് വെബിന്റെ വെബ് പേജുകളിലൂടെ സഞ്ചരിക്കുന്നതിനെ വെബ് ബ്രൗസിംഗ് എന്ന് വിളിക്കുന്നു.

2) Search engines

        വേൾഡ് വൈഡ് വെബിൽ ലഭ്യമായ വിവരങ്ങൾ കണ്ടെത്താൻ ആളുകളെ സഹായിക്കുന്നതിന് രൂപകൽപ്പന

      ചെയ്തിട്ടുള്ള പ്രത്യേക പ്രോഗ്രാമുകളാണ് ഇന്റർനെറ്റ് സെർച്ച് എഞ്ചിൻ വെബ്‌സൈറ്റുകൾ.

        സെർച്ച് എഞ്ചിൻ പ്രോഗ്രാമുകൾ നിർദ്ദിഷ്ട കീവേഡുകൾക്കായി വേൾഡ് വൈഡ് വെബിൽ ലഭ്യമായ

documents തിരയുന്നു.

  കീവേഡുകളുമായി പൊരുത്തപ്പെടുന്ന documents /      വെബ് പേജുകളുടെ ഒരു ലിസ്റ്റ് ഇത് നൽകുന്നു. 

Google, Bing, Yahoo Search, Ask     തുടങ്ങിയവയാണ് വെബ് സെർച്ച് എഞ്ചിൻസൈറ്റുകൾ.

3) E-Mail

       ഇന്റർനെറ്റിലൂടെ കമ്പ്യൂട്ടറുകൾക്കിടയിൽ ഡിജിറ്റൽ സന്ദേശങ്ങൾകൈമാറുന്നതിനുള്ള ഒരു രീതിയാണ്

   ഇലക്ട്രോണിക് മെയിൽഅല്ലെങ്കിൽ ഇ-മെയിൽ.

Sections of an e-mail -To  (Recepient Address) ,Cc (Carbon copy),Bcc (Blind carbon 

copy) ,Subject ,Content 

Advantages of using e-mail - വേഗത,  ഉപയോഗിക്കാൻ എളുപ്പമാണ്,  അറ്റാച്ചുമെന്റുകൾ നൽകുന്നത്,

 പരിസ്ഥിതി സൗഹാർദ്ദം,  ഒരു ഇ-  മെയിലിന് മറുപടി,  ചെലവ് കുറഞ്ഞത്,   എപ്പോൾ വേണമെങ്കിലും ലഭ്യമാണ്

Disadvantages of using e-mail- വൈറസുകൾ,    ജങ്ക് മെയിലുകൾഎന്നിവ
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4) Social media

       വ്യക്തികൾക്കും കമ്മ്യൂണിറ്റികൾക്കും ഉള്ളടക്കം സൃഷ്ടിക്കാനും പങ്കിടാനും ചർച്ച ചെയ്യാനും പരിഷ്ക്കരിക്കാനും

 കഴിയുന്ന മൊബൈൽ,       വെബ് അധിഷ്ഠിത സാങ്കേതികവിദ്യകളുടെ ഉപയോഗത്തെ സോഷ്യൽ മീഡിയ

സൂചിപ്പിക്കുന്നു.

Classification of social media.

a) Internet forums –     പോസ്റ്റുചെയ്‌ത സന്ദേശങ്ങളുടെ രൂപത്തിൽ‌ആളുകൾ‌ക്ക്

      സംഭാഷണങ്ങളിൽ‌ഏർ‌പ്പെടാൻ‌കഴിയുന്ന ഒരുഓൺലൈൻ ചർച്ചാ വെബ്‌സൈറ്റാണിത്.

e.g.  Ubuntu Forum.

b) Social blogs –        പ്രദർശിപ്പിച്ച എൻ‌ട്രികളോ പോസ്റ്റുകളോ അടങ്ങുന്ന ഒരു ചർച്ചഅല്ലെങ്കിൽ

 വിവര വെബ്‌സൈറ്റാണിത്.   e.g. Blogger.com and Wordpress.com

c) Microblogs -       ഹ്രസ്വ വാചകങ്ങളോ വ്യക്തിഗത ചിത്രങ്ങളോ വീഡിയോ ലിങ്കുകളോ കൈമാറാൻ

  മൈക്രോബ്ലോഗുകൾ ഉപയോക്താക്കളെ അനുവദിക്കുന്നു.  e.g. Twitter.com

d) Wikis -   ഒരു കമ്മ്യൂണിറ്റി document       രൂപീകരിക്കുന്നതിന് ഒരു വെബ് പേജിൽ ഉള്ളടക്കം

      ചേർക്കാനോ നിലവിലുള്ള വിവരങ്ങൾഎഡിറ്റുചെയ്യാനോ വിക്കികൾആളുകളെ അനുവദിക്കുന്നു.  

e.g. wikipedia.org

e) Social networks-       സോഷ്യൽ നെറ്റ്വർക്കിംഗ് സൈറ്റുകൾആളുകളെ വ്യക്തിഗത വെബ്

       പേജുകൾ നിർമ്മിക്കാനും തുടർന്ന് ആശയവിനിമയം നടത്താനും ഉള്ളടക്കം പങ്കിടാനും

  ചങ്ങാതിമാരുമായി ബന്ധപ്പെടാനും അനുവദിക്കുന്നു.   e.g. facebook.com and linkedin.com.

f) Content communities -ഫോട്ടോകൾ,   വീഡിയോകൾ മുതലായവ

    ഓർഗനൈസുചെയ്യുകയും പങ്കിടുകയും ചെയ്യുന്ന വെബ്‌സൈറ്റുകളാണ് contentകമ്മ്യൂണിറ്റികൾ.  

e.g. Youtube.com

Advantages of social media 

  ആളുകളെ ഒരുമിച്ച് കൊണ്ടുവരിക,    ഇവന്റുകൾ ആസൂത്രണം ചെയ്യുക,  ഓർഗനൈസുചെയ്യുക,  ബിസിനസ്

പ്രമോഷൻ,  സാമൂഹിക കഴിവുകൾ

Limitations in use of social media

 സ്വകാര്യതയിലേക്കുള്ളകടന്നുകയറ്റം, ആസക്തി,  പ്രചരിക്കുന്ന കിംവദന്തികൾ
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 സൈബർസുരക്ഷ

         വിലപ്പെട്ട വിവരങ്ങളുടെ സംരക്ഷണം നൽകാൻ ഇത് ഉപയോഗിക്കുന്നുഅനധികൃതആക്‌സസ്സിൽ നിന്നുള്ള

   ക്രെഡിറ്റ് കാർഡ് വിവരങ്ങൾ പോലെ.

1.  കമ്പ്യൂട്ടർ വൈറസ്

         ഒരു കമ്പ്യൂട്ടർ സിസ്റ്റത്തിന്റെ പതിവ് പ്രവർത്തനത്തെതകരാറിലാക്കുന്ന ഒരു മോശം പ്രോഗ്രാമാണ് വൈറസ്.

2. വേം

         മറ്റ് കമ്പ്യൂട്ടറുകളിലേക്ക് വ്യാപിക്കുന്നതിനായി സ്വയംആവർത്തിക്കുന്ന ഒരുസ്റ്റാൻഡ് എലോൺ മാൽവെയർ

പ്രോഗ്രാമാണിത്.

3.  ട്രോജൻ ഹോർസ്

     ഇത് ഒരു ഉപയോഗപ്രദമായ സോഫ്‌റ്റ്‌വെയർആയി കാണപ്പെടുന്നു,    പക്ഷേ ഇത് ഹാനികരമായ

സോഫ്‌റ്റ്‌വെയറാണ്,     ഇത് ഉപയോഗപ്രദമായ സോഫ്‌റ്റ്‌വെയറുകളോ ഫയലുകളോ ഇല്ലാതാക്കും.

4. സ്പാമുകൾ

         ഒരു ഉൽപ്പന്നമോ സേവനമോ പ്രൊമോട്ട് ചെയ്യുന്നതിന് സ്വീകർത്താക്കളുടെ സമ്മതമില്ലാതെ ഒരു ഇമെയിൽ

   അയയ്ക്കുന്നതിനെ സ്പാമിംഗ് എന്ന് വിളിക്കുന്നു.     അത്തരമൊരു ഇമെയിലിനെ സ്പാം എന്ന് വിളിക്കുന്നു.

5. ഹാക്കിംഗ്

    കംപ്യൂട്ടർ ശൃംഖലകളിൽ അതിക്രമിച്ചു കടക്കുന്ന പ്രക്രിയയാണിത്.

6. ഫിഷിംഗ്

   അംഗീകൃത വെബ്‌സൈറ്റായി പ്രവർത്തിച്ച് ഉപയോക്തൃനാമം, പാസ്‌വേഡ്,  ബാങ്ക് a/c വിശദാംശങ്ങൾ... 

    തുടങ്ങിയ മറ്റ് വിവരങ്ങൾ നേടാനുള്ളശ്രമമാണിത്.

7.    ഡിനൈൽഓഫ് സർവീസ് അറ്റക്ക്

    ഈആക്രമണം കാരണം കമ്പ്യൂട്ടർ restart  ചെയ്യൻ നിർബന്ധിതരായി,   ഇത് യഥാർത്ഥ

  ഉപയോക്താക്കൾക്ക് സേവനം നിരസിച്ചു.

8.       മാൻ ഇൻ ദി മിഡിൽഅറ്റക്ക്

      അയയ്‌ക്കുന്നയാൾസ്വീകർത്താവിന് അയയ്‌ക്കുന്ന ഇലക്ട്രോണിക് സന്ദേശങ്ങൾആക്രമണകാരി

       രഹസ്യമായി തടസ്സപ്പെടുത്തുകയും സന്ദേശങ്ങൾ പരിഷ്‌ക്കരിക്കുകയും സ്വീകർത്താവിന് വീണ്ടും കൈമാറുകയും

  ചെയ്യുന്ന ഒരുആക്രമണമാണിത്.
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   നെറ്റ്‌വർക്ക് ആക്രമണങ്ങൾ തടയുന്ന മാർഗങ്ങൾ

1. ഫയർവാൾ

   ഡാറ്റ വിശകലനം ചെയ്തുകൊണ്ട് ഇൻകമിംഗ്,      ഔട്ട്‌ഗോയിംഗ് നെറ്റ്‌വർക്ക് ട്രാഫിക് നിയന്ത്രിക്കുകയും മറ്റ്

          നെറ്റ്‌വർക്കിൽ നിന്ന് ഒരുസ്ഥാപനത്തിലെ കമ്പ്യൂട്ടർ നെറ്റ്‌വർക്കുകൾക്ക് സുരക്ഷ നൽകുകയും ചെയ്യുന്ന ഒരു

സംവിധാനമാണിത്.

2.  ആന്റിവൈറസ് സ്കാനർ

വൈറസുകൾ,  വേം ,         ട്രോജൻ ഹോർസ് എന്നിവയ്ക്കായി കമ്പ്യൂട്ടർ ഫയലുകൾസ്കാൻ ചെയ്യുന്നതിനും

     രോഗബാധിതമായ സിസ്റ്റത്തെസുഖപ്പെടുത്തുന്നതിനും ഉപയോഗിക്കുന്ന ഒരു ഉപകരണമാണിത്.

3. കുക്കീസ്

         ഞങ്ങളുടെ വിശദാംശങ്ങൾ ട്രാക്ക് ചെയ്യുന്ന ഒരു വെബ്സൈറ്റ് സന്ദർശിക്കുമ്പോൾസൃഷ്ടിക്കപ്പെടുന്ന ചെറിയ

  ടെക്സ്റ്റ് ഫയലുകളാണ് കുക്കികൾ.

 മാതൃക ചോദ്യങ്ങൾ 

1.     ഇന്റർനെറ്റ് വൈവിധ്യമാർന്ന സേവനങ്ങൾ വാഗ്ദാനം ചെയ്യുന്നു,          മാത്രമല്ലഅവ ലോകമെമ്പാടും

 വ്യാപകമായി ഉപയോഗിക്കപ്പെടുന്നു.

a)   ഈസേവനങ്ങളിലൊന്നിൽ travel23@gmail.com   പോലുള്ള വിലാസംആവശ്യമാണ്.  ഈ

  സേവനത്തിന് പേര് നൽകുക.      ഈസേവനത്തിന്റെ വ്യാപകമായ ഉപയോഗത്തിനുള്ള കാരണങ്ങൾഎഴുതുക.

b)           ഒരു വാക്ക് അല്ലെങ്കിൽ ഒരു വാക്യത്തെക്കുറിച്ചുള്ള വിവരങ്ങൾഅടങ്ങിയ വെബ്‌സൈറ്റുകളുടെ ഒരു ലിസ്റ്റ്

   നൽകുന്ന സേവനത്തിന് പേര് നൽകുക

2.   താഴെ പറയുന്നവ നിർവചിക്കുക:

a)          ഫിഷിങ് b) ഹാക്കിങ്

3.      സോഷ്യൽ മീഡിയ ഉപയോഗിക്കുന്നതിൽ രണ്ട് പോരായ്മകൾഎഴുതുക.
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CHAPTER 10

   വിവര സാങ്കേതിക വിദ്യയുടെ ഉപയോഗം

ഇ-ഗവേണൻസ്

      സർക്കാർഅവരുടെ സേവനങ്ങൾ ജനങ്ങൾക്ക് നൽകുന്നതിന് ഇന്റർനെറ്റ്,  ആശയവിനിമയ

 സാങ്കേതികവിദ്യയും ഉപയോഗിക്കുന്നു

ഇ-   ഗവേണൻസിലെ ഇടപെടലുകളുടെ തരങ്ങൾ

1) Government to Government (G2G)

       ഗവൺമെന്റ് ഡിപ്പാർട്ട്‌മെന്റുകൾഅല്ലെങ്കിൽ ഓർഗനൈസേഷനുകൾ തമ്മിലുള്ളഡാറ്റയോ വിവരങ്ങളോ

 പങ്കിടലാണ് ഇത്.

2) Government to Citizens (G2C)

      ഇത് സർക്കാരിനും പൗരന്മാർക്കും ഇടയിൽ ഒരു ഇന്റർഫേസ് സൃഷ്ടിക്കുന്നു.    ഇവിടെ പൗരന്മാർക്ക് ധാരാളം

  പൊതുസേവനങ്ങൾ ആസ്വദിക്കുന്നു.

3) Government to Business (G2B)

     ഐസിടി ടൂളുകൾ ഉപയോഗിച്ച് ബിസിനസുകാർക്ക് സർക്കാരുമായി സംവദിക്കാം.

4) Government to Employee (G2E)

      തങ്ങളുടെ ജീവനക്കാരുമായുള്ളആശയവിനിമയത്തിനായി സർക്കാർ വിവരങ്ങളുംആശയവിനിമയ

 ഉപകരണങ്ങളും ഉപയോഗിക്കുന്നു.

ഇ-  ഗവേണൻസ് ഇൻഫ്രാസ്ട്രക്ചർ

1.    സ്റ്റേറ്റ് ഡാറ്റ സെന്റർ (SDC)

       പൗരന്മാർക്ക് ഓൺലൈൻ സേവനങ്ങൾ നൽകുന്നതിനും സംസ്ഥാനത്തിന്റെ കേന്ദ്രഡാറ്റാബേസ്

    സൂക്ഷിക്കുന്നതിനും ഡാറ്റ സംഭരണം സുരക്ഷിതമാക്കുന്നതിനും ഉത്തരവാദിത്തമുണ്ട്.

2.      കേരള സ്റ്റേറ്റ് വൈഡ് ഏരിയ നെറ്റ്‌വർക്ക് (KSWAN)

ഇ-     ഗവേണൻസ് ഇൻഫ്രാസ്ട്രക്ചറിന്റെ നട്ടെല്ലായി ഇത് പ്രവർത്തിക്കുന്നു

 ഇത് തിരുവനന്തപുരം, കൊച്ചി,      കോഴിക്കോട് എന്നിവയെഅതിന്റെ കേന്ദ്രങ്ങളായി ബന്ധിപ്പിക്കുകയും 152 
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   ബ്ലോക്ക് പഞ്ചായത്തുകളെ ബന്ധിപ്പിക്കുന്ന 14   ജില്ലകളിലേക്കും വ്യാപിക്കുകയും ചെയ്യുന്നു.

3.    പൊതു സേവന കേന്ദ്രങ്ങൾ (CSC)

 ഗ്രാമപ്രദേശങ്ങൾക്കുള്ളഇ-      ഗവേണൻസ് സേവനങ്ങളുടെ ഫ്രണ്ട് എൻഡ് ഡെലിവറി പോയിന്റാണിത്.

വൈദ്യുതി, ടെലിഫോൺ,  വാട്ടർ ബില്ലുകൾ,      ഓൺലൈൻഅപേക്ഷകൾസമർപ്പിക്കൽ തുടങ്ങിയ യൂട്ടിലിറ്റി

  പേയ്‌മെന്റുകളിൽ ഇത് സഹായിക്കുന്നു.

Eg:  അക്ഷയ കേന്ദ്രങ്ങൾ

ഇ-ബിസിനസ്

       വിവരസാങ്കേതികവിദ്യയുടെ സഹായത്തോടെ ബിസിനസ്സ് വിവരങ്ങൾ പങ്കുവയ്ക്കലും ബിസിനസ് ബന്ധങ്ങൾ

    നിലനിർത്തലും ബിസിനസ് ഇടപാടുകൾ നടത്തലുംആണ്.

1. ഇ-  കൊമേഴ്‌സും ഇ-ബിസിനസും

ഇ-       കൊമേഴ്‌സ് പണം കൈമാറ്റം ചെയ്യുന്നബിസിനസ്സ് ഇടപാടുകൾ ഉൾക്കൊള്ളുന്നു

ഇ-  ബിസിനസിൽ മാർക്കറ്റിംഗ്,       അസംസ്‌കൃതമായി നേടൽ തുടങ്ങിയ ബിസിനസ്സ് നടത്തുന്നതിന്റെ എല്ലാ

    വശങ്ങളും ഉൾപ്പെടുന്നുസാമഗ്രികൾഅല്ലെങ്കിൽ സാധനങ്ങൾ,  ഉപഭോക്തൃ വിദ്യാഭ്യാസം,  വിതരണക്കാരെ

 തിരയുക തുടങ്ങിയവ.

2.    ഇലക്ട്രോണിക് പേയ്മെന്റ് സിസ്റ്റം (ഇപിഎസ്)

        ഒരു ഓൺലൈൻ പരിതസ്ഥിതിയിൽ വാങ്ങുന്നവരും വിൽക്കുന്നവരും തമ്മിലുള്ളസാമ്പത്തിക വിനിമയ

 സംവിധാനമാണ് EPS  എന്ന് വിളിക്കുന്നു

ക്രെഡിറ്റ്/  ഡെബിറ്റ് കാർഡ്,        ഇലക്ട്രോണിക് ചെക്ക് അല്ലെങ്കിൽഡിജിറ്റൽ പണം എന്നിവ ഉപയോഗിച്ചാണ്

  സാമ്പത്തികകൈമാറ്റം നടത്തുന്നത്

3. ഇ-ബാങ്കിംഗ്

        ഇലക്ട്രോണിക് ചാനലുകൾ വഴി ഉപഭോക്താക്കൾക്ക് നേരിട്ട് ബാങ്കിംഗ് സേവനങ്ങളുടെ ഓട്ടോമേറ്റഡ്

ഡെലിവറിയാണിത്.

ഇ-  ബിസിനസിന്റെ നേട്ടം

   ഇത് ഭൂമിശാസ്ത്രപരമായ പരിമിതികളെ മറികടക്കുന്നു

  പ്രവർത്തന ചെലവ് കുറയ്ക്കുന്നു

    ഇത് യാത്രാ സമയവും ചെലവും കുറയ്ക്കുന്നു

  അത് എല്ലായ്‌പ്പോഴും തുറന്നിരിക്കും
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       ചോയ്‌സിന്റെ വിശാലമായ ശ്രേണിയിൽ നിന്ന് ഞങ്ങൾക്ക് ഉൽപ്പന്നം വേഗത്തിൽ കണ്ടെത്താനാകും

ഇ-  ബിസിനസിനുള്ള വെല്ലുവിളികൾ

ഇ-    ബിസിനസ്സിനെക്കുറിച്ചും അതിന്റെ സാധ്യതകളെക്കുറിച്ചും അറിവില്ലായ്മ

     ഗ്രാമീണ ജനതയ്ക്ക് പ്ലാസ്റ്റിക് പണം ഇല്ല -  ക്രെഡിറ്റ് കാർഡ്,  ഡെബിറ്റ് കാർഡ്,   നെറ്റ് ബാങ്കിംഗ് സംവിധാനം

 ജാഗ്രതയോടെ ഉപയോഗിച്ചില്ലെങ്കിൽ,     ഉപഭോക്താക്കൾക്ക് അവരുടെ ക്രെഡിറ്റ് കാർഡ് നമ്പർ, 

    പാസ്‌വേഡുകൾ മുതലായ വിലപ്പെട്ട വിവരങ്ങൾ നഷ്ടമായേക്കാം.

  ‘   ’ ഉപഭോക്താക്കൾക്ക്ഈ ടച്ച്ആൻഡ് ഫീൽ ഗുണമില്ല

   കാര്യക്ഷമമായ ഷിപ്പിംഗ് സൗകര്യം ആവശ്യമാണ്

ഇ-ലേണിംഗ്

     വിദ്യാഭ്യാസത്തിൽ ഇലക്ട്രോണിക് മീഡിയയുടെയുംഐടിയുടെയും ഉപയോഗത്തെഇ-   ലേണിംഗ് എന്ന്

വിളിക്കുന്നു.

ഇ-  ലേണിംഗ് ഉപകരണങ്ങൾ

1.    ഇലക്ട്രോണിക്സ് ബുക്ക് റീഡർ (ഇ-ബുക്കുകൾ)

         കമ്മ്യൂണിക്കേഷൻ ഇന്റർഫേസുകൾ വഴി ഡിജിറ്റൽ ബുക്ക് ഉള്ളടക്കം ലോഡുചെയ്‌ത പോർട്ടബിൾ കമ്പ്യൂട്ടർ

     ഉപകരണങ്ങളെ ഇലക്ട്രോണിക് ബുക്ക് റീഡർ എന്ന് വിളിക്കുന്നു

2. ഇ- ടെക്സ്റ്റ്

     ഇലക്ട്രോണിക് ഫോർമാറ്റിൽ ലഭ്യമായ വാചക വിവരങ്ങളെ ഇ-   ടെക്സ്റ്റ് എന്ന് വിളിക്കുന്നു

3.  ഓൺലൈൻ ചാറ്റ്

        ഇന്റർനെറ്റിലൂടെ രണ്ടോ അതിലധികമോ വ്യക്തികൾ തമ്മിലുള്ള വാചകസന്ദേശങ്ങളുടെ തത്സമയ

കൈമാറ്റമാണിത്

4. ഇ-കണ്ടന്റ്

വീഡിയോകൾ, അവതരണങ്ങൾ, ആനിമേഷനുകൾ,   ഗ്രാഫിക്സ് തുടങ്ങിയ ഇ-   ലേണിംഗ് മെറ്റീരിയലുകളെ e-

content  എന്ന് വിളിക്കുന്നു.

5.   വിദ്യാഭ്യാസ ടിവി ചാനലുകൾ

   ഈടെലിവിഷൻ ചാനലുകൾ ഇ-   ലേണിംഗ് ഉദ്ദേശ്യത്തിനായി സമർപ്പിച്ചിരിക്കുന്നു

      ഈചാനലുകൾ വിവിധ വിഷയങ്ങളിൽ റെക്കോർഡ് ചെയ്ത ക്ലാസുകൾ,  വിദഗ്ധരുമായുള്ളഅഭിമുഖങ്ങൾ, 
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    ലാബ് പരീക്ഷണങ്ങൾ തുടങ്ങിയവസംപ്രേക്ഷണം ചെയ്യുന്നു.

ഇ-  ലേണിംഗിന്റെ പ്രയോജനങ്ങൾ

         വിദൂരസ്ഥലങ്ങളിൽ നിന്നുള്ള ധാരാളം വിദ്യാർത്ഥികൾക്ക് വിവിധ വിഷയങ്ങളിൽ കോഴ്സുകൾ വാഗ്ദാനം

  ചെയ്യാൻ ഇതിന് കഴിയും.

  പഠനച്ചെലവ് വളരെ കുറവാണ്

       വിദ്യാർത്ഥികൾക്ക് ദേശീയമായും അന്തർദ്ദേശീയമായും പ്രശസ്തമായ വിവിധസ്ഥാപനങ്ങളിൽ നിന്ന്

   ഓൺലൈൻ കോഴ്സുകൾ ചെയ്യാൻ കഴിയും.

ഇ-     പഠനത്തിന് സമയവുംസ്ഥലവും ഒരു തടസ്സമല്ല.

ഇ-  ലേണിംഗിനുള്ള വെല്ലുവിളികൾ

     വിദ്യാർത്ഥികളും അധ്യാപകരും തമ്മിൽ മുഖാമുഖ സമ്പർക്കം സാധ്യമല്ല.

    അധ്യാപകരും വിദ്യാർത്ഥികളും തമ്മിലുള്ള പരിമിതമായ ഇടപെടൽ

ഇ-        ലേണിംഗിന് കമ്പ്യൂട്ടറുകളോ സമാനമായ ഏതെങ്കിലും തരത്തിലുള്ള ഉപകരണങ്ങളോ ഉയർന്ന

  വേഗതയുള്ളഇന്റർനെറ്റോ ആവശ്യമാണ്

   വിദ്യാർത്ഥികൾക്ക് വ്യക്തിഗതശ്രദ്ധ ലഭിക്കില്ല

   യഥാർത്ഥ ലബോറട്ടറി സാഹചര്യത്തിൽ ഹാൻഡ്-   ഓൺപ്രാക്ടിക്കലും ഇ-   ലേണിംഗിൽ ഒരു പരിമിതിയാണ്.

   ആരോഗ്യ സംരക്ഷണത്തിൽഐസിടി ആപ്ലിക്കേഷൻ

 മെഡിക്കൽ ഉപകരണങ്ങൾ: ECG, ECHO ടെസ്റ്റ്, TMT, CT     സ്കാനർ തുടങ്ങിയ മിക്ക മെഡിക്കൽ

   ഉപകരണങ്ങളും കമ്പ്യൂട്ടറുകളുടെ സഹായത്തോടെ പ്രവർത്തിക്കുന്നു.

   ഇലക്‌ട്രോണിക് മെഡിക്കൽ റെക്കോർഡ് (EMR):       ഒരു പ്രാക്ടീസിൽ നിന്ന് രോഗിയുടെ എല്ലാ മെഡിക്കൽ

     ചരിത്രവും അടങ്ങുന്ന പേപ്പർ ചാർട്ടിന്റെ ഡിജിറ്റൽ പതിപ്പാണിത്.

  വെബ് അധിഷ്‌ഠിത പിന്തുണ:       രോഗങ്ങളാൽ ബുദ്ധിമുട്ടുന്ന രോഗികൾക്ക് രോഗനിർണയം നടത്താനും ചികിത്സ

     നൽകാനും വിവരങ്ങൾ നേടുന്നതിന് ഡോക്ടർമാർ ഇന്റർനെറ്റ് ഉപയോഗിക്കുന്നു.

ടെലിമെഡിസിൻ: ടെലി-      മെഡിസിൻ ഉപകരണങ്ങളുടെ സഹായത്തോടെ ഡോക്ടർമാർക്കും നഴ്‌സുമാർക്കും

       രോഗികളുടെ അവസ്ഥനിരീക്ഷിച്ചുകൊണ്ട് വിദൂരസ്ഥലങ്ങളിൽ രോഗികളെ പരിശോധിക്കാൻ കഴിയും.  ഒരു

വിജയഭേരി എഡ്യൂക്കേഷണൽ പ്രൊജക്റ്റ്, ജില്ലാ പഞ്ചായത്ത് മലപ്പുറം                                                                             75

Join Telegram Channel: https://t.me/hsslive Downloaded from www.Hsslive.in ®



   ടെലിഫോണും കമ്പ്യൂട്ടറും ഉപയോഗിച്ചാണ്

 ഗവേഷണവും വികസനവും:  വിവിധ ഗവേഷണ-     വികസന മേഖലകളിൽ കമ്പ്യൂട്ടറുകളുടെ പങ്ക്

ഒഴിച്ചുകൂടാനാവാത്തതാണ്.

ICT  പ്രാപ്തമാക്കിയ സേവനങ്ങൾ

   ബിസിനസ് പ്രോസസ് ഔട്ട്‌സോഴ്‌സിംഗ് (ബിപിഒ):     നിർദ്ദിഷ്ട ബിസിനസ് ഫംഗ്‌ഷനുകളുടെ പ്രവർത്തനങ്ങളും

        ഉത്തരവാദിത്തങ്ങളും ചെയ്യാൻ ഒരു മൂന്നാം കക്ഷി സേവന ദാതാവിനെ നിയമിക്കുന്ന പ്രക്രിയ. ജീവനക്കാരെയും

       ആസ്തികളെയും ഒരുസ്ഥാപനത്തിൽ നിന്ന് മറ്റൊന്നിലേക്ക് മാറ്റുന്നതും ഇതിൽ ഉൾപ്പെട്ടേക്കാം.  ഇത്

     സേവനങ്ങളിലെ കാര്യക്ഷമത വർദ്ധിപ്പിക്കുകയും ചെലവ് ലാഭിക്കുകയും ചെയ്യുന്നു.

Eg. Costumer care service.

   നോളജ് പ്രോസസ് ഔട്ട്‌സോഴ്‌സിംഗ് (കെ‌പി‌ഒ):     വിജ്ഞാനവും വിവരവുമായി ബന്ധപ്പെട്ട ജോലികൾ

     ഓർഗനൈസേഷനിലെ വിവിധ കമ്പനികളും അല്ലെങ്കിൽസബ്‌സിഡിയറികളും നിർവഹിക്കുന്നു.  ഡാറ്റാ

തിരയൽ,  ഡാറ്റ സംയോജനം,     മാർക്കറ്റ് തിരയൽ തുടങ്ങിയവ ഇതിൽ ഉൾപ്പെടുന്നു.

 കോൾ സെന്റർ:    ഒരു കോൾ സെന്റർ (  സർവീസ് സെന്റർ,  സെയിൽസ് സെന്റർ,   കോൺടാക്റ്റ് സെന്റർ

  മുതലായവ എന്നുംഅറിയപ്പെടുന്നു..)     ഒരുസ്ഥാപനത്തിന്റെ വിവിധ ഉത്തരവാദിത്തങ്ങളെ

  പിന്തുണയ്ക്കുന്നതിനായി ധാരാളം ഇൻകമിംഗ്,     ഔട്ട്ഗോയിംഗ് കോളുകൾകൈകാര്യം ചെയ്യുന്നതിനായി

    സജ്ജീകരിച്ചിട്ടുള്ള ഒരു ടെലിഫോൺ സേവനസൗകര്യമാണ്.

ടെലികോൺഫറൻസിംഗ്:         ഐടി ഇൻഫ്രാഘടനയും സേവനങ്ങളും ഉപയോഗിച്ച് വിദൂരസ്ഥലങ്ങളിൽ രണ്ടോ

        അതിലധികമോ പാർട്ടികൾ തമ്മിൽ നടത്തുന്ന മീറ്റിംഗോ കോൺഫറൻസോആണ് ടെലി

കോൺഫറൻസിംഗ്.

 വീഡിയോ കോൺഫറൻസിംഗ്:       വീഡിയോ കോൺഫറൻസിംഗ് എന്നത് ഒരു തരം ടെലി കോൺഫറൻസിംഗ്

ആണ്,      അതിൽ കോൺഫറൻസിൽ ഉൾപ്പെട്ട കക്ഷികളുടെ വീഡിയോയും ഉൾപ്പെടുത്തിയിട്ടുണ്ട്.  ഒരു

     വീഡിയോ ക്യാമറയും മൈക്രോഫോണുംആശയവിനിമയ സംവിധാനവും ആവശ്യമാണ്.

 മാതൃക ചോദ്യങ്ങൾ

വിജയഭേരി എഡ്യൂക്കേഷണൽ പ്രൊജക്റ്റ്, ജില്ലാ പഞ്ചായത്ത് മലപ്പുറം                                                                             76

Join Telegram Channel: https://t.me/hsslive Downloaded from www.Hsslive.in ®



1. ഇ-      ഗവേണൻസ് നടപ്പിലാക്കുന്നതിനുള്ളഏതെങ്കിലും രണ്ട് വെല്ലുവിളികൾ എഴുതുക.

2.  പരമ്പരാഗതഅധ്യാപന-      പഠന പ്രക്രിയയുടെ പല പരിമിതികളും മറികടക്കാൻ ഇ-   ലേണിംഗ് നമ്മെ

അനുവദിക്കുന്നു.

a) ഇ-      ലേണിംഗ് പ്രോസസ് വർദ്ധിപ്പിക്കുന്നതിന് ഏതെങ്കിലും മൂന്ന് ഇ-   ലേണിംഗ് ടൂളുകൾക്ക് പേര്

നൽകുക.

b) ഇ-     ലേണിംഗിന്റെ ഏതെങ്കിലും മൂന്ന് ഗുണങ്ങൾഎഴുതുക.

3. ഇ-      ബിസിനസ് നടപ്പിലാക്കുന്നതിന്റെ ഗുണവും ദോഷവും താരതമ്യം ചെയ്യുക.

4.       മിക്കവാറും എല്ലാ സേവനങ്ങളും ബിസിനസ്സുകളും ഇപ്പോൾ ഓൺലൈനിൽ ലഭ്യമാണ്.

a)       ഇത്തരം സന്ദർഭങ്ങളിൽ വാങ്ങുന്നവരും വിൽക്കുന്നവരും തമ്മിലുള്ള പണമിടപാട്

   സുഗമമാക്കുന്നസംവിധാനത്തിന് പേര് നൽകുക.

b) ഇ-    ഗവേണൻസിന്റെഅടിസ്ഥാനസൗകര്യങ്ങൾ വിശദീകരിക്കുക.

5. ഇ-      ഗവേണൻസിന്റെ ഏതെങ്കിലും രണ്ട് നേട്ടങ്ങൾസംക്ഷിപ്തമായി വിവരിക്കുക.

6.     ടെലികോൺഫറൻസിംഗും വീഡിയോ കോൺഫറൻസിംഗും തമ്മിൽ വേർതിരിച്ചറിയണോ?

7.     ആരോഗ്യ സംരക്ഷണത്തിൽഐസിടിയുടെ പങ്ക് എന്താണ്?

8.    നോളജ് പ്രോസസ് ഔട്ട്സോഴ്സിംഗ് (KPO)   എന്നതുകൊണ്ട് എന്താണ് അർത്ഥമാക്കുന്നത്?
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